summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHeinrich Wendel <lanius@gentoo.org>2004-10-07 15:23:00 +0000
committerHeinrich Wendel <lanius@gentoo.org>2004-10-07 15:23:00 +0000
commit788ccdc0875f64bf62a869d33383174885970e89 (patch)
tree7b9a90d01bb4893f66c99d1adeb9f7fb5e763155 /app-text
parentadd patch to fix crash on accessing empty bookmarks, bug #51253 (diff)
downloadhistorical-788ccdc0875f64bf62a869d33383174885970e89.tar.gz
historical-788ccdc0875f64bf62a869d33383174885970e89.tar.bz2
historical-788ccdc0875f64bf62a869d33383174885970e89.zip
add patch to build with freetype-2.1.7, bug #65831
Diffstat (limited to 'app-text')
-rw-r--r--app-text/xpdf/ChangeLog6
-rw-r--r--app-text/xpdf/Manifest5
-rw-r--r--app-text/xpdf/files/xpdf-3.00-freetype-2.1.7.patch74
-rw-r--r--app-text/xpdf/xpdf-3.00-r2.ebuild3
4 files changed, 84 insertions, 4 deletions
diff --git a/app-text/xpdf/ChangeLog b/app-text/xpdf/ChangeLog
index 3eed477b2723..d5f862cf4dac 100644
--- a/app-text/xpdf/ChangeLog
+++ b/app-text/xpdf/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-text/xpdf
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/xpdf/ChangeLog,v 1.39 2004/10/07 15:19:44 lanius Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/xpdf/ChangeLog,v 1.40 2004/10/07 15:23:00 lanius Exp $
+
+ 07 Oct 2004; Heinrich Wendel <lanius@gentoo.org>
+ +files/xpdf-3.00-freetype-2.1.7.patch, xpdf-3.00-r2.ebuild:
+ add patch to build with freetype-2.1.7, bug #65831
07 Oct 2004; Heinrich Wendel <lanius@gentoo.org>
+files/xpdf-3.00-empty-bookmark.patch, xpdf-3.00-r2.ebuild:
diff --git a/app-text/xpdf/Manifest b/app-text/xpdf/Manifest
index 8bd4106ddb33..7165f100ce57 100644
--- a/app-text/xpdf/Manifest
+++ b/app-text/xpdf/Manifest
@@ -1,9 +1,9 @@
MD5 da4e42aa1b0307c9a605711650025436 xpdf-3.00-r1.ebuild 951
MD5 78e8623c972db9014d5ed698031c9189 xpdf-2.02.1.ebuild 1127
MD5 6077c4fa36327883ebb4aaa2ed20023e xpdf-3.00.ebuild 835
-MD5 330311423c40acfe36b8b9c6cc04cbf1 xpdf-3.00-r2.ebuild 2977
+MD5 5ccae46c0e80018d359020a3663d37ef xpdf-3.00-r2.ebuild 3028
MD5 e72ff64a0feb9484ea01864bd308c13c xpdf-2.03.ebuild 1128
-MD5 b84e42dceab4968d9334da7c3b94bbba ChangeLog 4923
+MD5 66eb715108b7192c44f0c45b7b63a7c9 ChangeLog 5090
MD5 26b4b081d538c195dc39bcb2ec8e6f3a metadata.xml 161
MD5 8221707abac9c48b486b8c2b9bc7a7a0 files/xpdf-3.00-empty-bookmark.patch 373
MD5 263f91efedaa87e4597ab0a83407137d files/xpdfrc.1 1593
@@ -11,6 +11,7 @@ MD5 f200f24c7cfa6061337dc6c0e03f36b9 files/xpdf-3.00-nodrm.diff 1049
MD5 d2fc1b3562bfee9f9c7fb5beaa741084 files/xpdf-3.00-truetype.diff.gz 3288
MD5 87cd94ef77a9e99ca1fac42c32270d39 files/digest-xpdf-2.03 61
MD5 fd6eaa6f4bb5d94506718515cf20ac26 files/digest-xpdf-3.00 61
+MD5 1ca86139c360680d756c771b7c6c8647 files/xpdf-3.00-freetype-2.1.7.patch 2743
MD5 7c0787e730fecfb5b6ebc5a7a69cd64e files/xpdfrc 1092
MD5 5b8ecf36053280853d55ea04143da297 files/digest-xpdf-2.02.1 64
MD5 fd6eaa6f4bb5d94506718515cf20ac26 files/digest-xpdf-3.00-r1 61
diff --git a/app-text/xpdf/files/xpdf-3.00-freetype-2.1.7.patch b/app-text/xpdf/files/xpdf-3.00-freetype-2.1.7.patch
new file mode 100644
index 000000000000..b6f789516ebc
--- /dev/null
+++ b/app-text/xpdf/files/xpdf-3.00-freetype-2.1.7.patch
@@ -0,0 +1,74 @@
+diff -Naur xpdf-3.00/configure.in xpdf-3.00.new/configure.in
+--- xpdf-3.00/configure.in 2004-01-22 02:26:44.000000000 +0100
++++ xpdf-3.00.new/configure.in 2004-09-29 19:27:16.089925504 +0200
+@@ -306,10 +306,13 @@
+ dnl ##### (Note: FT_Get_Name_Index was added in FT 2.0.5, and is
+ dnl ##### the reason that Xpdf requires 2.0.5+.)
+ smr_CHECK_LIB(freetype2, freetype, [FreeType2 font rasterizer - version 2.0.5+],
+- FT_Get_Name_Index, freetype/freetype.h, -lm)
++ FT_Get_Name_Index, freetype/ft2build.h, -lm)
+ if test x"$freetype2_LIBS" = x; then
+ smr_CHECK_LIB(freetype2, freetype, [FreeType2 font rasterizer - version 2.0.5+],
+- FT_Get_Name_Index, freetype.h, -lm)
++ FT_Get_Name_Index, ft2build.h, -lm)
++ if test "x$smr_have_freetype2_library" = xyes; then
++ AC_DEFINE(HAVE_FREETYPE_H)
++ fi
+ fi
+ AC_SUBST(freetype2_LIBS)
+ AC_SUBST(freetype2_CFLAGS)
+diff -Naur xpdf-3.00/splash/SplashFTFont.cc xpdf-3.00.new/splash/SplashFTFont.cc
+--- xpdf-3.00/splash/SplashFTFont.cc 2004-01-22 02:26:44.000000000 +0100
++++ xpdf-3.00.new/splash/SplashFTFont.cc 2004-09-29 19:27:46.527298320 +0200
+@@ -12,8 +12,10 @@
+ #pragma implementation
+ #endif
+
+-#include "freetype/ftoutln.h"
+-#include "freetype/internal/ftobjs.h" // needed for FT_New_Size decl
++#include <ft2build.h>
++#include FT_OUTLINE_H
++#include FT_GLYPH_H
++#include FT_SIZES_H // needed for FT_New_Size decl
+ #include "gmem.h"
+ #include "SplashMath.h"
+ #include "SplashGlyphBitmap.h"
+diff -Naur xpdf-3.00/splash/SplashFTFont.h xpdf-3.00.new/splash/SplashFTFont.h
+--- xpdf-3.00/splash/SplashFTFont.h 2004-01-22 02:26:44.000000000 +0100
++++ xpdf-3.00.new/splash/SplashFTFont.h 2004-09-29 19:27:16.091925200 +0200
+@@ -15,7 +15,8 @@
+ #pragma interface
+ #endif
+
+-#include <freetype/freetype.h>
++#include <ft2build.h>
++#include FT_FREETYPE_H
+ #include "SplashFont.h"
+
+ class SplashFTFontFile;
+diff -Naur xpdf-3.00/splash/SplashFTFontEngine.h xpdf-3.00.new/splash/SplashFTFontEngine.h
+--- xpdf-3.00/splash/SplashFTFontEngine.h 2004-01-22 02:26:44.000000000 +0100
++++ xpdf-3.00.new/splash/SplashFTFontEngine.h 2004-09-29 19:27:16.091925200 +0200
+@@ -15,7 +15,8 @@
+ #pragma interface
+ #endif
+
+-#include <freetype/freetype.h>
++#include <ft2build.h>
++#include FT_FREETYPE_H
+ #include "gtypes.h"
+
+ class SplashFontFile;
+diff -Naur xpdf-3.00/splash/SplashFTFontFile.h xpdf-3.00.new/splash/SplashFTFontFile.h
+--- xpdf-3.00/splash/SplashFTFontFile.h 2004-01-22 02:26:44.000000000 +0100
++++ xpdf-3.00.new/splash/SplashFTFontFile.h 2004-09-29 19:27:16.091925200 +0200
+@@ -15,7 +15,8 @@
+ #pragma interface
+ #endif
+
+-#include <freetype/freetype.h>
++#include <ft2build.h>
++#include FT_FREETYPE_H
+ #include "SplashFontFile.h"
+
+ class SplashFontFileID;
diff --git a/app-text/xpdf/xpdf-3.00-r2.ebuild b/app-text/xpdf/xpdf-3.00-r2.ebuild
index 35b0bd63c5dd..30e6eba6827a 100644
--- a/app-text/xpdf/xpdf-3.00-r2.ebuild
+++ b/app-text/xpdf/xpdf-3.00-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/xpdf/xpdf-3.00-r2.ebuild,v 1.4 2004/10/07 15:19:44 lanius Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/xpdf/xpdf-3.00-r2.ebuild,v 1.5 2004/10/07 15:23:00 lanius Exp $
inherit eutils
@@ -50,6 +50,7 @@ src_unpack() {
unpack ${A}
cd ${S}
epatch ${FILESDIR}/xpdf-3.00-truetype.diff.gz
+ epatch ${FILESDIR}/xpdf-3.00-freetype-2.1.7.patch
epatch ${FILESDIR}/xpdf-3.00-empty-bookmark.patch
use nodrm && epatch ${FILESDIR}/xpdf-3.00-nodrm.diff
}