summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthieu Sozeau <mattam@gentoo.org>2005-09-21 21:28:24 +0000
committerMatthieu Sozeau <mattam@gentoo.org>2005-09-21 21:28:24 +0000
commit0c714c08c3d19885d70f35cb94bcbaffe5b0f23e (patch)
tree2d18b03a8b24a7ea980719920e681bbcb3903549 /app-text
parentbug 106772, allow build without X (diff)
downloadhistorical-0c714c08c3d19885d70f35cb94bcbaffe5b0f23e.tar.gz
historical-0c714c08c3d19885d70f35cb94bcbaffe5b0f23e.tar.bz2
historical-0c714c08c3d19885d70f35cb94bcbaffe5b0f23e.zip
Add fix for ocaml-3.08.4.
Package-Manager: portage-2.0.51.22-r1
Diffstat (limited to 'app-text')
-rw-r--r--app-text/active-dvi/Manifest2
-rw-r--r--app-text/active-dvi/active-dvi-1.6.0.ebuild11
2 files changed, 9 insertions, 4 deletions
diff --git a/app-text/active-dvi/Manifest b/app-text/active-dvi/Manifest
index fbf9c503123f..fd4ab570a836 100644
--- a/app-text/active-dvi/Manifest
+++ b/app-text/active-dvi/Manifest
@@ -1,4 +1,4 @@
-MD5 3e9b75143428c95ddb3e75aa2efc8526 active-dvi-1.6.0.ebuild 2578
+MD5 0f2dbb70af9a340dbac78b4335da1bf6 active-dvi-1.6.0.ebuild 2686
MD5 51ed1f25540daca21c6bfe1e88a23c45 active-dvi-1.4.0.ebuild 2467
MD5 627fba2cc6a7d2e94966d9829535a42c ChangeLog 1493
MD5 c472f5fd1646eb8bca71d8df5cb2bdcc metadata.xml 164
diff --git a/app-text/active-dvi/active-dvi-1.6.0.ebuild b/app-text/active-dvi/active-dvi-1.6.0.ebuild
index 5fe711d97a75..c60805ac0a16 100644
--- a/app-text/active-dvi/active-dvi-1.6.0.ebuild
+++ b/app-text/active-dvi/active-dvi-1.6.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/active-dvi/active-dvi-1.6.0.ebuild,v 1.3 2005/03/18 16:49:58 mattam Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/active-dvi/active-dvi-1.6.0.ebuild,v 1.4 2005/09/21 21:28:24 mattam Exp $
inherit eutils
@@ -54,15 +54,20 @@ pkg_setup() {
src_unpack() {
unpack ${A}
+ cd ${S}
# need to remove texhash, it'll cause problems with
# the sandbox if we try and run it during emerge
- sed -i -e "s/texhash//" ${S}/Makefile
+ sed -i -e "s/texhash//" Makefile
+
+ if has_version ">=dev-lang/ocaml-3.08.4"; then
+ sed -i -e "s/resize_window/resize_subwindow/" grY11.c
+ fi
if use cjk ; then
local fp=/usr/X11R6/lib/X11/fonts/truetype
sed -i -e "s%msmincho.ttc%${fp}/kochi-mincho-subst.ttf%g" \
-e "s%msgothic.ttc%${fp}/kochi-gothic-subst.ttf%g" \
- ${S}/conf/jpfonts.conf
+ conf/jpfonts.conf
fi
}