summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarinus Schraal <foser@gentoo.org>2006-11-21 15:53:59 +0000
committerMarinus Schraal <foser@gentoo.org>2006-11-21 15:53:59 +0000
commit29a9507f01e3541965aa321c732f4d625b7e4006 (patch)
tree426aa464cbdce755d8e8062ba6d2c79a143903c3 /app-text/wv
parentTaken maintainership. (diff)
downloadhistorical-29a9507f01e3541965aa321c732f4d625b7e4006.tar.gz
historical-29a9507f01e3541965aa321c732f4d625b7e4006.tar.bz2
historical-29a9507f01e3541965aa321c732f4d625b7e4006.zip
make sure people revdep-rebuild
Package-Manager: portage-2.1.1-r2
Diffstat (limited to 'app-text/wv')
-rw-r--r--app-text/wv/ChangeLog7
-rw-r--r--app-text/wv/files/digest-wv-1.2.3-r13
-rw-r--r--app-text/wv/wv-1.2.3-r1.ebuild51
3 files changed, 60 insertions, 1 deletions
diff --git a/app-text/wv/ChangeLog b/app-text/wv/ChangeLog
index 3ce551e0ef75..5ecbc7ea1f4d 100644
--- a/app-text/wv/ChangeLog
+++ b/app-text/wv/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-text/wv
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/wv/ChangeLog,v 1.40 2006/11/21 14:01:19 foser Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/wv/ChangeLog,v 1.41 2006/11/21 15:53:59 foser Exp $
+
+*wv-1.2.3-r1 (21 Nov 2006)
+
+ 21 Nov 2006; Marinus Schraal <foser@gentoo.org> wv-1.2.3-r1.ebuild :
+ Remove library compatability linking, add revdep rebuild warning (#153800)
*wv-1.2.3 (21 Nov 2006)
diff --git a/app-text/wv/files/digest-wv-1.2.3-r1 b/app-text/wv/files/digest-wv-1.2.3-r1
new file mode 100644
index 000000000000..ada3a120118f
--- /dev/null
+++ b/app-text/wv/files/digest-wv-1.2.3-r1
@@ -0,0 +1,3 @@
+MD5 eaae329d73dc746659a91a2a0ca5ffce wv-1.2.3.tar.gz 629506
+RMD160 4d3bdfb44bb354bafa0c12677a299d94cfb7efe0 wv-1.2.3.tar.gz 629506
+SHA256 30e095bac65a3318cd3ea8616434de606c39dd351c7812a923fdb57f301d533e wv-1.2.3.tar.gz 629506
diff --git a/app-text/wv/wv-1.2.3-r1.ebuild b/app-text/wv/wv-1.2.3-r1.ebuild
new file mode 100644
index 000000000000..119ac7f35350
--- /dev/null
+++ b/app-text/wv/wv-1.2.3-r1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/wv/wv-1.2.3-r1.ebuild,v 1.1 2006/11/21 15:53:59 foser Exp $
+
+inherit eutils
+
+DESCRIPTION="Tool for conversion of MSWord doc and rtf files to something readable"
+SRC_URI="mirror://sourceforge/wvware/${P}.tar.gz"
+HOMEPAGE="http://wvware.sourceforge.net/"
+
+IUSE="wmf"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+SLOT="0"
+LICENSE="GPL-2"
+
+RDEPEND=">=dev-libs/glib-2
+ >=gnome-extra/libgsf-1.13
+ sys-libs/zlib
+ media-libs/libpng
+ dev-libs/libxml2
+ wmf? ( >=media-libs/libwmf-0.2.2 )"
+
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.9"
+
+src_compile() {
+
+ econf `use_with wmf libwmf` || die "./configure failed"
+
+ emake || die "Compilation failed"
+
+}
+
+src_install () {
+
+ make DESTDIR="${D}" install || die "Installation failed"
+
+ dodoc README
+
+ rm -f ${D}/usr/share/man/man1/wvConvert.1
+ dosym /usr/share/man/man1/wvWare.1 /usr/share/man/man1/wvConvert.1
+
+}
+
+pkg_postinst() {
+
+ ewarn "You have to re-emerge packages that linked against wv by running:"
+ ewarn "revdep-rebuild"
+
+}
+