summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Ahlberg <aliz@gentoo.org>2002-07-28 13:23:53 +0000
committerDaniel Ahlberg <aliz@gentoo.org>2002-07-28 13:23:53 +0000
commit1b4da881840f7a44ec2850a52d076b40cb12d3be (patch)
tree60dcffa04220b044ecca7c2af790dec406603c38 /app-text/rfcutil
parentAdded credit for CJK patch (diff)
downloadhistorical-1b4da881840f7a44ec2850a52d076b40cb12d3be.tar.gz
historical-1b4da881840f7a44ec2850a52d076b40cb12d3be.tar.bz2
historical-1b4da881840f7a44ec2850a52d076b40cb12d3be.zip
Intial release.
Diffstat (limited to 'app-text/rfcutil')
-rw-r--r--app-text/rfcutil/ChangeLog9
-rw-r--r--app-text/rfcutil/files/digest-rfcutil-3.2.31
-rw-r--r--app-text/rfcutil/rfcutil-3.2.3.ebuild41
3 files changed, 51 insertions, 0 deletions
diff --git a/app-text/rfcutil/ChangeLog b/app-text/rfcutil/ChangeLog
new file mode 100644
index 000000000000..c44530448ae6
--- /dev/null
+++ b/app-text/rfcutil/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for app-text/rfcutil
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/rfcutil/ChangeLog,v 1.1 2002/07/28 13:23:51 aliz Exp $
+
+*rfcutil-3.2.3 (28 Jul 2002)
+
+ 28 Jul 2002; Daniel Ahlberg <aliz@gentoo.org> rfcutil-3.2.3.ebuild :
+
+ Initial import. Ebuild submitted by Paul Belt <gaarde@yahoo.com>.
diff --git a/app-text/rfcutil/files/digest-rfcutil-3.2.3 b/app-text/rfcutil/files/digest-rfcutil-3.2.3
new file mode 100644
index 000000000000..2fa2c7d213ff
--- /dev/null
+++ b/app-text/rfcutil/files/digest-rfcutil-3.2.3
@@ -0,0 +1 @@
+MD5 d40ed11198b51d4c3e5c316ac81cd146 rfc-3.2.3.tar.gz 10469
diff --git a/app-text/rfcutil/rfcutil-3.2.3.ebuild b/app-text/rfcutil/rfcutil-3.2.3.ebuild
new file mode 100644
index 000000000000..917e42c11400
--- /dev/null
+++ b/app-text/rfcutil/rfcutil-3.2.3.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/rfcutil/rfcutil-3.2.3.ebuild,v 1.1 2002/07/28 13:23:51 aliz Exp $
+
+MY_PN="rfc"
+MY_P="${MY_PN}-${PV}"
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="RFC Util allows you to specify the number of an RFC, or a search
+string, and it returns all related RFCs. It features command line switches to
+spawn lynx or w3m to view the RFC, dump to file for offline viewing, or mail to
+an address. It also allows local and remote lookups of port, service, or proto
+numbers."
+HOMEPAGE="http://www.dewn.com/rfc/"
+SRC_URI="http://www.dewn.com/rfc/${MY_P}.tar.gz"
+
+KEYWORDS="x86"
+SLOT="0"
+LICENSE="as-is"
+
+src_compile() {
+ patch -l -p0 < ${FILESDIR}/${MY_P}.gaarde || die
+}
+
+src_install () {
+ newbin ${MY_P} ${MY_PN}
+ doman ${MY_PN}.1
+ dodoc CHANGELOG INSTALL KNOWN_BUGS README
+ mkdir -p ${D}/var/cache/rfc/
+}
+
+pkg_postinst () {
+ einfo "Generating rfc-index"
+ /usr/bin/rfc -i
+ einfo "Gaarde suggests you make a cron.monthly to run the following:"
+ einfo " /usr/bin/rfc -i"
+}
+
+pkg_prerm () {
+ rm /var/cache/rfc/* -f
+}