summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Schweizer <genstef@gentoo.org>2007-09-04 06:53:53 +0000
committerStefan Schweizer <genstef@gentoo.org>2007-09-04 06:53:53 +0000
commitbb80c2a6fdd62fd9f9cedbcda366430261149e86 (patch)
tree51450aee2cb7a482b9dbf64ae6271e8c8d9c2195 /app-text/poppler-bindings
parentfix previous poppler (diff)
downloadhistorical-bb80c2a6fdd62fd9f9cedbcda366430261149e86.tar.gz
historical-bb80c2a6fdd62fd9f9cedbcda366430261149e86.tar.bz2
historical-bb80c2a6fdd62fd9f9cedbcda366430261149e86.zip
version bump
Package-Manager: portage-2.1.3.7
Diffstat (limited to 'app-text/poppler-bindings')
-rw-r--r--app-text/poppler-bindings/ChangeLog8
-rw-r--r--app-text/poppler-bindings/files/digest-poppler-bindings-0.63
-rw-r--r--app-text/poppler-bindings/poppler-bindings-0.6.ebuild69
3 files changed, 79 insertions, 1 deletions
diff --git a/app-text/poppler-bindings/ChangeLog b/app-text/poppler-bindings/ChangeLog
index 0221532ffef5..e8bbf4dd6942 100644
--- a/app-text/poppler-bindings/ChangeLog
+++ b/app-text/poppler-bindings/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-text/poppler-bindings
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/poppler-bindings/ChangeLog,v 1.66 2007/08/23 06:28:28 genstef Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/poppler-bindings/ChangeLog,v 1.67 2007/09/04 06:53:33 genstef Exp $
+
+*poppler-bindings-0.6 (04 Sep 2007)
+
+ 04 Sep 2007; Stefan Schweizer <genstef@gentoo.org>
+ +poppler-bindings-0.6.ebuild:
+ version bump
*poppler-bindings-0.5.91 (23 Aug 2007)
diff --git a/app-text/poppler-bindings/files/digest-poppler-bindings-0.6 b/app-text/poppler-bindings/files/digest-poppler-bindings-0.6
new file mode 100644
index 000000000000..8d9556383cde
--- /dev/null
+++ b/app-text/poppler-bindings/files/digest-poppler-bindings-0.6
@@ -0,0 +1,3 @@
+MD5 96883867572aa1e55e979ec75369c562 poppler-0.6.tar.gz 1228142
+RMD160 ebdb3d0a38a573dfa2da52949225461dfa882aa9 poppler-0.6.tar.gz 1228142
+SHA256 ef4bb8fd1bb4dffd5dc689509bf3e33260774550425ee78995a8d0297f76bfae poppler-0.6.tar.gz 1228142
diff --git a/app-text/poppler-bindings/poppler-bindings-0.6.ebuild b/app-text/poppler-bindings/poppler-bindings-0.6.ebuild
new file mode 100644
index 000000000000..76173d2a3343
--- /dev/null
+++ b/app-text/poppler-bindings/poppler-bindings-0.6.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/poppler-bindings/poppler-bindings-0.6.ebuild,v 1.1 2007/09/04 06:53:33 genstef Exp $
+
+inherit autotools eutils multilib
+
+MY_P=${P/-bindings/}
+DESCRIPTION="rendering bindings for GUI toolkits for poppler"
+HOMEPAGE="http://poppler.freedesktop.org/"
+SRC_URI="http://poppler.freedesktop.org/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="gtk qt3 cairo qt4"
+
+RDEPEND="~app-text/poppler-${PV}
+ cairo? ( >=x11-libs/cairo-0.5 )
+ gtk? (
+ >=x11-libs/gtk+-2.6
+ >=gnome-base/libglade-2
+ )
+ qt3? ( =x11-libs/qt-3* )
+ qt4? ( =x11-libs/qt-4* )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ >=sys-devel/automake-1.9.6"
+
+S=${WORKDIR}/${MY_P}
+
+src_unpack(){
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/poppler-0.6-bindings.patch
+
+ AT_M4DIR="m4" eautoreconf
+ sed -i s:/usr/lib/qt:/usr/lib/qt4: configure
+}
+
+src_compile() {
+ # Configure needs help finding qt libs on multilib systems
+ export QTLIB="${QTDIR}/$(get_libdir)"
+ echo $QTLIB
+
+ econf --enable-opi \
+ $(use_enable cairo cairo-output) \
+ $(use_enable gtk poppler-glib) \
+ $(use_enable qt3 poppler-qt) \
+ $(use_enable qt4 poppler-qt4) \
+ || die "configuration failed"
+ cd poppler
+ if use cairo; then
+ emake libpoppler-cairo.la || die "cairo failed"
+ fi
+ if use qt4; then
+ emake libpoppler-arthur.la || die "arthur failed"
+ fi
+ cd ..
+ emake || die "compilation failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+}
+
+pkg_postinst() {
+ ewarn "You need to rebuild everything depending on poppler, use revdep-rebuild"
+}