summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarl Trygve Kalleberg <karltk@gentoo.org>2001-11-11 22:10:20 +0000
committerKarl Trygve Kalleberg <karltk@gentoo.org>2001-11-11 22:10:20 +0000
commite470b584ebf79b4590d94ec896e1586eb80fd574 (patch)
tree4d0ef26cc0edd2718f21b4987499dfeaff7f69ca /app-text/pinfo
parentand again ;) (diff)
downloadhistorical-e470b584ebf79b4590d94ec896e1586eb80fd574.tar.gz
historical-e470b584ebf79b4590d94ec896e1586eb80fd574.tar.bz2
historical-e470b584ebf79b4590d94ec896e1586eb80fd574.zip
pinfo is a better info than info. (So is cat, for that matter, but pinfo has colors)
Diffstat (limited to 'app-text/pinfo')
-rw-r--r--app-text/pinfo/files/digest-pinfo-0.6.31
-rw-r--r--app-text/pinfo/pinfo-0.6.3.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/app-text/pinfo/files/digest-pinfo-0.6.3 b/app-text/pinfo/files/digest-pinfo-0.6.3
new file mode 100644
index 000000000000..35bbfd58bf74
--- /dev/null
+++ b/app-text/pinfo/files/digest-pinfo-0.6.3
@@ -0,0 +1 @@
+MD5 e5ab4675c87bfacde0e0af57583f3e3d pinfo-0.6.3.tar.gz
diff --git a/app-text/pinfo/pinfo-0.6.3.ebuild b/app-text/pinfo/pinfo-0.6.3.ebuild
new file mode 100644
index 000000000000..ad352e386f46
--- /dev/null
+++ b/app-text/pinfo/pinfo-0.6.3.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Karl Trygve Kalleberg <karltk@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/app-text/pinfo/pinfo-0.6.3.ebuild,v 1.1 2001/11/11 22:10:20 karltk Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Hypertext info and man viewer based on (n)curses"
+SRC_URI="http://zeus.polsl.gliwice.pl/~pborys/stable-version/pinfo-0.6.3.tar.gz"
+HOMEPAGE="http://zeus.polsl.gliwice.pl/~pborys/"
+DEPEND="virtual/glibc
+ >=sys-libs/ncurses-5.2
+ >=sys-devel/gettext-0.10.39
+ >=sys-devel/bison-1.28"
+
+src_compile() {
+ local myconf
+ if [ "`use readline`" ] ; then
+ myconf="$myconf --with-readline"
+ fi
+
+ ./configure \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man \
+ $myconf || die "./configure failed"
+
+ emake || die
+ #make || die
+}
+
+src_install () {
+ make DESTDIR=${D} install || die
+}