summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDan Armak <danarmak@gentoo.org>2002-03-21 10:36:07 +0000
committerDan Armak <danarmak@gentoo.org>2002-03-21 10:36:07 +0000
commit94c39cf8dd003bb1bdf7577b0c51d1885520b8c8 (patch)
treeb9683b20581d36851b204b811b581525d1e45aff /app-text/noweb
parentupdated too new version of bind (diff)
downloadhistorical-94c39cf8dd003bb1bdf7577b0c51d1885520b8c8.tar.gz
historical-94c39cf8dd003bb1bdf7577b0c51d1885520b8c8.tar.bz2
historical-94c39cf8dd003bb1bdf7577b0c51d1885520b8c8.zip
use awk not icon, because icon is broken and may take a while to fix. Also fix some sandbox
violations.
Diffstat (limited to 'app-text/noweb')
-rw-r--r--app-text/noweb/ChangeLog9
-rw-r--r--app-text/noweb/files/noweb-2.9-r1-gentoo.diff (renamed from app-text/noweb/files/noweb-2.9-gentoo.diff)42
-rw-r--r--app-text/noweb/noweb-2.9-r1.ebuild (renamed from app-text/noweb/noweb-2.9.ebuild)19
3 files changed, 51 insertions, 19 deletions
diff --git a/app-text/noweb/ChangeLog b/app-text/noweb/ChangeLog
index 999563c0d706..7dc7c8db7c4c 100644
--- a/app-text/noweb/ChangeLog
+++ b/app-text/noweb/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-text/noweb
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/app-text/noweb/ChangeLog,v 1.1 2002/02/01 21:53:10 gbevin Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/noweb/ChangeLog,v 1.2 2002/03/21 10:36:07 danarmak Exp $
+
+*noweb-2.9-r1 (21 Mar 2002)
+
+ 21 Mar 2002; Dan Armak <danarmak@gentoo.org> ChangeLog :
+
+ Use awk not icon to compile. Icon package is in trouble and I don't want to depend on it right now.
+ Also some sandbox fixes.
*noweb-2.9 (1 Feb 2002)
diff --git a/app-text/noweb/files/noweb-2.9-gentoo.diff b/app-text/noweb/files/noweb-2.9-r1-gentoo.diff
index d24b8c31b454..c3170db70ab6 100644
--- a/app-text/noweb/files/noweb-2.9-gentoo.diff
+++ b/app-text/noweb/files/noweb-2.9-r1-gentoo.diff
@@ -1,5 +1,6 @@
---- Makefile.orig Wed Mar 28 15:40:00 2001
-+++ Makefile Wed Aug 1 20:46:24 2001
+diff -ur src-new/Makefile src/Makefile
+--- Makefile Wed Mar 28 15:40:00 2001
++++ Makefile Thu Mar 21 12:22:47 2002
@@ -3,12 +3,12 @@
#
# Adjust these two lines for your ANSI C compiler
@@ -8,8 +9,7 @@
+#CFLAGS=
# If you have Icon, you should use the Icon versions of the noweb pipeline.
# Set LIBSRC=icon
--LIBSRC=awk
-+LIBSRC=icon
+ LIBSRC=awk
# If you have no Icon compiler, but do have icont, make ICONC=icont
-ICONC=iconc
+ICONC=icont
@@ -177,26 +177,43 @@
sed -e "s@|LIBDIR|@$(LIBNAME)@" -e "s@|TEXINPUTS|@$(TEXNAME)@" xdoc/cpif.txt | gzip > $(CATDIR)/cpif.$(MANEXT).gz
sed -e "s@|LIBDIR|@$(LIBNAME)@" -e "s@|TEXINPUTS|@$(TEXNAME)@" xdoc/nodefs.txt | gzip > $(CATDIR)/nodefs.$(MANEXT).gz
sed -e "s@|LIBDIR|@$(LIBNAME)@" -e "s@|TEXINPUTS|@$(TEXNAME)@" xdoc/noroots.txt | gzip > $(CATDIR)/noroots.$(MANEXT).gz
-@@ -143,13 +143,13 @@
+@@ -143,13 +143,14 @@
rm -f $(CATDIR)/nountangle.$(MANEXT).gz
(cd $(CATDIR); ln notangle.$(MANEXT).gz nountangle.$(MANEXT).gz)
install-tex:
- -mkdir $(TEXINPUTS) 2>/dev/null
- cp tex/nwmac.tex tex/noweb.sty $(TEXINPUTS)
+- -texhash || echo "Program texhash not found or failed"
+ -mkdir -p ${DESTDIR}/$(TEXINPUTS) 2>/dev/null
+ cp tex/nwmac.tex tex/noweb.sty ${DESTDIR}/$(TEXINPUTS)
- -texhash || echo "Program texhash not found or failed"
++ #-texhash || echo "Program texhash not found or failed"
install-elisp:
- -mkdir $(ELISP) 2>/dev/null
- cp elisp/noweb-mode.el $(ELISP)
-+ -mkdir -p $(ELISP) 2>/dev/null
-+ cp elisp/noweb-mode.el /$(ELISP)
++ # right now $ELISP is /dev/null so don't mess with it
++ #-mkdir -p $(DESTDIR)/$(ELISP) 2>/dev/null
++ #cp elisp/noweb-mode.el $(DESTDIR)$(ELISP)
checkin:
for i in lib tex xdoc; do (cd $$i; make "CINAME=$(CINAME)" "CIMSG=$(CIMSG)" checkin); done
---- icon/Makefile.orig Thu Sep 14 03:00:00 2000
-+++ icon/Makefile Wed Aug 1 20:46:03 2001
+diff -ur src-new/awk/Makefile src/awk/Makefile
+--- awk/Makefile Mon Mar 27 02:00:00 2000
++++ awk/Makefile Thu Mar 21 12:09:35 2002
+@@ -16,8 +16,8 @@
+ touch $(EXECS)
+
+ install: all
+- cp $(LIBEXECS) $(LIB)
+- cp $(BINEXECS) $(BIN)
++ cp $(LIBEXECS) $(DESTDIR)/$(LIB)
++ cp $(BINEXECS) $(DESTDIR)/$(BIN)
+
+ source: $(EXECS)
+
+diff -ur src-new/icon/Makefile src/icon/Makefile
+--- icon/Makefile Thu Sep 14 03:00:00 2000
++++ icon/Makefile Thu Mar 21 12:08:58 2002
@@ -32,9 +32,9 @@
touch $(SRCS)
@@ -210,8 +227,9 @@
clean:
/bin/rm -f *.tex *.dvi *.aux *.log *.blg *.bbl *~ *.toc *.html *.u1 *.u2
---- lib/Makefile.orig Fri Jun 23 13:56:00 2000
-+++ lib/Makefile Wed Aug 1 20:46:03 2001
+diff -ur src-new/lib/Makefile src/lib/Makefile
+--- lib/Makefile Fri Jun 23 13:56:00 2000
++++ lib/Makefile Thu Mar 21 12:08:58 2002
@@ -11,9 +11,9 @@
chmod +x unmarkup emptydefn toascii nwmtime pipedocs h2a btdefn
diff --git a/app-text/noweb/noweb-2.9.ebuild b/app-text/noweb/noweb-2.9-r1.ebuild
index a9bdf762242d..9a96508cb3b4 100644
--- a/app-text/noweb/noweb-2.9.ebuild
+++ b/app-text/noweb/noweb-2.9-r1.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2001 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Dan Armak <danarmak@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/app-text/noweb/noweb-2.9.ebuild,v 1.4 2001/08/31 13:59:02 danarmak Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/noweb/noweb-2.9-r1.ebuild,v 1.1 2002/03/21 10:36:07 danarmak Exp $
S=${WORKDIR}/src
#SRC_URI="ftp://ftp.dante.de/tex-archive/web/noweb/src.tar.gz"
@@ -10,8 +10,7 @@ SRC_URI="http://www.ibiblio.org/pub/Linux/distributions/gentoo/distfiles/noweb-s
HOMEPAGE="http://www.eecs.harvard.edu/~nr/noweb/"
DESCRIPTION="a literate programming tool, lighter than web"
-DEPEND="dev-lang/icon
- sys-devel/gcc
+DEPEND="sys-devel/gcc
app-text/tetex
sys-apps/gawk"
@@ -19,21 +18,29 @@ src_unpack() {
unpack ${A}
cd ${S}
- patch -p0 <${FILESDIR}/${P}-gentoo.diff
+ patch -p0 <${FILESDIR}/${PF}-gentoo.diff || die
}
src_compile() {
- try make
+ emake || die
}
src_install () {
- try make DESTDIR=${D} install
+ make DESTDIR=${D} install || die
[ -x /usr/bin/nawk ] || dosym /usr/bin/gawk /usr/bin/nawk
}
+pkg_postinst() {
+
+ einfo "Running texhash to complete installation.."
+ addwrite "/var/lib/texmf"
+ addwrite "/usr/share/texmf"
+ addwrite "/var/cache/fonts"
+ texhash
+}