summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2008-05-19 10:26:03 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2008-05-19 10:26:03 +0000
commit0051b8df7b61bbf8680c680f32d7cc6fe4beed4a (patch)
treed841fc2980460c1417d4b76c2f30ed6ff4a2710e /app-text/libxmlpatch/libxmlpatch-0.3.1.ebuild
parentInitial import of ssddiff, a C++ implementation of xmldiff. (diff)
downloadhistorical-0051b8df7b61bbf8680c680f32d7cc6fe4beed4a.tar.gz
historical-0051b8df7b61bbf8680c680f32d7cc6fe4beed4a.tar.bz2
historical-0051b8df7b61bbf8680c680f32d7cc6fe4beed4a.zip
Initial import of Nokia's xmlpatch suite.
Package-Manager: portage-2.1.5
Diffstat (limited to 'app-text/libxmlpatch/libxmlpatch-0.3.1.ebuild')
-rw-r--r--app-text/libxmlpatch/libxmlpatch-0.3.1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/app-text/libxmlpatch/libxmlpatch-0.3.1.ebuild b/app-text/libxmlpatch/libxmlpatch-0.3.1.ebuild
new file mode 100644
index 000000000000..0401c7a4a601
--- /dev/null
+++ b/app-text/libxmlpatch/libxmlpatch-0.3.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/libxmlpatch/libxmlpatch-0.3.1.ebuild,v 1.1 2008/05/19 10:26:03 flameeyes Exp $
+
+inherit eutils autotools
+
+DESCRIPTION="A set of tools to create and apply patch to XML files using XPath"
+HOMEPAGE="http://opensource.nokia.com/projects/xmlpatch/index.html"
+SRC_URI="mirror://sourceforge/${PN/lib}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="dev-libs/glib"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}/${P}-asneeded.patch"
+
+ eautoreconf
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc LEGAL_NOTICE README TODO AUTHORS NEWS ChangeLog
+}