summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2011-08-04 16:25:30 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2011-08-04 16:25:30 +0000
commite7d78d88e6bb2edf1279e3341f5e944827032d82 (patch)
tree544a46c22c2f71d7a272be794f3ee0ae4c7cd50c /app-text/libwpg/libwpg-0.1.3.ebuild
parentUpdate avx patchset and fix the linguas detection. (diff)
downloadhistorical-e7d78d88e6bb2edf1279e3341f5e944827032d82.tar.gz
historical-e7d78d88e6bb2edf1279e3341f5e944827032d82.tar.bz2
historical-e7d78d88e6bb2edf1279e3341f5e944827032d82.zip
Moved from media-libs/libwpg to app-text/libwpg
Package-Manager: portage-2.2.0_alpha50/cvs/Linux x86_64 RepoMan-Options: --force
Diffstat (limited to 'app-text/libwpg/libwpg-0.1.3.ebuild')
-rw-r--r--app-text/libwpg/libwpg-0.1.3.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/app-text/libwpg/libwpg-0.1.3.ebuild b/app-text/libwpg/libwpg-0.1.3.ebuild
new file mode 100644
index 000000000000..523cf093c000
--- /dev/null
+++ b/app-text/libwpg/libwpg-0.1.3.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/libwpg/libwpg-0.1.3.ebuild,v 1.1 2011/08/04 16:25:30 scarabeus Exp $
+
+inherit base eutils
+
+DESCRIPTION="C++ library to read and parse graphics in WPG"
+HOMEPAGE="http://libwpg.sourceforge.net/libwpg.htm"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0.1"
+KEYWORDS="alpha amd64 hppa ia64 ppc ppc64 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="doc"
+
+RDEPEND=">=app-text/libwpd-0.8.0"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ doc? ( app-doc/doxygen )"
+
+src_compile() {
+ econf \
+ --disable-dependency-tracking \
+ $(use_with doc docs)
+ emake || die "emake failed"
+}