summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Houser <chouser@gentoo.org>2002-01-12 06:45:55 +0000
committerChris Houser <chouser@gentoo.org>2002-01-12 06:45:55 +0000
commit1d3dc069fdd05f60a0155e2d8dcd8c794564b1b7 (patch)
tree392c3a7ceef72ab34a7a38fcec15308c83190c7e /app-text/htmltidy
parentNew version of Gabber, removed old one.. (diff)
downloadhistorical-1d3dc069fdd05f60a0155e2d8dcd8c794564b1b7.tar.gz
historical-1d3dc069fdd05f60a0155e2d8dcd8c794564b1b7.tar.bz2
historical-1d3dc069fdd05f60a0155e2d8dcd8c794564b1b7.zip
first htmltidy ebuild
Diffstat (limited to 'app-text/htmltidy')
-rw-r--r--app-text/htmltidy/files/digest-htmltidy-0.8.41
-rw-r--r--app-text/htmltidy/htmltidy-0.8.4.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/app-text/htmltidy/files/digest-htmltidy-0.8.4 b/app-text/htmltidy/files/digest-htmltidy-0.8.4
new file mode 100644
index 000000000000..f111c9f96f3d
--- /dev/null
+++ b/app-text/htmltidy/files/digest-htmltidy-0.8.4
@@ -0,0 +1 @@
+MD5 5faa2b127ae7f1c7ab07ed677db189e7 tidy4aug00.tgz 147456
diff --git a/app-text/htmltidy/htmltidy-0.8.4.ebuild b/app-text/htmltidy/htmltidy-0.8.4.ebuild
new file mode 100644
index 000000000000..7928e98f96ab
--- /dev/null
+++ b/app-text/htmltidy/htmltidy-0.8.4.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: Chouser <chouser@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/app-text/htmltidy/htmltidy-0.8.4.ebuild,v 1.1 2002/01/12 06:45:55 chouser Exp $
+
+# convert from normalized gentoo version number to htmltidy's wacky date thing
+month=(dmy jan feb mar apr may jun jul aug sep oct nov dec)
+parts=(${PV//./ })
+vers=$(printf "%d%s%02d" ${parts[2]} ${month[${parts[1]}]} ${parts[0]})
+P=tidy${vers}
+S=${WORKDIR}/${P}
+
+DESCRIPTION="fix mistakes and tidy up sloppy editing in HTML and XML"
+SRC_URI="http://prdownloads.sourceforge.net/tidy/${P}.tgz"
+HOMEPAGE="http://tidy.sourceforge.net/"
+DEPEND=""
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ # fix man page install path and skip "chown"
+ t=Makefile
+ cp $t $t.orig
+ sed 's:)man/:)share/man/:; s:chgrp\|chown:#&:' $t.orig > $t
+}
+
+src_compile() {
+ emake CFLAGS="${CFLAGS}" || die "emake failed"
+}
+
+src_install () {
+ mkdir -p "${D}/usr/bin"
+ mkdir -p "${D}/usr/share/man/man1"
+ make INSTALLDIR="${D}/usr/" install || die
+ dohtml -a html,gif *
+}