summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-09-12 02:11:10 +0000
committerMike Frysinger <vapier@gentoo.org>2003-09-12 02:11:10 +0000
commit7154b2358dd9025d21900bc763aa223e1ec1f919 (patch)
tree76bee6d9112ef847a3011518668cd111031826b5 /app-text/gv/gv-3.5.8-r2.ebuild
parentTwo new versions (both masked) (diff)
downloadhistorical-7154b2358dd9025d21900bc763aa223e1ec1f919.tar.gz
historical-7154b2358dd9025d21900bc763aa223e1ec1f919.tar.bz2
historical-7154b2358dd9025d21900bc763aa223e1ec1f919.zip
gcc3 patch #24154
Diffstat (limited to 'app-text/gv/gv-3.5.8-r2.ebuild')
-rw-r--r--app-text/gv/gv-3.5.8-r2.ebuild32
1 files changed, 13 insertions, 19 deletions
diff --git a/app-text/gv/gv-3.5.8-r2.ebuild b/app-text/gv/gv-3.5.8-r2.ebuild
index 2d7d599619f6..712d84ea4a8e 100644
--- a/app-text/gv/gv-3.5.8-r2.ebuild
+++ b/app-text/gv/gv-3.5.8-r2.ebuild
@@ -1,18 +1,14 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/gv/gv-3.5.8-r2.ebuild,v 1.7 2003/09/05 22:37:21 msterret Exp $
-
-# this r1 is a major change. it uses sed instead of patches.
-# hopefully this will enable everyone to compile gv on widely
-# different configurations, eliminating the gv.man/gv._man problem
+# $Header: /var/cvsroot/gentoo-x86/app-text/gv/gv-3.5.8-r2.ebuild,v 1.8 2003/09/12 02:11:10 vapier Exp $
DESCRIPTION="standard ghostscript frontend used by programs like LyX"
-SRC_URI="ftp://ftpthep.physik.uni-mainz.de/pub/gv/unix/${P}.tar.gz"
HOMEPAGE="http://wwwthep.physik.uni-mainz.de/~plass/gv/"
+SRC_URI="ftp://ftpthep.physik.uni-mainz.de/pub/gv/unix/${P}.tar.gz"
-SLOT="0"
LICENSE="GPL-2"
-KEYWORDS="ppc x86 alpha sparc"
+SLOT="0"
+KEYWORDS="x86 ppc alpha sparc"
# There's probably more, but ghostscript also depends on it,
# so I can't identify it
@@ -23,7 +19,8 @@ DEPEND="virtual/x11
src_unpack() {
unpack ${A}
cd ${S}
- patch -p1 < ${FILESDIR}/${PF}-gentoo.diff
+ epatch ${FILESDIR}/${PF}-gentoo.diff
+ epatch ${FILESDIR}/${PV}-gcc3.patch
}
src_compile() {
@@ -35,17 +32,14 @@ src_compile() {
make Makefiles || die
cd source
-
- cp Makefile 1
- cat 1 | sed -e 's/install.man:: gv.man/install.man::/' \
+ sed -i \
+ -e 's/install.man:: gv.man/install.man::/' \
-e 's/all:: gv./\#all:: gv./' \
- -e '/gv.man/ c \#removed by sed for ebuilding' > Makefile
- rm 1
- if [ ! "`grep gv.man Makefile`" = "" ];
- then
- echo "sed didn't completely remove gv.man references from the Makefile."
- echo "We'll just run make and pray."
- sleep 2s
+ -e '/gv.man/ c \#removed by sed for ebuilding' \
+ Makefile
+ if [ ! "`grep gv.man Makefile`" = "" ] ; then
+ ewarn "sed didn't completely remove gv.man references from the Makefile."
+ ewarn "We'll just run make and pray."
fi
cd ${S}