summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMamoru Komachi <usata@gentoo.org>2005-02-12 13:15:10 +0000
committerMamoru Komachi <usata@gentoo.org>2005-02-12 13:15:10 +0000
commit1a6f018d0b95002153e5c7ef4d3e2f1e1c3c97ac (patch)
tree8f2d2fba6f9d3f6826b3fcb93b75074cbc0e9b80 /app-text/flpsed
parentfixed older ebuilds to use kernel-2.eclass correctly + version bumpt to 1.9.4 (diff)
downloadhistorical-1a6f018d0b95002153e5c7ef4d3e2f1e1c3c97ac.tar.gz
historical-1a6f018d0b95002153e5c7ef4d3e2f1e1c3c97ac.tar.bz2
historical-1a6f018d0b95002153e5c7ef4d3e2f1e1c3c97ac.zip
Version bumped. This closes bug #79595.
Package-Manager: portage-2.0.51-r15
Diffstat (limited to 'app-text/flpsed')
-rw-r--r--app-text/flpsed/ChangeLog7
-rw-r--r--app-text/flpsed/files/digest-flpsed-0.3.21
-rw-r--r--app-text/flpsed/flpsed-0.3.2.ebuild30
-rw-r--r--app-text/flpsed/flpsed-0.3.ebuild4
4 files changed, 39 insertions, 3 deletions
diff --git a/app-text/flpsed/ChangeLog b/app-text/flpsed/ChangeLog
index 51317b4a0573..490726a1cc45 100644
--- a/app-text/flpsed/ChangeLog
+++ b/app-text/flpsed/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-text/flpsed
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/flpsed/ChangeLog,v 1.2 2005/01/01 16:14:15 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/flpsed/ChangeLog,v 1.3 2005/02/12 13:15:10 usata Exp $
+
+*flpsed-0.3.2 (12 Feb 2005)
+
+ 12 Feb 2005; Mamoru KOMACHI <usata@gentoo.org> +flpsed-0.3.2.ebuild:
+ Version bumped. This closes bug #79595.
*flpsed-0.3 (07 Nov 2004)
diff --git a/app-text/flpsed/files/digest-flpsed-0.3.2 b/app-text/flpsed/files/digest-flpsed-0.3.2
new file mode 100644
index 000000000000..f667c39e1054
--- /dev/null
+++ b/app-text/flpsed/files/digest-flpsed-0.3.2
@@ -0,0 +1 @@
+MD5 e3f4e0decb51431023d8472de5934dbe flpsed-0.3.2.tar.gz 13649
diff --git a/app-text/flpsed/flpsed-0.3.2.ebuild b/app-text/flpsed/flpsed-0.3.2.ebuild
new file mode 100644
index 000000000000..e57d1305bf86
--- /dev/null
+++ b/app-text/flpsed/flpsed-0.3.2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/flpsed/flpsed-0.3.2.ebuild,v 1.1 2005/02/12 13:15:10 usata Exp $
+
+inherit flag-o-matic
+
+DESCRIPTION="a pseudo PostScript editor"
+HOMEPAGE="http://www.ecademix.com/JohannesHofmann/"
+SRC_URI="http://www.ecademix.com/JohannesHofmann/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND="virtual/x11
+ >=x11-libs/fltk-1.1
+ virtual/ghostscript"
+
+src_compile() {
+ append-flags $(fltk-config --cxxflags)
+ append-ldflags $(fltk-config --ldflags)
+
+ emake -f ${FILESDIR}/Makefile-0.3 || die "emake failed"
+}
+
+src_install() {
+ dobin flpsed
+ dodoc README ChangeLog
+}
diff --git a/app-text/flpsed/flpsed-0.3.ebuild b/app-text/flpsed/flpsed-0.3.ebuild
index a28b29759978..1bf609941926 100644
--- a/app-text/flpsed/flpsed-0.3.ebuild
+++ b/app-text/flpsed/flpsed-0.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/flpsed/flpsed-0.3.ebuild,v 1.2 2005/01/01 16:14:15 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/flpsed/flpsed-0.3.ebuild,v 1.3 2005/02/12 13:15:10 usata Exp $
inherit flag-o-matic
@@ -10,7 +10,7 @@ SRC_URI="http://www.ecademix.com/JohannesHofmann/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~x86"
+KEYWORDS="x86"
IUSE=""
DEPEND="virtual/x11