summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-08-13 18:57:40 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-08-13 18:57:40 +0000
commit31d336c20bd35f4292b502cd370cadd73601f4f4 (patch)
tree1eb51276ff4281b63963caad1c3bf55dc54d319a /app-text/aspell
parentmasked aspell for testing (diff)
downloadhistorical-31d336c20bd35f4292b502cd370cadd73601f4f4.tar.gz
historical-31d336c20bd35f4292b502cd370cadd73601f4f4.tar.bz2
historical-31d336c20bd35f4292b502cd370cadd73601f4f4.zip
version bump
Diffstat (limited to 'app-text/aspell')
-rw-r--r--app-text/aspell/ChangeLog8
-rw-r--r--app-text/aspell/aspell-0.50_pre20020730.ebuild63
2 files changed, 70 insertions, 1 deletions
diff --git a/app-text/aspell/ChangeLog b/app-text/aspell/ChangeLog
index 114aacc4d075..280df48ad4ce 100644
--- a/app-text/aspell/ChangeLog
+++ b/app-text/aspell/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-text/aspell
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/app-text/aspell/ChangeLog,v 1.6 2002/08/07 14:49:08 cselkirk Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/aspell/ChangeLog,v 1.7 2002/08/13 18:57:40 seemant Exp $
+
+*aspell-0.50_pre20020730 (13 Aug 2002)
+
+ 13 Aug 2002; Seemant Kulleen <seemant@gentoo.org> aspell-0.50_pre20020730 :
+
+ Version bump (long needed)
*aspell-0.33-7.1-r2 (24 Jul 2002)
diff --git a/app-text/aspell/aspell-0.50_pre20020730.ebuild b/app-text/aspell/aspell-0.50_pre20020730.ebuild
new file mode 100644
index 000000000000..f2331ca63e79
--- /dev/null
+++ b/app-text/aspell/aspell-0.50_pre20020730.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/aspell/aspell-0.50_pre20020730.ebuild,v 1.1 2002/08/13 18:57:40 seemant Exp $
+
+inherit libtool
+
+MY_P=${P/_pre/-}
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="A spell checker replacement for ispell"
+SRC_URI="http://savannah.gnu.org/download/aspell/${MY_P}.tar.gz"
+HOMEPAGE="http://aspell.sourceforge.net"
+
+DEPEND=">=app-text/pspell-0.12
+ >=sys-libs/ncurses-5.2"
+
+SLOT="0"
+LICENSE="LGPL-2"
+KEYWORDS="x86 ppc"
+
+#
+# These flags a reset here because too much optimisation can cause aspell's
+# compilation process to break. Moreover, these must be set before ./configure
+# otherwise it breaks again. A very fragile build process, really.
+#
+CXXFLAGS="-O2"
+CFLAGS=${CXXFLAGS}
+
+# needed to compile
+
+if [ -e /lib/libc-2.2.5.so ] && [ `gcc -dumpversion` == "2.95.3" ]; then
+ if [ ! -f /etc/aspell/aspell.conf ]; then
+ mkdir -p /etc/aspell
+ touch /etc/aspell/aspell.conf
+ fi
+ if [ ! -f /root/.aspell.conf ]; then
+ touch /root/.aspell.conf
+ fi
+fi
+
+src_compile() {
+# elibtoolize
+
+ econf \
+ --disable-static \
+ --sysconfdir=/etc/aspell || die
+
+ emake || die
+
+}
+
+src_install () {
+
+ make DESTDIR=${D} install || die
+ cd ${D}/usr/share/doc/${P}
+ dohtml -r man-html
+ docinto text
+ dodoc man-text
+ cd ${S}
+
+ dodoc README* TODO
+
+}
+