summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2011-02-15 15:51:29 +0000
committerAlexis Ballier <aballier@gentoo.org>2011-02-15 15:51:29 +0000
commitaf8304e2a68dba10e7551f7ce1d25886c59aead7 (patch)
tree2aab39b7ff52448978108892a1eac874fd5cdb8a /app-text/active-dvi
parentinitial import, ebuild by me (diff)
downloadhistorical-af8304e2a68dba10e7551f7ce1d25886c59aead7.tar.gz
historical-af8304e2a68dba10e7551f7ce1d25886c59aead7.tar.bz2
historical-af8304e2a68dba10e7551f7ce1d25886c59aead7.zip
version bump, bug #316131
Package-Manager: portage-2.2.0_alpha23/cvs/Linux x86_64
Diffstat (limited to 'app-text/active-dvi')
-rw-r--r--app-text/active-dvi/ChangeLog10
-rw-r--r--app-text/active-dvi/active-dvi-1.9.ebuild69
-rw-r--r--app-text/active-dvi/files/active-dvi-1.9-htmlcflags.patch13
3 files changed, 90 insertions, 2 deletions
diff --git a/app-text/active-dvi/ChangeLog b/app-text/active-dvi/ChangeLog
index b38f646bdae6..3a952e66bb55 100644
--- a/app-text/active-dvi/ChangeLog
+++ b/app-text/active-dvi/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-text/active-dvi
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/active-dvi/ChangeLog,v 1.36 2009/12/26 19:39:04 pva Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/active-dvi/ChangeLog,v 1.37 2011/02/15 15:51:29 aballier Exp $
+
+*active-dvi-1.9 (15 Feb 2011)
+
+ 15 Feb 2011; Alexis Ballier <aballier@gentoo.org> +active-dvi-1.9.ebuild,
+ +files/active-dvi-1.9-htmlcflags.patch:
+ version bump, bug #316131
26 Dec 2009; Peter Volkov <pva@gentoo.org> active-dvi-1.8.ebuild:
virtual/ghostscript->app-text/ghostscript-gpl: ghostscript-gpl is the only
diff --git a/app-text/active-dvi/active-dvi-1.9.ebuild b/app-text/active-dvi/active-dvi-1.9.ebuild
new file mode 100644
index 000000000000..b299c64b790a
--- /dev/null
+++ b/app-text/active-dvi/active-dvi-1.9.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/active-dvi/active-dvi-1.9.ebuild,v 1.1 2011/02/15 15:51:29 aballier Exp $
+
+EAPI="2"
+
+inherit eutils autotools texlive-common
+
+MY_PN=${PN/ctive-/}
+MY_P=${MY_PN}-${PV}
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="A DVI previewer and a presenter for slides written in LaTeX"
+SRC_URI="http://gallium.inria.fr/advi/${MY_P}.tar.gz"
+HOMEPAGE="http://gallium.inria.fr/advi/"
+LICENSE="LGPL-2.1"
+
+IUSE="+ocamlopt"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND=">=dev-lang/ocaml-3.11.2[ocamlopt?]
+ >=dev-ml/camlimages-3.0.1[truetype,tiff,jpeg,gs]
+ virtual/latex-base
+ app-text/ghostscript-gpl
+ x11-libs/libXinerama"
+DEPEND="${RDEPEND}
+ || ( ( dev-texlive/texlive-pstricks dev-texlive/texlive-pictures )
+ app-text/ptex )
+ x11-proto/xineramaproto
+ dev-ml/findlib
+ app-text/htmlc
+ dev-tex/hevea"
+
+DOCS="README TODO"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-1.7.3-asneeded.patch"
+ epatch "${FILESDIR}/${P}-htmlcflags.patch"
+ AT_M4DIR="." eautoreconf
+}
+
+src_configure() {
+ TEXMFMAIN=/usr/share/texmf-site econf $(use_enable ocamlopt native-program) \
+ --docdir="/usr/share/doc/${PF}"
+}
+
+src_compile() {
+ emake || die "emake failed"
+ cd doc
+ VARTEXFONTS="${T}/fonts" emake splash.dvi scratch_write_splash.dvi scratch_draw_splash.dvi || die "failed to create documentation"
+}
+
+src_install() {
+ emake DESTDIR="${D}" PACKAGE="${PF}" install || die
+
+ # now install the documentation
+ dodoc ${DOCS}
+
+ export STRIP_MASK="*/bin/advi.byt"
+}
+
+pkg_postinst() {
+ etexmf-update
+}
+
+pkg_postrm() {
+ etexmf-update
+}
diff --git a/app-text/active-dvi/files/active-dvi-1.9-htmlcflags.patch b/app-text/active-dvi/files/active-dvi-1.9-htmlcflags.patch
new file mode 100644
index 000000000000..59697ec4dc83
--- /dev/null
+++ b/app-text/active-dvi/files/active-dvi-1.9-htmlcflags.patch
@@ -0,0 +1,13 @@
+Index: advi-1.9/doc/Makefile.am
+===================================================================
+--- advi-1.9.orig/doc/Makefile.am
++++ advi-1.9/doc/Makefile.am
+@@ -113,6 +113,8 @@ TEX_ENV = TEXINPUTS=$(srcdir):$(top_src
+ HEVEA_FLAGS = -entities -I $(srcdir) -I $(top_srcdir)/tex
+ HTMLC_FLAGS = -I $(srcdir)/includes \
+ -D CamlVersion '$(OCAMLVERSION)' \
++ -D HOSTNAME "$(HOSTNAME)" \
++ -D USER "$(USER)" \
+ -D version '$(VERSION)'
+
+ MV = mv -f