summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno Boeck <hanno@gentoo.org>2006-03-27 00:18:03 +0000
committerHanno Boeck <hanno@gentoo.org>2006-03-27 00:18:03 +0000
commit248ed0da1c5be40618b03206b15794abd0f96023 (patch)
tree0a4c1b75d14bd8b053d238dfb6638c6ebcd2fc5d /app-shells/mksh/mksh-26c.ebuild
parentVersion bump wrt bug #126877 (diff)
downloadhistorical-248ed0da1c5be40618b03206b15794abd0f96023.tar.gz
historical-248ed0da1c5be40618b03206b15794abd0f96023.tar.bz2
historical-248ed0da1c5be40618b03206b15794abd0f96023.zip
mksh update
Package-Manager: portage-2.1_pre7-r1
Diffstat (limited to 'app-shells/mksh/mksh-26c.ebuild')
-rw-r--r--app-shells/mksh/mksh-26c.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/app-shells/mksh/mksh-26c.ebuild b/app-shells/mksh/mksh-26c.ebuild
new file mode 100644
index 000000000000..6f50245a78a1
--- /dev/null
+++ b/app-shells/mksh/mksh-26c.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-shells/mksh/mksh-26c.ebuild,v 1.1 2006/03/27 00:18:03 hanno Exp $
+
+DESCRIPTION="MirBSD KSH Shell"
+HOMEPAGE="http://mirbsd.mirsolutions.de/?mksh"
+SRC_URI="http://mirbsd.mirsolutions.de/MirOS/dist/mir/mksh/${PN}-R${PV}.cpio.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~ppc ~x86"
+IUSE=""
+DEPEND="app-arch/cpio"
+RDEPEND=""
+S=${WORKDIR}/${PN}
+
+src_unpack() {
+ gzip -dc ${DISTDIR}/${PN}-R${PV}.cpio.gz | cpio -mid
+}
+
+src_compile() {
+ sh Build.sh -d -r
+}
+
+src_install() {
+ dobin mksh
+ doman mksh.1
+}
+
+src_test() {
+ ./Test.sh
+}