summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTavis Ormandy <taviso@gentoo.org>2004-10-26 14:17:22 +0000
committerTavis Ormandy <taviso@gentoo.org>2004-10-26 14:17:22 +0000
commitff21efdbc446375b4d534084b11c3f15bb1c5873 (patch)
tree26a6acb00cd3f33a076b9c2539c0a3ff9b2b25e4 /app-shells/ksh
parentuse $(tc-getCC) / amd64 stable (diff)
downloadhistorical-ff21efdbc446375b4d534084b11c3f15bb1c5873.tar.gz
historical-ff21efdbc446375b4d534084b11c3f15bb1c5873.tar.bz2
historical-ff21efdbc446375b4d534084b11c3f15bb1c5873.zip
use toolchain-funcs to determine compiler
Diffstat (limited to 'app-shells/ksh')
-rw-r--r--app-shells/ksh/ChangeLog5
-rw-r--r--app-shells/ksh/Manifest8
-rw-r--r--app-shells/ksh/ksh-93.20040229.ebuild6
3 files changed, 11 insertions, 8 deletions
diff --git a/app-shells/ksh/ChangeLog b/app-shells/ksh/ChangeLog
index 9c5e0bcfa03a..b416a21c3577 100644
--- a/app-shells/ksh/ChangeLog
+++ b/app-shells/ksh/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-shells/ksh
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/ksh/ChangeLog,v 1.17 2004/10/23 10:43:36 hattya Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/ksh/ChangeLog,v 1.18 2004/10/26 14:17:22 taviso Exp $
+
+ 26 Oct 2004; Tavis Ormandy <taviso@gentoo.org> ksh-93.20040229.ebuild:
+ use toolchain-funcs to determine compiler
23 Oct 2004; Akinori Hattori <hattya@gentoo.org> ksh-93.20040229.ebuild:
add ~ia64, bug #68321.
diff --git a/app-shells/ksh/Manifest b/app-shells/ksh/Manifest
index 35702d380fb4..b682d82c18a8 100644
--- a/app-shells/ksh/Manifest
+++ b/app-shells/ksh/Manifest
@@ -1,8 +1,8 @@
-MD5 e6fd139b0f227b9c9cfab997385e4637 ChangeLog 2113
+MD5 b80521984ea1f9830e7c98c6c60f65b4 ksh-93.20040229.ebuild 2283
MD5 405957e8521340f83ac6d305853e2e55 ksh-93.20030724.ebuild 2378
-MD5 4fbff1e3a8aab37a06d88a72eb3acd2c ksh-93.20040229.ebuild 2264
+MD5 910266c520ee62e17bc3cc2e24059097 ChangeLog 2231
MD5 e283b9362f2885bedf238e7c08f51e26 metadata.xml 1272
+MD5 c2103b0157f069fd50dacdf50670d848 files/ksh-build-problems.diff 303
+MD5 fc05a830ab720e8d3462bb10f0474258 files/ksh-93.20030724-libs.diff 12867
MD5 75a91bdad38d09a163894fd8ebc8adff files/digest-ksh-93.20030724 206
MD5 9d9dc80da41b462852a6632153563619 files/digest-ksh-93.20040229 206
-MD5 fc05a830ab720e8d3462bb10f0474258 files/ksh-93.20030724-libs.diff 12867
-MD5 c2103b0157f069fd50dacdf50670d848 files/ksh-build-problems.diff 303
diff --git a/app-shells/ksh/ksh-93.20040229.ebuild b/app-shells/ksh/ksh-93.20040229.ebuild
index 686d3871ac9a..2b0a6d08fab0 100644
--- a/app-shells/ksh/ksh-93.20040229.ebuild
+++ b/app-shells/ksh/ksh-93.20040229.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/ksh/ksh-93.20040229.ebuild,v 1.12 2004/10/23 10:43:36 hattya Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/ksh/ksh-93.20040229.ebuild,v 1.13 2004/10/26 14:17:22 taviso Exp $
-inherit ccc eutils flag-o-matic
+inherit ccc eutils flag-o-matic toolchain-funcs
RELEASE="2004-02-29"
DESCRIPTION="The Original Korn Shell, 1993 revision (ksh93)"
@@ -48,7 +48,7 @@ src_compile() {
# set the optimisations for the build process
export CCFLAGS="${CFLAGS}"
- cd ${S}; ./bin/package only make ast-ksh CC=${CC:-gcc} || die
+ cd ${S}; ./bin/package only make ast-ksh CC="$(tc-getCC)" || die
# install the optional locale data.
# heh, check out locale fudd, or piglatin :)