summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTavis Ormandy <taviso@gentoo.org>2004-09-23 08:10:09 +0000
committerTavis Ormandy <taviso@gentoo.org>2004-09-23 08:10:09 +0000
commit52548fa94650516124f035c80c51f3e65307351c (patch)
tree91ddf57123ab4291e30da6f0f71543870c1bceda /app-shells/ksh
parentclean older versions (diff)
downloadhistorical-52548fa94650516124f035c80c51f3e65307351c.tar.gz
historical-52548fa94650516124f035c80c51f3e65307351c.tar.bz2
historical-52548fa94650516124f035c80c51f3e65307351c.zip
attempting to fix #50000
Diffstat (limited to 'app-shells/ksh')
-rw-r--r--app-shells/ksh/ChangeLog6
-rw-r--r--app-shells/ksh/Manifest7
-rw-r--r--app-shells/ksh/files/ksh-build-problems.diff11
-rw-r--r--app-shells/ksh/ksh-93.20040229.ebuild3
4 files changed, 22 insertions, 5 deletions
diff --git a/app-shells/ksh/ChangeLog b/app-shells/ksh/ChangeLog
index e540ec64c81c..2ce001534d4e 100644
--- a/app-shells/ksh/ChangeLog
+++ b/app-shells/ksh/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-shells/ksh
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/ksh/ChangeLog,v 1.14 2004/09/14 17:59:09 gustavoz Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/ksh/ChangeLog,v 1.15 2004/09/23 08:10:09 taviso Exp $
+
+ 23 Sep 2004; Tavis Ormandy <taviso@gentoo.org>
+ +files/ksh-build-problems.diff, ksh-93.20040229.ebuild:
+ attempting to fix #50000
14 Sep 2004; Gustavo Zacarias <gustavoz@gentoo.org> ksh-93.20040229.ebuild:
Stable on sparc
diff --git a/app-shells/ksh/Manifest b/app-shells/ksh/Manifest
index 96d120892a1b..9b14a0a74848 100644
--- a/app-shells/ksh/Manifest
+++ b/app-shells/ksh/Manifest
@@ -1,7 +1,8 @@
-MD5 95a0dcaad3512f4521064465dadc884e ChangeLog 1783
+MD5 b69e8af4a74400adf830326c3a58ac38 ksh-93.20040229.ebuild 2253
MD5 405957e8521340f83ac6d305853e2e55 ksh-93.20030724.ebuild 2378
-MD5 22584ad89bcde63276f462db9a2d990d ksh-93.20040229.ebuild 2204
+MD5 3df1a8d73328d1c64b8fc545afe5183e ChangeLog 1916
MD5 e283b9362f2885bedf238e7c08f51e26 metadata.xml 1272
+MD5 c2103b0157f069fd50dacdf50670d848 files/ksh-build-problems.diff 303
+MD5 fc05a830ab720e8d3462bb10f0474258 files/ksh-93.20030724-libs.diff 12867
MD5 75a91bdad38d09a163894fd8ebc8adff files/digest-ksh-93.20030724 206
MD5 9d9dc80da41b462852a6632153563619 files/digest-ksh-93.20040229 206
-MD5 fc05a830ab720e8d3462bb10f0474258 files/ksh-93.20030724-libs.diff 12867
diff --git a/app-shells/ksh/files/ksh-build-problems.diff b/app-shells/ksh/files/ksh-build-problems.diff
new file mode 100644
index 000000000000..bc1a2456b868
--- /dev/null
+++ b/app-shells/ksh/files/ksh-build-problems.diff
@@ -0,0 +1,11 @@
+--- src/lib/libast/comp/conf.sh.orig Wed Aug 13 00:08:55 2003
++++ src/lib/libast/comp/conf.sh Wed Aug 13 00:10:55 2003
+@@ -266,7 +266,7 @@
+ -e 's,[ ].*,,' \
+ -e '/^[S_]/!d' \
+ `cat $tmp.f` 2>/dev/null |
+-sort -u > $tmp.v
++sort -u | grep -v _O_SC_CLK_TCK > $tmp.v
+ case $debug in
+ -d2) exit ;;
+ esac
diff --git a/app-shells/ksh/ksh-93.20040229.ebuild b/app-shells/ksh/ksh-93.20040229.ebuild
index 6005133eea9b..83ccc15dd396 100644
--- a/app-shells/ksh/ksh-93.20040229.ebuild
+++ b/app-shells/ksh/ksh-93.20040229.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/ksh/ksh-93.20040229.ebuild,v 1.8 2004/09/14 17:59:09 gustavoz Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/ksh/ksh-93.20040229.ebuild,v 1.9 2004/09/23 08:10:09 taviso Exp $
inherit ccc eutils flag-o-matic
@@ -36,6 +36,7 @@ src_unpack() {
# `package read` will unpack any tarballs put in place.
${S}/bin/package read || die
+ epatch ${FILESDIR}/ksh-build-problems.diff || die
}
src_compile() {