summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTavis Ormandy <taviso@gentoo.org>2003-06-13 09:22:16 +0000
committerTavis Ormandy <taviso@gentoo.org>2003-06-13 09:22:16 +0000
commitf5777ac57cf6972c1cd3660c22573a072c9a974b (patch)
treed8648df2092fc84deb922d3317cb6ea3404e03d2 /app-shells/csh
parent9wm license for larswm (diff)
downloadhistorical-f5777ac57cf6972c1cd3660c22573a072c9a974b.tar.gz
historical-f5777ac57cf6972c1cd3660c22573a072c9a974b.tar.bz2
historical-f5777ac57cf6972c1cd3660c22573a072c9a974b.zip
tweaking the example login scripts.
Diffstat (limited to 'app-shells/csh')
-rw-r--r--app-shells/csh/ChangeLog9
-rw-r--r--app-shells/csh/Manifest6
-rw-r--r--app-shells/csh/csh-1.29-r1.ebuild10
-rw-r--r--app-shells/csh/files/dot.cshrc38
-rw-r--r--app-shells/csh/files/dot.login12
5 files changed, 66 insertions, 9 deletions
diff --git a/app-shells/csh/ChangeLog b/app-shells/csh/ChangeLog
index d85f9151e92c..7bed7788d737 100644
--- a/app-shells/csh/ChangeLog
+++ b/app-shells/csh/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-shells/csh
# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/csh/ChangeLog,v 1.5 2003/06/12 21:57:51 taviso Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/csh/ChangeLog,v 1.6 2003/06/13 09:21:57 taviso Exp $
+
+ 13 Jun 2003; Tavis Ormandy <taviso@gentoo.org> csh-1.29-r1.ebuild,
+ files/dot.cshrc, files/dot.login:
+ include the example login scripts in ${FILESDIR}.
+
+ modified the scripts to turn on some nice things, like set emacs, and
+ aliased ls to ls --color.
12 Jun 2003; Tavis Ormandy <taviso@gentoo.org> csh-1.29-r1.ebuild:
put some empty csh login scripts in /etc, provide some skel files with docs.
diff --git a/app-shells/csh/Manifest b/app-shells/csh/Manifest
index ea7013d3659c..aae4df374e78 100644
--- a/app-shells/csh/Manifest
+++ b/app-shells/csh/Manifest
@@ -1,7 +1,9 @@
MD5 40d1ad4d9431c17c016fb5e5e65210b0 csh-1.29.ebuild 3809
-MD5 7a6525cf208da371175f36abcc4bfee5 csh-1.29-r1.ebuild 4213
-MD5 a2e33a5f9d0ca529d3b90613b0dddb15 ChangeLog 1163
+MD5 60cc3b5753dafc9ef7dea385bec350a8 csh-1.29-r1.ebuild 4065
+MD5 81808bf99086db215030e3b96e6712e0 ChangeLog 1424
MD5 49c0a95e6881eb7e2932d149f62f0de2 files/mksignames.c 10722
MD5 49ee962115384f8a0acedfcf225fd27a files/digest-csh-1.29 148
MD5 213922a7d6fdee0a89e9a349653be22d files/linux-vs-bsd.diff 7483
MD5 70a304fe872eabbec7c515095af358fc files/digest-csh-1.29-r1 162
+MD5 9c4ac725c9c47454dc12aff08d3419a8 files/dot.cshrc 1436
+MD5 2365e5e2ca11496be2169a6944a38994 files/dot.login 224
diff --git a/app-shells/csh/csh-1.29-r1.ebuild b/app-shells/csh/csh-1.29-r1.ebuild
index 146fe9579409..619f88359678 100644
--- a/app-shells/csh/csh-1.29-r1.ebuild
+++ b/app-shells/csh/csh-1.29-r1.ebuild
@@ -1,13 +1,11 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/csh/csh-1.29-r1.ebuild,v 1.3 2003/06/12 22:10:04 taviso Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/csh/csh-1.29-r1.ebuild,v 1.4 2003/06/13 09:21:59 taviso Exp $
DESCRIPTION="Classic UNIX shell with C like syntax"
HOMEPAGE="http://www.netbsd.org/"
-SRC_URI="http://cvs.gentoo.org/~taviso/${P}.tar.gz
- ftp://ftp.netbsd.org/pub/NetBSD/NetBSD-release-1-6/src/etc/skel/dot.cshrc
- ftp://ftp.netbsd.org/pub/NetBSD/NetBSD-release-1-6/src/etc/skel/dot.login"
+SRC_URI="http://cvs.gentoo.org/~taviso/${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
@@ -34,8 +32,8 @@ src_compile() {
cd ${S}; cp ${WORKDIR}/printf.c \
${WORKDIR}/vis.h \
${WORKDIR}/vis.c \
- ${DISTDIR}/dot.login \
- ${DISTDIR}/dot.cshrc \
+ ${FILESDIR}/dot.login \
+ ${FILESDIR}/dot.cshrc \
${S}
# this parses the output of the bash builtin `kill`
diff --git a/app-shells/csh/files/dot.cshrc b/app-shells/csh/files/dot.cshrc
new file mode 100644
index 000000000000..4032a4bfc69f
--- /dev/null
+++ b/app-shells/csh/files/dot.cshrc
@@ -0,0 +1,38 @@
+# Gentoo example csh .cshrc file
+
+# some simple aliases
+alias h history 25 # use `h` to show the last 25 commands
+alias j jobs -l # use `j` to list the background/stopped jobs
+alias ls ls -F --color=auto # most people expect `ls` to show nice colours.
+alias la ls -a # \
+alias lf ls -FA # > some shortcuts to common ls options
+alias ll ls -lA # /
+
+# you can override environment variables from /etc/csh.env from here
+setenv EDITOR vim
+setenv VISUAL ${EDITOR}
+setenv EXINIT 'set autoindent'
+setenv PAGER less
+
+# make sure there is something sane in $PATH
+if ( ! $?PATH ) then
+ set path = (~/bin /bin /sbin /usr/{bin,sbin,X11R6/bin,pkg/{,s}bin,games} /usr/local/{,s}bin)
+endif
+
+# some options you might want in an interactive shell
+if ($?prompt) then
+ set filec # use <ESC><ESC> to complete on filenames.
+ set emacs # simple line editing.
+ set history = 1000 # remember last 1000 commands
+ set ignoreeof # dont exit if ^D is hit by accident
+ set mail = (/var/mail/$USER) # where is your user mbox?
+ set mch = `hostname -s` # display short hostname in prompt.
+ set unm = `whoami` # your username
+
+ # some example csh prompts, choose one you like.
+ set prompt = "% " # csh default, simple.
+ set prompt = "${mch:q}: {\!} " # NetBSD example prompt, shows hostname and history reference
+ set prompt = "${unm:q}@${mch:q}% " # similar to bash.
+
+ umask 0022 # set your user's umask.
+endif
diff --git a/app-shells/csh/files/dot.login b/app-shells/csh/files/dot.login
new file mode 100644
index 000000000000..9b3d1ac5ccbe
--- /dev/null
+++ b/app-shells/csh/files/dot.login
@@ -0,0 +1,12 @@
+# Gentoo example csh .login file
+
+if ( ! $?SHELL ) then
+ setenv SHELL /bin/csh
+endif
+
+set noglob
+eval `tset -s -m 'network:?xterm'`
+unset noglob
+stty status '^T' crt -tostop
+
+if ( -x /usr/games/fortune ) /usr/games/fortune