summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorge Shapovalov <george@gentoo.org>2003-03-25 09:51:20 +0000
committerGeorge Shapovalov <george@gentoo.org>2003-03-25 09:51:20 +0000
commitcee9153d9920d5a6dc5599400acebde5188607d4 (patch)
treeea3acf5bb203c1c7a53e5ee967a29ec088a3ede8 /app-sci
parentSecurity update (diff)
downloadhistorical-cee9153d9920d5a6dc5599400acebde5188607d4.tar.gz
historical-cee9153d9920d5a6dc5599400acebde5188607d4.tar.bz2
historical-cee9153d9920d5a6dc5599400acebde5188607d4.zip
made 3.1.4 stable. Added mpi support to -r1 (marked ~x86 for now)
Diffstat (limited to 'app-sci')
-rw-r--r--app-sci/gromacs/files/digest-gromacs-3.1.4-r11
-rw-r--r--app-sci/gromacs/gromacs-3.1.4-r1.ebuild45
-rw-r--r--app-sci/gromacs/gromacs-3.1.4.ebuild4
3 files changed, 48 insertions, 2 deletions
diff --git a/app-sci/gromacs/files/digest-gromacs-3.1.4-r1 b/app-sci/gromacs/files/digest-gromacs-3.1.4-r1
new file mode 100644
index 000000000000..7f41e1fba1e3
--- /dev/null
+++ b/app-sci/gromacs/files/digest-gromacs-3.1.4-r1
@@ -0,0 +1 @@
+MD5 835247417207a9852583a78f835a7da2 gromacs-3.1.4.tar.gz 2713384
diff --git a/app-sci/gromacs/gromacs-3.1.4-r1.ebuild b/app-sci/gromacs/gromacs-3.1.4-r1.ebuild
new file mode 100644
index 000000000000..93c744f2a259
--- /dev/null
+++ b/app-sci/gromacs/gromacs-3.1.4-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-sci/gromacs/gromacs-3.1.4-r1.ebuild,v 1.1 2003/03/25 09:51:20 george Exp $
+
+IUSE="mpi"
+
+DESCRIPTION="The ultimate Molecular Dynamics simulation package"
+SRC_URI="ftp://ftp.gromacs.org/pub/gromacs/${P}.tar.gz"
+HOMEPAGE="http://www.gromacs.org/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+
+#mpi is a local USE flag now
+#May become official when situation with mpich is cleared (now the only mpi implementation awailable is lam-mpi)
+DEPEND=">=dev-libs/fftw-2.1.3
+ mpi? ( >=dev-libs/lam-mpi-6.5.6 )
+ >=sys-devel/binutils-2.10.91.0.2"
+
+
+src_compile() {
+#!!!Please note!!!
+#for troublesome work gromacs should be compiled with the same mpi setting as fftw.
+#Unfortunately portage cannot trace optional dependencies of dependencies at present.
+#Until this (planned) feature is completed, please try to do corresponding check yourself.
+ local myconf=""
+ use mpi && myconf="${myconf} --enable-mpi"
+
+ econf \
+ --enable-fortran \
+ --datadir=/usr/share/${P} ${myconf} || die "./configure failed"
+ emake || die
+}
+
+src_install () {
+ make DESTDIR=${D} install || die
+
+ # Install documentation.
+ dodoc AUTHORS COPYING INSTALL README
+
+ #move html docs under /usr/share/doc
+ #and leave examples and templates under /usr/gromacs...
+ mv ${D}/usr/share/${P}/html ${D}/usr/share/doc/${PF}
+}
diff --git a/app-sci/gromacs/gromacs-3.1.4.ebuild b/app-sci/gromacs/gromacs-3.1.4.ebuild
index e2dc15a3afc0..5d5d1cb0adc8 100644
--- a/app-sci/gromacs/gromacs-3.1.4.ebuild
+++ b/app-sci/gromacs/gromacs-3.1.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-sci/gromacs/gromacs-3.1.4.ebuild,v 1.2 2003/02/13 09:22:09 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-sci/gromacs/gromacs-3.1.4.ebuild,v 1.3 2003/03/25 09:51:20 george Exp $
IUSE=""
@@ -10,7 +10,7 @@ HOMEPAGE="http://www.gromacs.org/"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~x86"
+KEYWORDS="x86"
DEPEND=">=dev-libs/fftw-2.1.3
>=sys-devel/binutils-2.10.91.0.2"