summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorge Shapovalov <george@gentoo.org>2003-03-13 18:01:48 +0000
committerGeorge Shapovalov <george@gentoo.org>2003-03-13 18:01:48 +0000
commita32ba5a83edab6cc69bad65f232dc70bdee6e2fd (patch)
tree59bf36bdcf0aec5065d718751de84d1305eb414a /app-sci
parentversion bump (diff)
downloadhistorical-a32ba5a83edab6cc69bad65f232dc70bdee6e2fd.tar.gz
historical-a32ba5a83edab6cc69bad65f232dc70bdee6e2fd.tar.bz2
historical-a32ba5a83edab6cc69bad65f232dc70bdee6e2fd.zip
new package: Orbital Reconstruction Simulation Algorithym
Diffstat (limited to 'app-sci')
-rw-r--r--app-sci/orsa/ChangeLog10
-rw-r--r--app-sci/orsa/files/digest-orsa-0.3.0_rc11
-rw-r--r--app-sci/orsa/orsa-0.3.0_rc1.ebuild56
3 files changed, 67 insertions, 0 deletions
diff --git a/app-sci/orsa/ChangeLog b/app-sci/orsa/ChangeLog
new file mode 100644
index 000000000000..f1d439912675
--- /dev/null
+++ b/app-sci/orsa/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for app-sci/orsa
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
+# $Header: /var/cvsroot/gentoo-x86/app-sci/orsa/ChangeLog,v 1.1 2003/03/13 18:01:48 george Exp $
+
+*orsa-0.3.0_rc1.ebuild (13 Mar 2003)
+
+ 13 Mar 2003; George Shapovalov <george@gentoo.org> ChangeLog, orsa-0.3.0_rc1.ebuild, files/{digest-orsa-0.3.0_rc1} :
+ initial release (#15726)
+ ORSA Orbital Reconstruction Simulation Algorithym
+ ebuild submitted by David Cozatt <yggsdrasil@hotmail.com>
diff --git a/app-sci/orsa/files/digest-orsa-0.3.0_rc1 b/app-sci/orsa/files/digest-orsa-0.3.0_rc1
new file mode 100644
index 000000000000..1291333a4024
--- /dev/null
+++ b/app-sci/orsa/files/digest-orsa-0.3.0_rc1
@@ -0,0 +1 @@
+MD5 d61839f5d1db07c36eb73a07ba2dc98d orsa-0.3.0-rc1.tar.gz 480152
diff --git a/app-sci/orsa/orsa-0.3.0_rc1.ebuild b/app-sci/orsa/orsa-0.3.0_rc1.ebuild
new file mode 100644
index 000000000000..e2157ccf0814
--- /dev/null
+++ b/app-sci/orsa/orsa-0.3.0_rc1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-sci/orsa/orsa-0.3.0_rc1.ebuild,v 1.1 2003/03/13 18:01:48 george Exp $
+
+IUSE=""
+
+#inherit sourceforge
+inherit base
+inherit flag-o-matic
+
+Name=${P/_/-}
+S=${WORKDIR}/${Name}
+DESCRIPTION="ORSA Orbital Reconstruction Simulation Algorithym"
+SRC_URI="http://download.sourceforge.net/${PN}/${Name}.tar.gz"
+HOMEPAGE="http://${PN}.sourceforge.net"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86"
+
+DEPEND="virtual/glibc
+ dev-libs/fftw
+ dev-libs/gsl
+ x11-libs/qt
+ sys-libs/readline"
+
+
+replace-flags k6-3 i586
+replace-flags k6-2 i586
+replace-flags k6 i586
+
+src_compile() {
+
+#Avoid locking (can break parallel builds)
+
+# ./configure \
+# --host=${CHOST} \
+# --prefix=/usr \
+# --infodir=/usr/share/info \
+# --mandir=/usr/share/man || die "./configure failed"
+
+ econf || die
+ emake || die
+
+ #Uncomment the 'make check ...' line if you want to run the test suite.
+ #Note that the check.log file will be several megabytes in size.
+ #make check > ${WORKDIR}/check.log 2>&1 || die
+
+}
+
+src_install () {
+
+ einstall || die
+ dodoc AUTHORS COPYING ChangeLog INSTALL NEWS README THANKS
+
+}