summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Kursawe <phosphan@gentoo.org>2004-07-02 19:33:08 +0000
committerPatrick Kursawe <phosphan@gentoo.org>2004-07-02 19:33:08 +0000
commit82d154ab0143b025f38351240e8d1b06dfcce11b (patch)
tree26dff85cef0262fff951c3ff37a71fb22174c2b4 /app-sci
parentInitial commit. See bug #42211. (diff)
downloadhistorical-82d154ab0143b025f38351240e8d1b06dfcce11b.tar.gz
historical-82d154ab0143b025f38351240e8d1b06dfcce11b.tar.bz2
historical-82d154ab0143b025f38351240e8d1b06dfcce11b.zip
Fixing bug #54507
Diffstat (limited to 'app-sci')
-rw-r--r--app-sci/spectromatic/ChangeLog7
-rw-r--r--app-sci/spectromatic/Manifest5
-rw-r--r--app-sci/spectromatic/files/spectromatic-1.0-stringliteral.patch78
-rw-r--r--app-sci/spectromatic/spectromatic-1.0.ebuild3
4 files changed, 89 insertions, 4 deletions
diff --git a/app-sci/spectromatic/ChangeLog b/app-sci/spectromatic/ChangeLog
index d066bc9c52fa..d789b2246986 100644
--- a/app-sci/spectromatic/ChangeLog
+++ b/app-sci/spectromatic/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-sci/spectromatic
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-sci/spectromatic/ChangeLog,v 1.4 2004/06/24 22:18:23 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-sci/spectromatic/ChangeLog,v 1.5 2004/07/02 19:33:08 phosphan Exp $
+
+ 02 Jul 2004; Patrick Kursawe <phosphan@gentoo.org> spectromatic-1.0.ebuild,
+ files/spectromatic-1.0-stringliteral.patch:
+ Adding patch that replaces deprecated multiline string literals, see
+ bug #54507
19 Apr 2004; Patrick Kursawe <phosphan@gentoo.org> spectromatic-1.0.ebuild:
Changed patch to epatch
diff --git a/app-sci/spectromatic/Manifest b/app-sci/spectromatic/Manifest
index c5c70d10bba1..966ffc9904ec 100644
--- a/app-sci/spectromatic/Manifest
+++ b/app-sci/spectromatic/Manifest
@@ -1,5 +1,6 @@
-MD5 ab21ae345b6c1ac5ebe45dc6221a008d spectromatic-1.0.ebuild 890
-MD5 a3305ab479cb67c7ed0bdfc36d0d5aa1 ChangeLog 478
+MD5 d8b29c21bda7f2fc8a804f74636f5127 spectromatic-1.0.ebuild 935
+MD5 9a8489a18e7e7a5083bf2a84a7315cd5 ChangeLog 687
MD5 8c623e53daafa025137077c6b65815bd metadata.xml 156
+MD5 981e4c6dcc48b5ffbd99f76b39c32ef8 files/spectromatic-1.0-stringliteral.patch 2217
MD5 3f1f11cd807e925f279e51c239688289 files/spectromatic-1.0-gentoo.diff 603
MD5 23d4c34b3e33e1ed27f69a9d41c34220 files/digest-spectromatic-1.0 69
diff --git a/app-sci/spectromatic/files/spectromatic-1.0-stringliteral.patch b/app-sci/spectromatic/files/spectromatic-1.0-stringliteral.patch
new file mode 100644
index 000000000000..2d18f01b216a
--- /dev/null
+++ b/app-sci/spectromatic/files/spectromatic-1.0-stringliteral.patch
@@ -0,0 +1,78 @@
+diff -ru spectromatic-1.0/spectromatic.c spectromatic-1.0-new/spectromatic.c
+--- spectromatic-1.0/spectromatic.c 2002-03-30 06:17:34.000000000 +0100
++++ spectromatic-1.0-new/spectromatic.c 2004-07-02 21:25:49.485524639 +0200
+@@ -21,6 +21,7 @@
+ ****************************************************************************/
+
+ #include <stdio.h>
++#include <stdlib.h>
+ #include <malloc.h>
+ #include <png.h>
+ #include <string.h>
+@@ -37,36 +38,36 @@
+ void usage (char *pname)
+ {
+ fprintf (stderr,
+-"
+-Usage: %s [options] file.wav
+-
+-Options:
+- --window <size> FFT window size (default: 2048)
+-
+- --step <size> Slide the window by <size> samples each time
+- (default: 200)
+-
+- --inverse White/Colour-on-black
+-
+- --logarithmic Intensity is calculated by
+- log10 (1 + 9 * (amplitude / max_amp)) -
+- better for visualising weaker signals
+-
+- --combine XYZ Determines how a stereo signal is
+- represented as an RGB image. The argument is
+- a 3-character block, each character
+- corresponding to R, G and B components. It
+- may take values of L, R, A, D, X or Z,
+- meaning Left, Right, Average, Difference,
+- Cross-Correlation or Zero respectively.
+-
+- --verbose Slightly less quiet
+-
+- --version Print out the version
+-
+- --help You're in it.
+-
+-", pname);
++"\n"
++"Usage: %s [options] file.wav\n"
++"\n"
++"Options:\n"
++" --window <size> FFT window size (default: 2048)\n"
++"\n"
++" --step <size> Slide the window by <size> samples each time \n"
++" (default: 200)\n"
++"\n"
++" --inverse White/Colour-on-black\n"
++"\n"
++" --logarithmic Intensity is calculated by\n"
++" log10 (1 + 9 * (amplitude / max_amp)) -\n"
++" better for visualising weaker signals\n"
++"\n"
++" --combine XYZ Determines how a stereo signal is\n"
++" represented as an RGB image. The argument is\n"
++" a 3-character block, each character\n"
++" corresponding to R, G and B components. It\n"
++" may take values of L, R, A, D, X or Z,\n"
++" meaning Left, Right, Average, Difference,\n"
++" Cross-Correlation or Zero respectively.\n"
++"\n"
++" --verbose Slightly less quiet\n"
++"\n"
++" --version Print out the version\n"
++"\n"
++" --help You're in it.\n"
++"\n"
++, pname);
+
+
+ exit (-1);
diff --git a/app-sci/spectromatic/spectromatic-1.0.ebuild b/app-sci/spectromatic/spectromatic-1.0.ebuild
index b87ad89b96a5..25c956b6ef14 100644
--- a/app-sci/spectromatic/spectromatic-1.0.ebuild
+++ b/app-sci/spectromatic/spectromatic-1.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-sci/spectromatic/spectromatic-1.0.ebuild,v 1.5 2004/06/24 22:18:23 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-sci/spectromatic/spectromatic-1.0.ebuild,v 1.6 2004/07/02 19:33:08 phosphan Exp $
inherit eutils
@@ -21,6 +21,7 @@ src_unpack() {
unpack ${MY_P}.tar.gz
cd ${S}
epatch ${FILESDIR}/${P}-gentoo.diff
+ epatch ${FILESDIR}/${P}-stringliteral.patch
}
src_compile() {
emake || die