summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Nigbur <pyrania@gentoo.org>2003-10-02 20:04:24 +0000
committerMarkus Nigbur <pyrania@gentoo.org>2003-10-02 20:04:24 +0000
commit800a6ed74f526fc9848c56618841f9d3994f2496 (patch)
treeb0bb8e65f234ff88c302295a1ea69623312f81de /app-sci
parentversion bump #30063 (diff)
downloadhistorical-800a6ed74f526fc9848c56618841f9d3994f2496.tar.gz
historical-800a6ed74f526fc9848c56618841f9d3994f2496.tar.bz2
historical-800a6ed74f526fc9848c56618841f9d3994f2496.zip
bump
Diffstat (limited to 'app-sci')
-rw-r--r--app-sci/qcad/Manifest2
-rw-r--r--app-sci/qcad/files/digest-qcad-2.0.0.81
-rw-r--r--app-sci/qcad/qcad-2.0.0.8.ebuild40
3 files changed, 42 insertions, 1 deletions
diff --git a/app-sci/qcad/Manifest b/app-sci/qcad/Manifest
index 7c06fdd171d4..0ca1fc9369dc 100644
--- a/app-sci/qcad/Manifest
+++ b/app-sci/qcad/Manifest
@@ -1,7 +1,7 @@
MD5 455005252a4e88b056c339eca4cebf97 qcad-2.0.0.1.ebuild 898
MD5 78087931907a06e3d4bcb3d970c0f53f qcad-2.0.0.8.ebuild 906
MD5 bf3847f2e7959afa3128e1695453c6b0 qcad-1.5.4.ebuild 1043
-MD5 579a28464c508618bd0c811655130aee ChangeLog 1362
+MD5 55a2d2e46a3badb500190bca5f7b9b6c ChangeLog 1469
MD5 8c623e53daafa025137077c6b65815bd metadata.xml 156
MD5 1a2663c1af2274b28422a9a3c04a7bac files/digest-qcad-1.5.4 67
MD5 60a5ca4d64db440e1b071abd424ccfdf files/digest-qcad-2.0.0.1 71
diff --git a/app-sci/qcad/files/digest-qcad-2.0.0.8 b/app-sci/qcad/files/digest-qcad-2.0.0.8
new file mode 100644
index 000000000000..9103f74fdbce
--- /dev/null
+++ b/app-sci/qcad/files/digest-qcad-2.0.0.8
@@ -0,0 +1 @@
+MD5 47be1475525e7f792432c8bd135ec56b qcad-2.0.0.8-1.src.tar.gz 2386211
diff --git a/app-sci/qcad/qcad-2.0.0.8.ebuild b/app-sci/qcad/qcad-2.0.0.8.ebuild
new file mode 100644
index 000000000000..9e46a16faf96
--- /dev/null
+++ b/app-sci/qcad/qcad-2.0.0.8.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $ Header: $
+inherit kde-functions
+
+MY_P=${P}-1.src
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="A 2D CAD package based upon Qt."
+SRC_URI="http://www.ribbonsoft.com/archives/qcad/${MY_P}.tar.gz"
+HOMEPAGE="http://www.ribbonsoft.com/qcad.html"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc"
+
+need-qt 3
+
+DEPEND="${DEPEND}
+ >=sys-apps/sed-4"
+
+src_compile() {
+ cd ${S}/scripts
+ sed -i -e 's/^make/make ${MAKEOPTS}/' build_qcad.sh
+ sed -i -e 's/^\.\/configure/.\/configure --host=${CHOST}/' build_qcad.sh
+ sh build_qcad.sh || die "build failed"
+}
+
+src_install () {
+ cd qcad
+ mv qcad qcad.bin
+ dobin qcad.bin
+ echo -e "#!/bin/sh\ncd /usr/share/${P}\nqcad.bin" > qcad
+ chmod ugo+rx qcad
+ dobin qcad
+ dodir /usr/share/${P}
+ cp -a patterns examples fonts scripts qm ${D}/usr/share/${P}
+ cd ..
+ dodoc README
+}
+