summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Imhof <tantive@gentoo.org>2003-04-03 17:37:59 +0000
committerMichael Imhof <tantive@gentoo.org>2003-04-03 17:37:59 +0000
commit68d427df65f09698c32bb91c86ced29920761d90 (patch)
tree74e902f0e68ebe6351d19fe1fac36a5eb8fb137e /app-sci
parentAdded busybox.links into scripts dir. Closes #18678. (diff)
downloadhistorical-68d427df65f09698c32bb91c86ced29920761d90.tar.gz
historical-68d427df65f09698c32bb91c86ced29920761d90.tar.bz2
historical-68d427df65f09698c32bb91c86ced29920761d90.zip
Initial release. This ebuild was submitted by Gontran Zepeda <gontran@gontran.net>. Should close #18679.
Diffstat (limited to 'app-sci')
-rw-r--r--app-sci/clustalw/ChangeLog10
-rw-r--r--app-sci/clustalw/clustalw-1.83.ebuild37
-rw-r--r--app-sci/clustalw/files/digest-clustalw-1.831
-rw-r--r--app-sci/clustalw/files/optimize-clustalw1.83.patch13
4 files changed, 61 insertions, 0 deletions
diff --git a/app-sci/clustalw/ChangeLog b/app-sci/clustalw/ChangeLog
new file mode 100644
index 000000000000..1420a44e4ace
--- /dev/null
+++ b/app-sci/clustalw/ChangeLog
@@ -0,0 +1,10 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $ Header: $
+
+*clustalw-1.83 (04 Apr 2003)
+
+ 04 Apr 2003; Michael Imhof <tantive@gentoo.org> :
+ Initial release.
+ This ebuild was submitted by Gontran Zepeda <gontran@gontran.net>.
+ Should close #18679.
diff --git a/app-sci/clustalw/clustalw-1.83.ebuild b/app-sci/clustalw/clustalw-1.83.ebuild
new file mode 100644
index 000000000000..2af20e8d3e3f
--- /dev/null
+++ b/app-sci/clustalw/clustalw-1.83.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# Author: Gontran Zepeda <gontran@gontran.net>
+# $Header: /var/cvsroot/gentoo-x86/app-sci/clustalw/clustalw-1.83.ebuild,v 1.1 2003/04/03 17:37:59 tantive Exp $
+
+DESCRIPTION="Improving the sensitivity of progressive multiple sequence alignment through sequence weighting, position specific gap penalties and weight matrix choice."
+
+# ClustalW is ubiquitous, but this is the contact group.
+HOMEPAGE="http://www.embl-heidelberg.de/~seqanal/"
+
+# One source.
+SRC_URI="ftp://ftp.ebi.ac.uk/pub/software/unix/clustalw/${PN}${PV}.UNIX.tar.gz"
+
+LICENSE="clustalw"
+SLOT="0"
+KEYWORDS="~x86 ~sparc ~ppc ~alpha"
+IUSE=""
+DEPEND="virtual/glibc"
+
+S=${WORKDIR}/${PN}${PV}
+
+src_unpack(){
+ # let's use gentoo CFLAGS, et al.
+ unpack ${A}
+ cd ${S}
+ patch -p0 < ${FILESDIR}/optimize-${PN}${PV}.patch
+}
+src_compile() {
+ # clustalw uses only makefile. cool: stupid emake tricks.
+ EXTRA_EMAKE="-e ${CFLAGS}"
+ emake || die
+}
+src_install() {
+ # a mano
+ dobin clustalw
+ dodoc README clustalw.doc clustalw.ms clustalw_help
+}
diff --git a/app-sci/clustalw/files/digest-clustalw-1.83 b/app-sci/clustalw/files/digest-clustalw-1.83
new file mode 100644
index 000000000000..f2c2bf79faef
--- /dev/null
+++ b/app-sci/clustalw/files/digest-clustalw-1.83
@@ -0,0 +1 @@
+MD5 dc240277e5bb14ffc106d4a5fda87752 clustalw1.83.UNIX.tar.gz 166863
diff --git a/app-sci/clustalw/files/optimize-clustalw1.83.patch b/app-sci/clustalw/files/optimize-clustalw1.83.patch
new file mode 100644
index 000000000000..b987c2399a24
--- /dev/null
+++ b/app-sci/clustalw/files/optimize-clustalw1.83.patch
@@ -0,0 +1,13 @@
+--- makefile.orig 2003-03-26 16:04:35.000000000 +0000
++++ makefile 2003-03-26 16:05:42.000000000 +0000
+@@ -11,8 +11,8 @@
+ HEADERS = general.h clustalw.h
+
+ CC = cc
+-CFLAGS = -c -O
+-LFLAGS = -O -lm
++CFLAGS += -c
++LFLAGS = -lm
+
+ clustalw : $(OBJECTS) amenu.o clustalw.o
+ $(CC) -o $@ $(OBJECTS) amenu.o clustalw.o $(LFLAGS)