summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Januszewski <spock@gentoo.org>2004-01-23 16:20:13 +0000
committerMichael Januszewski <spock@gentoo.org>2004-01-23 16:20:13 +0000
commit4c2ad8a5e305758386bf7e6d35077f5b561ba71a (patch)
tree7aba61a5b479ca66500e768472353f4d8e441bdc /app-sci
parentChangelog updated (diff)
downloadhistorical-4c2ad8a5e305758386bf7e6d35077f5b561ba71a.tar.gz
historical-4c2ad8a5e305758386bf7e6d35077f5b561ba71a.tar.bz2
historical-4c2ad8a5e305758386bf7e6d35077f5b561ba71a.zip
Initial commit.
Diffstat (limited to 'app-sci')
-rw-r--r--app-sci/gimps/ChangeLog10
-rw-r--r--app-sci/gimps/Manifest6
-rw-r--r--app-sci/gimps/files/digest-gimps-23.51
-rw-r--r--app-sci/gimps/files/gimps-conf.d12
-rw-r--r--app-sci/gimps/files/gimps-init.d28
-rw-r--r--app-sci/gimps/gimps-23.5.ebuild53
-rw-r--r--app-sci/gimps/metadata.xml9
7 files changed, 119 insertions, 0 deletions
diff --git a/app-sci/gimps/ChangeLog b/app-sci/gimps/ChangeLog
new file mode 100644
index 000000000000..4578140fef87
--- /dev/null
+++ b/app-sci/gimps/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for app-sci/gimps
+# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-sci/gimps/ChangeLog,v 1.1 2004/01/23 16:20:13 spock Exp $
+
+*gimps-23.5 (23 Jan 2004)
+
+ 23 Jan 2004; Michal 'Spock' Januszewski <spock@gentoo.org>
+ gimps-23.5.ebuild, metadata.xml:
+ Initial commit, closes bug #38010.
+
diff --git a/app-sci/gimps/Manifest b/app-sci/gimps/Manifest
new file mode 100644
index 000000000000..c159e9085a2f
--- /dev/null
+++ b/app-sci/gimps/Manifest
@@ -0,0 +1,6 @@
+MD5 b3c633f15ea0a4a766357959599d301e gimps-23.5.ebuild 1410
+MD5 383d14da37a53f273696ee79e91532c5 ChangeLog 368
+MD5 d94d306da3804e41296e1bf04c7c9cae metadata.xml 255
+MD5 1e5892c6e82e3ad26032af4e0637a493 files/gimps-conf.d 283
+MD5 65ffb8ca67e7ce5e10533e82b40ae2e1 files/gimps-init.d 554
+MD5 6b074ac7234f04005d756b656851a22b files/digest-gimps-23.5 61
diff --git a/app-sci/gimps/files/digest-gimps-23.5 b/app-sci/gimps/files/digest-gimps-23.5
new file mode 100644
index 000000000000..f16612324ac4
--- /dev/null
+++ b/app-sci/gimps/files/digest-gimps-23.5
@@ -0,0 +1 @@
+MD5 176aacee43b025d687df322149adb0ee mprime235.tar.gz 417531
diff --git a/app-sci/gimps/files/gimps-conf.d b/app-sci/gimps/files/gimps-conf.d
new file mode 100644
index 000000000000..7e285f6ec2a0
--- /dev/null
+++ b/app-sci/gimps/files/gimps-conf.d
@@ -0,0 +1,12 @@
+# Config file for /etc/init.d/gimps
+
+# the number of CPUs GIMPS will use
+GIMPS_CPUS="1"
+
+# set up any options you want for GIMPS
+# for more info, `mprime -h`
+# GIMPS_OPTIONS=""
+
+# this is the directory where setiathome's run-time
+# data files will be stored
+GIMPS_DIR=/var/lib/gimps
diff --git a/app-sci/gimps/files/gimps-init.d b/app-sci/gimps/files/gimps-init.d
new file mode 100644
index 000000000000..0eab278406b5
--- /dev/null
+++ b/app-sci/gimps/files/gimps-init.d
@@ -0,0 +1,28 @@
+#!/sbin/runscript
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+
+depend() {
+ need net
+}
+
+checkconfig() {
+ if [ ! -e "${GIMPS_DIR}" ]
+ then
+ einfo "Creating ${GIMPS_DIR}"
+ mkdir "${GIMPS_DIR}"
+ fi
+}
+
+start() {
+ checkconfig
+ ebegin "Starting GIMPS"
+ nice -n 19 /opt/gimps/mprime -b${GIMPS_CPUS} -w${GIMPS_DIR} ${GIMPS_OPTIONS}
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping GIMPS"
+ killall mprime
+ eend $?
+}
diff --git a/app-sci/gimps/gimps-23.5.ebuild b/app-sci/gimps/gimps-23.5.ebuild
new file mode 100644
index 000000000000..8be45fa91983
--- /dev/null
+++ b/app-sci/gimps/gimps-23.5.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-sci/gimps/gimps-23.5.ebuild,v 1.1 2004/01/23 16:20:13 spock Exp $
+
+IUSE=""
+DESCRIPTION="GIMPS - The Great Internet Mersenne Prime Search"
+HOMEPAGE="http://mersenne.org/"
+SRC_URI="ftp://mersenne.org/gimps/mprime235.tar.gz"
+
+DEPEND=">=sys-apps/baselayout-1.8.0
+ >=sys-libs/glibc-2.1"
+SLOT="0"
+#LICENSE="as-is"
+KEYWORDS="~x86"
+
+S="${WORKDIR}"
+I="/opt/gimps"
+
+src_install () {
+
+ cd ${S}
+
+ dodir ${I} /var/lib/gimps
+ cp mprime ${D}/${I}
+ chown nobody:nogroup ${D}/${I}
+ chown nobody:nogroup ${D}/${I}/mprime
+
+ dodoc license.txt readme.txt stress.txt whatsnew.txt undoc.txt
+
+ exeinto /etc/init.d ; newexe ${FILESDIR}/gimps-init.d gimps
+ insinto /etc/conf.d ; newins ${FILESDIR}/gimps-conf.d gimps
+}
+
+pkg_postinst () {
+
+ einfo
+ einfo "You can use \`/etc/init.d/gimps start\` to start a GIMPS client in the"
+ einfo "background at boot. Have a look at /etc/conf.d/gimps and check some"
+ einfo "configuration options."
+ einfo ""
+ einfo "If you don't want to use the init script to start gimps, remember"
+ einfo "to cd into the directory where it should the data files first, eg.:"
+ einfo " cd /var/lib/gimps && ${I}/mprime"
+ einfo
+}
+
+pkg_postrm () {
+
+ einfo
+ einfo "GIMPS data files were not removed."
+ einfo "Remove them manually from /var/lib/gimps/."
+ einfo
+}
diff --git a/app-sci/gimps/metadata.xml b/app-sci/gimps/metadata.xml
new file mode 100644
index 000000000000..daa8053eefc4
--- /dev/null
+++ b/app-sci/gimps/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>no-herd</herd>
+<maintainer>
+ <email>spock@gentoo.org</email>
+ <name>Michal Januszewski</name>
+</maintainer>
+</pkgmetadata>