summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Kursawe <phosphan@gentoo.org>2003-11-11 16:20:40 +0000
committerPatrick Kursawe <phosphan@gentoo.org>2003-11-11 16:20:40 +0000
commit29bdace887c3c4c001ce515515e6349266174507 (patch)
tree0b1410188abed709292e74f39f0046c0e7a42ea2 /app-sci
parentTypo fix, binary move (diff)
downloadhistorical-29bdace887c3c4c001ce515515e6349266174507.tar.gz
historical-29bdace887c3c4c001ce515515e6349266174507.tar.bz2
historical-29bdace887c3c4c001ce515515e6349266174507.zip
Typo fix, binary move
Diffstat (limited to 'app-sci')
-rw-r--r--app-sci/predict/Manifest4
-rw-r--r--app-sci/predict/files/digest-predict-2.2.2-r11
-rw-r--r--app-sci/predict/predict-2.2.2-r1.ebuild165
3 files changed, 168 insertions, 2 deletions
diff --git a/app-sci/predict/Manifest b/app-sci/predict/Manifest
index 9e2005030a0e..dd0e85d3ef77 100644
--- a/app-sci/predict/Manifest
+++ b/app-sci/predict/Manifest
@@ -1,7 +1,7 @@
MD5 c8f528982e50242386fb046937ae475e predict-2.2.2.ebuild 4270
-MD5 8244ceab05cda4839ac2ebee5799c275 predict-2.2.2-r1.ebuild 4270
+MD5 db923275cb6b234747c7679e56c1ca15 predict-2.2.2-r1.ebuild 4339
MD5 163002f6f67fefdf7dd780158bdc45bd predict-2.2.1.ebuild 4562
-MD5 ce1fe94cee769f35bef79fcfc29285ea ChangeLog 566
+MD5 50adf65296cfa6f9375845e7b6269027 ChangeLog 720
MD5 8c623e53daafa025137077c6b65815bd metadata.xml 156
MD5 729e9f2e1ecbb139b17f650d2916da21 files/digest-predict-2.2.2-r1 66
MD5 e9851bdcd10870d0cf8dd12a543acb05 files/digest-predict-2.2.1 65
diff --git a/app-sci/predict/files/digest-predict-2.2.2-r1 b/app-sci/predict/files/digest-predict-2.2.2-r1
new file mode 100644
index 000000000000..8786565e5599
--- /dev/null
+++ b/app-sci/predict/files/digest-predict-2.2.2-r1
@@ -0,0 +1 @@
+MD5 2512bc6b584ece66de027e46f114ab53 predict-2.2.2.tar.gz 1637893
diff --git a/app-sci/predict/predict-2.2.2-r1.ebuild b/app-sci/predict/predict-2.2.2-r1.ebuild
new file mode 100644
index 000000000000..efdb0e4facce
--- /dev/null
+++ b/app-sci/predict/predict-2.2.2-r1.ebuild
@@ -0,0 +1,165 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-sci/predict/predict-2.2.2-r1.ebuild,v 1.1 2003/11/11 16:20:35 phosphan Exp $
+
+DESCRIPTION="Satellite tracking and orbital prediction."
+HOMEPAGE="http://www.qsl.net/kd2bd/predict.html"
+SRC_URI="http://www.amsat.org/amsat/ftp/software/Linux/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc"
+
+DEPEND="sys-libs/ncurses
+ gtk? ( =x11-libs/gtk+-1.2* )
+ xforms? ( x11-libs/xforms )"
+RDEPEND="gtk? ( =x11-libs/gtk+-1.2* )
+ xforms? ( x11-libs/xforms )"
+
+if [ -x /usr/bin/xearth ]; then
+ EARTHTRACKOK="yes"
+elif [ -x /usr/bin/xplanet ]; then
+ EARTHTRACKOK="yes"
+fi
+
+src_compile() {
+ # predict uses a ncurses based configure script
+ # this is what it does if it was bash based ;)
+
+ # set compiler string to a var so if compiler checks
+ # can be added at a later date
+ COMPILER="cc ${CFLAGS} -fomit-frame-pointer"
+
+ # write predict.h
+ echo "char *predictpath=\"/usr/share/predict/\";" > predict.h
+ echo "char soundcard=1;" >> predict.h
+ echo "char *version=\"${PV}\";" >> predict.h
+
+ # compile predict
+ einfo "compiling predict"
+ ${COMPILER} -L/lib -lm -lncurses -lpthread predict.c -o predict
+
+ # write vocalizer.h
+ cd vocalizer
+ echo "char *path={\"/usr/share/predict/vocalizer/\"};" > vocalizer.h
+
+ # compile vocalizer
+ einfo "compiling vocalizer"
+ ${COMPILER} vocalizer.c -o vocalizer
+
+ einfo "compiling clients"
+
+ # earthtrack
+ if test "${EARTHTRACKOK}" = "yes"; then
+ einfo "compiling earthtrack"
+ cd ${S}/clients/earthtrack
+ ${COMPILER} -lm earthtrack.c -o earthtrack
+ fi
+
+ # kep_reload
+ einfo "compiling kep_reload"
+ cd ${S}/clients/kep_reload
+ ${COMPILER} kep_reload.c -o kep_reload
+
+ # map
+ if [ "`use xforms`" ]; then
+ einfo "compiling map"
+ cd ${S}/clients/map
+ TCOMP="${COMPILER} -I/usr/X11R6/include -L/usr/X11R6/lib -lforms -lX11 -lm map.c map_cb.c map_main.c -o map"
+ ${TCOMP}
+ fi
+
+ # gsat
+ if [ "`use gtk`" ]; then
+ # note there are plugins for gsat but they are missing header files and wont compile
+ use nls || myconf="--disable-nls"
+ einfo "compiling gsat"
+ cd ${S}/clients/gsat-*
+ ./configure --prefix=/usr ${myconf}
+ cd src
+ mv globals.h globals.h.orig
+ sed -e "s:#define DEFAULTPLUGINSDIR .*:#define DEFAULTPLUGINSDIR \"/usr/lib/gsat/plugins/\":" globals.h.orig > globals.h
+ cd ..
+ emake
+ fi
+}
+
+src_install() {
+ # install predict
+ cd ${S}
+ dobin predict ${FILESDIR}/predict-update
+ dodoc CHANGES COPYING CREDITS HISTORY README
+ dodoc default/predict.*
+ dodoc docs/pdf/predict.pdf
+ dodoc docs/postscript/predict.ps
+ doman docs/man/predict.1
+
+ #install vocalizer
+ exeinto /usr/bin
+ cd vocalizer
+ doexe vocalizer
+ dodir /usr/share/predict/vocalizer
+ insinto /usr/share/predict/vocalizer
+ dosym /usr/bin/vocalizer /usr/share/predict/vocalizer/vocalizer
+ doins *.wav
+
+ mv README README.vocalizer
+ dodoc README.vocalizer
+
+ # install clients
+
+ # earthtrack
+ if test "${EARTHTRACKOK}" = "yes"; then
+ cd ${S}/clients/earthtrack
+ ln -s earthtrack earthtrack2
+ dobin earthtrack earthtrack2
+ mv README_FIRST README_FIRST.earthtrack
+ mv README README.earthtrack
+ dodoc README_FIRST.earthtrack README.earthtrack
+ fi
+
+ # kep_reload
+ cd ${S}/clients/kep_reload
+ dobin kep_reload
+ mv INSTALL INSTALL.kep_reload
+ mv README README.kep_reload
+ dodoc INSTALL.kep_reload README.kep_reload
+
+ # map
+ if [ "`use xforms`" ]; then
+ cd ${S}/clients/map
+ dobin map
+ for i in CHANGES README COPYING; do
+ mv ${i} ${i}.map
+ dodoc ${i}.map
+ done
+ fi
+
+ # gsat
+ if [ "`use gtk`" ]; then
+ # the install seems broken so do manually...
+ cd ${S}/clients/gsat-*
+ dodir /usr/lib/gsat/plugins
+ touch ${D}/usr/lib/gsat/plugins/.keep
+ cd src
+ dobin gsat
+ cd ..
+ for i in AUTHORS ABOUT-NLS COPYING ChangeLog INSTALL NEWS README Plugin_API; do
+ mv ${i} ${i}.gsat
+ dodoc ${i}.gsat
+ done
+ fi
+}
+
+pkg_postinst() {
+ einfo "to use the clients the following line will"
+ einfo "have to be inserted into /etc/services"
+ einfo "predict 1210/udp"
+ einfo "the port can be changed to anything"
+ einfo "the name predict is what is needed to work"
+ einfo "after that is set run 'predict -s'"
+ einfo ""
+ einfo "to get list of satellites run 'predict-update'"
+ einfo "before running predict this script will also update"
+ einfo "the list of satellites so they are up to date."
+}