summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-04-07 19:56:39 +0000
committerMike Frysinger <vapier@gentoo.org>2004-04-07 19:56:39 +0000
commit5f50440f899646e16c91645784aeafea20d92b8f (patch)
tree3f6484978dfe1fd00cebb5f495f3ffcb1d4278d4 /app-sci/molden
parentMarked stable on mips. (diff)
downloadhistorical-5f50440f899646e16c91645784aeafea20d92b8f.tar.gz
historical-5f50440f899646e16c91645784aeafea20d92b8f.tar.bz2
historical-5f50440f899646e16c91645784aeafea20d92b8f.zip
add inherit eutils
Diffstat (limited to 'app-sci/molden')
-rw-r--r--app-sci/molden/molden-4.0.ebuild16
1 files changed, 10 insertions, 6 deletions
diff --git a/app-sci/molden/molden-4.0.ebuild b/app-sci/molden/molden-4.0.ebuild
index fd85a85166d2..4fa4915cd8b6 100644
--- a/app-sci/molden/molden-4.0.ebuild
+++ b/app-sci/molden/molden-4.0.ebuild
@@ -1,19 +1,24 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-sci/molden/molden-4.0.ebuild,v 1.2 2004/04/05 03:09:03 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-sci/molden/molden-4.0.ebuild,v 1.3 2004/04/07 19:56:39 vapier Exp $
+
+inherit eutils gcc
MY_P="${PN}${PV}"
DESCRIPTION="Display molecular density from GAMESS-UK, GAMESS-US, GAUSSIAN and Mopac/Ampac."
HOMEPAGE="http://www.cmbi.kun.nl/~schaft/molden/molden.html"
SRC_URI="ftp://ftp.cmbi.kun.nl/pub/molgraph/${PN}/${MY_P}.tar.Z"
+
LICENSE="as-is"
SLOT="0"
KEYWORDS="~x86 ~ia64"
IUSE="opengl"
+
DEPEND=""
RDEPEND="virtual/x11
opengl? ( media-libs/glut )"
-S="${WORKDIR}/${MY_P}"
+
+S=${WORKDIR}/${MY_P}
src_unpack() {
unpack ${A}
@@ -23,7 +28,7 @@ src_unpack() {
# assuming people don't stupidly remove 3.9 patch with 3.9
epatch ${FILESDIR}/${PN}-3.9-fixMakefile.patch
# Respect $CC
- sed -i -e "s:^CC = cc:CC = ${CC}:g" ${S}/makefile
+ sed -i -e "s:^CC = cc:CC = $(gcc-getCC):g" ${S}/makefile
# Respect $CFLAGS
sed -i -e "s:^CFLAGS = :CFLAGS = ${CFLAGS} :g" ${S}/makefile
# Respect $FC if set
@@ -48,9 +53,8 @@ src_compile() {
src_install() {
dobin molden
- use opengl && \
- dobin moldenogl
- dodoc CopyRight HISTORY README REGISTER
+ use opengl && dobin moldenogl
+ dodoc HISTORY README REGISTER
cd doc
uncompress *
dodoc *