summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorge Shapovalov <george@gentoo.org>2003-10-29 01:53:08 +0000
committerGeorge Shapovalov <george@gentoo.org>2003-10-29 01:53:08 +0000
commit8b067855a196a14f8fdbf3c73f1eb9d475b7c59b (patch)
treeebcfaf5c72df76ea81c2cb6d4f262e47ee3da7e0 /app-sci/blas
parentmasked blas-19940131 until the whole blas transition is ready (diff)
downloadhistorical-8b067855a196a14f8fdbf3c73f1eb9d475b7c59b.tar.gz
historical-8b067855a196a14f8fdbf3c73f1eb9d475b7c59b.tar.bz2
historical-8b067855a196a14f8fdbf3c73f1eb9d475b7c59b.zip
this is a real version date + this one provides both static and dynamic libs. Masked until the whole blas transition is ready
Diffstat (limited to 'app-sci/blas')
-rw-r--r--app-sci/blas/ChangeLog14
-rw-r--r--app-sci/blas/Manifest10
-rw-r--r--app-sci/blas/blas-19940131.ebuild92
-rw-r--r--app-sci/blas/files/Makefile.bz2bin0 -> 1027 bytes
-rw-r--r--app-sci/blas/files/digest-blas-199401311
-rw-r--r--app-sci/blas/files/f77-reference14
6 files changed, 126 insertions, 5 deletions
diff --git a/app-sci/blas/ChangeLog b/app-sci/blas/ChangeLog
index bed5acae7beb..682eef502bae 100644
--- a/app-sci/blas/ChangeLog
+++ b/app-sci/blas/ChangeLog
@@ -1,8 +1,18 @@
# ChangeLog for app-sci/blas
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-sci/blas/ChangeLog,v 1.3 2003/02/12 05:15:30 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-sci/blas/ChangeLog,v 1.4 2003/10/29 01:53:01 george Exp $
- 02 Nov 2002; Hannes Mehnert <hannes@gentoo.org> blsa-19980702.ebuild:
+*blas-19940131 (27 Oct 2003)
+
+ 27 Oct 2003; George Shapovalov <george@gentoo.org> blas-19940131.ebuild, files/{Makefile.bz2,f77-reference} :
+ a "real" version (#30462),
+ according to code this is when last modifications were made.
+ This version provides both static and shared library.
+ This is a part of a large ehnahcement of blas support in portage (#30453)
+ package-masked for now
+ thanks to Derek Dolney <dolney@astro.physics.upenn.edu> for the "fix"
+
+ 02 Nov 2002; Hannes Mehnert <hannes@gentoo.org> blas-19980702.ebuild:
marked stable for x86
*blas-19980702 (31 Oct 2002)
diff --git a/app-sci/blas/Manifest b/app-sci/blas/Manifest
index d3f3988ee459..b085aa7c57d5 100644
--- a/app-sci/blas/Manifest
+++ b/app-sci/blas/Manifest
@@ -1,5 +1,9 @@
-MD5 1061bd61ecbed7462c7a8e8df335561c files/Makefile 1559
-MD5 ba7949ab229d3b52516732fc47caebeb files/digest-blas-19980702 52
MD5 c25009bd86eb6cf58c52686931176dbe blas-19980702.ebuild 571
-MD5 db1ff5fe43e39746cd473d93846714d6 ChangeLog 434
+MD5 9d5af381778b537f087ab24abddc1653 blas-19940131.ebuild 2181
+MD5 39e939b90e32b9d0daaae62d9cb95246 ChangeLog 899
MD5 8c623e53daafa025137077c6b65815bd metadata.xml 156
+MD5 1061bd61ecbed7462c7a8e8df335561c files/Makefile 1559
+MD5 2d7bae33a1553ed8eccbdb971a459ff2 files/f77-reference 396
+MD5 506dd7c8d76dd6213ad9e532346033b5 files/Makefile.bz2 1027
+MD5 ba7949ab229d3b52516732fc47caebeb files/digest-blas-19940131 52
+MD5 ba7949ab229d3b52516732fc47caebeb files/digest-blas-19980702 52
diff --git a/app-sci/blas/blas-19940131.ebuild b/app-sci/blas/blas-19940131.ebuild
new file mode 100644
index 000000000000..95a3ad136a06
--- /dev/null
+++ b/app-sci/blas/blas-19940131.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-sci/blas/blas-19940131.ebuild,v 1.1 2003/10/29 01:53:01 george Exp $
+
+DESCRIPTION="FORTRAN reference implementation of the BLAS (linear algebra lib)"
+HOMEPAGE="http://www.netlib.org/blas/"
+SRC_URI="http://www.netlib.org/blas/${PN}.tgz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="ifc"
+
+DEPEND="app-sci/blas-config
+ sys-devel/libtool
+ ifc? ( dev-lang/ifc )"
+
+RDEPEND="ifc? ( dev-lang/ifc )" # Need ifc runtime libraries
+
+PROVIDE="virtual/blas"
+
+S=${WORKDIR}
+
+ifc_info() {
+ if [ -z "${IFCFLAGS}" ]
+ then
+ einfo
+ einfo "You may want to set some ifc optimization flags by running this"
+ einfo "ebuild as, for example, \`IFCFLAGS=\"-O3 -tpp7 -xW\" emerge blas\`"
+ einfo "(Pentium 4 exclusive optimizations)."
+ einfo
+ einfo "ifc defaults to -O2, with code tuned for Pentium 4, but that"
+ einfo "will run on any processor."
+ einfo
+ einfo "Beware that ifc's -O3 is very aggressive, sometimes resulting in"
+ einfo "significantly worse performance."
+ einfo
+ sleep 5
+ fi
+}
+
+src_compile() {
+ cd ${S}
+ cp ${FILESDIR}/Makefile.bz2 .
+ bunzip2 Makefile.bz2
+
+ # Profile information will be installed in TOP_PATH:
+ TOP_PATH=${DESTTREE}/lib/blas
+ # Libraries will be installed in RPATH:
+ RPATH=${TOP_PATH}/reference
+
+ if [ "`use ifc`" ]
+ then
+ ifc_info
+ make static FC="ifc" FFLAGS="${IFCFLAGS}"
+ ifc -shared ${IFCFLAGS} \
+ -Wl,-soname,libblas.so.0 -o libblas.so.0.0.0 *.lo
+ else
+ # libg2c is required to link to libblas.so using ifc:
+ make libs \
+ FC="g77" \
+ FFLAGS="${CFLAGS}" \
+ LIBTOOL_FLAGS="-rpath ${RPATH} -lg2c" \
+ || die
+ fi
+}
+
+src_install() {
+ if [ "`use ifc`" ]
+ then
+ strip --strip-unneeded libblas.so.0.0.0
+ strip --strip-debug libblas.a
+
+ exeinto ${RPATH}
+ doexe libblas.so.0.0.0
+ dosym libblas.so.0.0.0 ${RPATH}/libblas.so.0
+ dosym libblas.so.0.0.0 ${RPATH}/libblas.so
+
+ insinto ${RPATH}
+ doins libblas.a
+ else
+ dodir ${RPATH}
+ libtool install -s libblas.la ${D}/${RPATH}
+ fi
+
+ insinto ${TOP_PATH}
+ doins ${FILESDIR}/f77-reference
+}
+
+pkg_postinst() {
+ blas-config f77-reference
+}
diff --git a/app-sci/blas/files/Makefile.bz2 b/app-sci/blas/files/Makefile.bz2
new file mode 100644
index 000000000000..f245ae4d8807
--- /dev/null
+++ b/app-sci/blas/files/Makefile.bz2
Binary files differ
diff --git a/app-sci/blas/files/digest-blas-19940131 b/app-sci/blas/files/digest-blas-19940131
new file mode 100644
index 000000000000..41ce05f23e36
--- /dev/null
+++ b/app-sci/blas/files/digest-blas-19940131
@@ -0,0 +1 @@
+MD5 5811e4b3dffa7a10956abf923cec1bd4 blas.tgz 94981
diff --git a/app-sci/blas/files/f77-reference b/app-sci/blas/files/f77-reference
new file mode 100644
index 000000000000..912d84403cd5
--- /dev/null
+++ b/app-sci/blas/files/f77-reference
@@ -0,0 +1,14 @@
+F77LIBS="-L/usr/lib/blas/reference -lblas"
+
+setup() {
+
+einfo "/usr/lib/libblas.so -> blas/reference/libblas.so"
+ln -sf blas/reference/libblas.so /usr/lib/libblas.so
+
+einfo "/usr/lib/libblas.so.0 -> blas/reference/libblas.so.0"
+ln -sf blas/reference/libblas.so.0 /usr/lib/libblas.so.0
+
+einfo "/usr/lib/libblas.a -> blas/reference/libblas.a"
+ln -sf blas/reference/libblas.a /usr/lib/libblas.a
+
+}