summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Hill <rhill@gentoo.org>2011-02-26 05:35:51 +0000
committerRyan Hill <rhill@gentoo.org>2011-02-26 05:35:51 +0000
commitaac5de801420af05269b2165cc55ff9c87fa38a2 (patch)
tree793647c7938f2c5b46ba2c51175e328ea1555030 /app-pda/msynctool/msynctool-0.22.ebuild
parentVersion bump (diff)
downloadhistorical-aac5de801420af05269b2165cc55ff9c87fa38a2.tar.gz
historical-aac5de801420af05269b2165cc55ff9c87fa38a2.tar.bz2
historical-aac5de801420af05269b2165cc55ff9c87fa38a2.zip
EAPI 3, dependencies, docs, etc.
Package-Manager: portage-2.2.0_alpha25/cvs/Linux x86_64
Diffstat (limited to 'app-pda/msynctool/msynctool-0.22.ebuild')
-rw-r--r--app-pda/msynctool/msynctool-0.22.ebuild23
1 files changed, 17 insertions, 6 deletions
diff --git a/app-pda/msynctool/msynctool-0.22.ebuild b/app-pda/msynctool/msynctool-0.22.ebuild
index 2f9801a5e34e..d4c36c8d3608 100644
--- a/app-pda/msynctool/msynctool-0.22.ebuild
+++ b/app-pda/msynctool/msynctool-0.22.ebuild
@@ -1,20 +1,31 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-pda/msynctool/msynctool-0.22.ebuild,v 1.2 2007/09/08 04:09:55 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-pda/msynctool/msynctool-0.22.ebuild,v 1.3 2011/02/26 05:32:34 dirtyepic Exp $
+
+EAPI="3"
DESCRIPTION="OpenSync msync tool"
HOMEPAGE="http://www.opensync.org/"
-SRC_URI="http://dev.gentooexperimental.org/~peper/distfiles/${P}.tar.bz2"
+SRC_URI="http://www.opensync.org/downloads/releases/${PV}/${P}.tar.bz2"
KEYWORDS="~amd64 ~ppc ~x86"
SLOT="0"
LICENSE="GPL-2"
IUSE=""
-DEPEND="=app-pda/libopensync-${PV}*"
-RDEPEND="${DEPEND}"
+RDEPEND="~app-pda/libopensync-${PV}
+ dev-libs/glib:2
+ dev-libs/libxml2"
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.9.0"
+
+src_prepare() {
+ sed -i -e 's: -Werror::g' \
+ -e 's: -R $(libdir)::g' \
+ tools/Makefile.in
+}
src_install() {
emake DESTDIR="${D}" install || die "emake install failed"
- dodoc AUTHORS ChangeLog NEWS README TODO
+ dodoc AUTHORS README
}