summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrandon Low <lostlogic@gentoo.org>2002-06-06 13:57:01 +0000
committerBrandon Low <lostlogic@gentoo.org>2002-06-06 13:57:01 +0000
commit91718b680b81693529b443e309f734eee4a97f54 (patch)
tree9f6dbdac862a7d299a6b2e874b82e7ceda4023f1 /app-office
parentjack-audio-connection-kit added. (New package) (diff)
downloadhistorical-91718b680b81693529b443e309f734eee4a97f54.tar.gz
historical-91718b680b81693529b443e309f734eee4a97f54.tar.bz2
historical-91718b680b81693529b443e309f734eee4a97f54.zip
Typo fix
Diffstat (limited to 'app-office')
-rw-r--r--app-office/siag/ChangeLog8
-rw-r--r--app-office/siag/files/digest-siag-3.5.2-r11
-rw-r--r--app-office/siag/siag-3.5.2-r1.ebuild49
3 files changed, 56 insertions, 2 deletions
diff --git a/app-office/siag/ChangeLog b/app-office/siag/ChangeLog
index bd2304ad0c0e..f73defaae22e 100644
--- a/app-office/siag/ChangeLog
+++ b/app-office/siag/ChangeLog
@@ -1,10 +1,14 @@
# ChangeLog for app-office/siag
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/app-office/siag/ChangeLog,v 1.2 2002/06/05 05:07:34 lostlogic Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/siag/ChangeLog,v 1.3 2002/06/06 13:57:01 lostlogic Exp $
*siag-3.5.2 (5 Jun 2002)
- 5 Jun 2002; G.Bevin <lostlogic@gentoo.org> ChangeLog : siag-3.5.2.ebuild
+ 6 Jun 2002; Brandon Low <lostlogic@gentoo.org> siag-3.5.2-r1.ebuild
+
+ Fix stupid but important typo /usr != /use
+
+ 5 Jun 2002; Brandon Low <lostlogic@gentoo.org> ChangeLog : siag-3.5.2.ebuild
Updated version, no type 1 font support for now, causes problems for some people.
This version is significantly updated from 3.4.7, read the ChangeLog on the siag
diff --git a/app-office/siag/files/digest-siag-3.5.2-r1 b/app-office/siag/files/digest-siag-3.5.2-r1
new file mode 100644
index 000000000000..a5c41821208e
--- /dev/null
+++ b/app-office/siag/files/digest-siag-3.5.2-r1
@@ -0,0 +1 @@
+MD5 80169faebe7bca9fd531b53b6c5d3ed5 siag-3.5.2.tar.gz 1514672
diff --git a/app-office/siag/siag-3.5.2-r1.ebuild b/app-office/siag/siag-3.5.2-r1.ebuild
new file mode 100644
index 000000000000..fe37b84db0eb
--- /dev/null
+++ b/app-office/siag/siag-3.5.2-r1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/app-office/siag/siag-3.5.2-r1.ebuild,v 1.1 2002/06/06 13:57:01 lostlogic Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="A free Office package for Linux"
+SRC_URI="ftp://siag.nu/pub/siag/${P}.tar.gz"
+HOMEPAGE="http://siag.nu/"
+
+DEPEND="virtual/x11
+ >=dev-libs/gmp-3.1.1
+ >=media-libs/xpm-3.4
+ >=x11-misc/mowitz-0.2.1
+ >=dev-lang/tcl-8.0.0"
+# >=media-libs/t1lib-1.0.1"
+
+RDEPEND="virtual/x11"
+# >=media-libs/t1lib-1.0.1"
+
+src_compile() {
+
+ local myconf
+#Causes segfaults in 3.5.2 on my system...
+# if [ "`use guile`" ]
+# then
+# myconf="$myconf --with-guile"
+# else
+# myconf="$myconf --without-guile"
+# fi
+ ./configure --prefix=/usr \
+ --with-x \
+ --with-xawm="Xaw" \
+ --mandir=/usr/share/man \
+ --host=${CHOST} \
+ --with-tcl \
+ --with-gmp \
+ $myconf || die "Configure failed"
+# --with-t1lib \
+
+ make || die "Make failed"
+
+}
+
+src_install () {
+
+ make DESTDIR=${D} install || die "Install failed"
+}
+