summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2002-12-01 09:25:48 +0000
committerMartin Schlemmer <azarah@gentoo.org>2002-12-01 09:25:48 +0000
commit7e4098b0bf8b541701cc60528e294a109d5cdd15 (patch)
tree70f10d0468370548931cd4f666d91dc06b932680 /app-office
parent0.5.5 as stable x86 (diff)
downloadhistorical-7e4098b0bf8b541701cc60528e294a109d5cdd15.tar.gz
historical-7e4098b0bf8b541701cc60528e294a109d5cdd15.tar.bz2
historical-7e4098b0bf8b541701cc60528e294a109d5cdd15.zip
use .tar.bz2 of freetype. use epatch()
Diffstat (limited to 'app-office')
-rw-r--r--app-office/openoffice/ChangeLog6
-rw-r--r--app-office/openoffice/files/digest-openoffice-1.0.1-r12
-rw-r--r--app-office/openoffice/openoffice-1.0.1-r1.ebuild37
3 files changed, 25 insertions, 20 deletions
diff --git a/app-office/openoffice/ChangeLog b/app-office/openoffice/ChangeLog
index 344ae15b9f41..b9947fb6e3e9 100644
--- a/app-office/openoffice/ChangeLog
+++ b/app-office/openoffice/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-office/openoffice
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/app-office/openoffice/ChangeLog,v 1.11 2002/11/05 21:56:31 gerk Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/openoffice/ChangeLog,v 1.12 2002/12/01 09:25:48 azarah Exp $
+
+ 01 Dec 2002; Martin Schlemmer <azarah@gentoo.org> openoffice-1.0.1.ebuild-r1 :
+ Change it to use freetype-2.1.2.tar.bz2, as I was braindead at the time
+ and used the .tar.gz. Also convert to use epatch().
*openoffice-1.0.1-r1 (22 Sep 2002)
diff --git a/app-office/openoffice/files/digest-openoffice-1.0.1-r1 b/app-office/openoffice/files/digest-openoffice-1.0.1-r1
index d72bfab15c97..d32aea91530a 100644
--- a/app-office/openoffice/files/digest-openoffice-1.0.1-r1
+++ b/app-office/openoffice/files/digest-openoffice-1.0.1-r1
@@ -1,4 +1,4 @@
MD5 34f2ca644b7d70573148c82d64eb6064 OOo_1.0.1_source.tar.bz2 136458398
MD5 cd4dd34b623a8704fbc800de79705171 STLport-4.5.3.tar.gz 739943
MD5 fdb06fdb5a4670b172f9fb738b717be9 gpc231.tar.Z 27917
-MD5 6574ebc4c33a175b54b73d94f681f39f freetype-2.1.2.tar.gz 950508
+MD5 23d04bf0cfc48772b8d698c95eec37bd freetype-2.1.2.tar.bz2 742830
diff --git a/app-office/openoffice/openoffice-1.0.1-r1.ebuild b/app-office/openoffice/openoffice-1.0.1-r1.ebuild
index d59488e723cf..6a134c7b3ad6 100644
--- a/app-office/openoffice/openoffice-1.0.1-r1.ebuild
+++ b/app-office/openoffice/openoffice-1.0.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/openoffice/openoffice-1.0.1-r1.ebuild,v 1.5 2002/11/05 21:56:31 gerk Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/openoffice/openoffice-1.0.1-r1.ebuild,v 1.6 2002/12/01 09:25:48 azarah Exp $
# IMPORTANT: This is extremely alpha!!!
@@ -26,7 +26,7 @@
# Get support going for installing a custom language pack. Also
# need to be able to install more than one language pack.
-inherit flag-o-matic
+inherit flag-o-matic eutils
# Compile problems with these ...
filter-flags "-funroll-loops"
filter-flags "-fomit-frame-pointer"
@@ -58,7 +58,7 @@ SRC_URI="http://ny1.mirror.openoffice.org/${PV}/OOo_${PV}_source.tar.bz2
http://sf1.mirror.openoffice.org/${PV}/OOo_${PV}_source.tar.bz2
http://www.stlport.org/archive/STLport-${STLP_VER}.tar.gz
ftp://ftp.cs.man.ac.uk/pub/toby/gpc/gpc231.tar.Z
- mirror://sourceforge/freetype/freetype-2.1.2.tar.gz"
+ mirror://sourceforge/freetype/freetype-2.1.2.tar.bz2"
HOMEPAGE="http://www.openoffice.org/"
LICENSE="LGPL-2 | SISSL-1.1"
@@ -155,57 +155,58 @@ src_unpack() {
einfo "Applying patches..."
# This allows JDK 1.4.0 to be used (Prez)
- patch -p1 < ${FILESDIR}/${PV}/${PN}-1.0.0-configure.patch || die
+ epatch ${FILESDIR}/${PV}/${PN}-1.0.0-configure.patch
# Get OO to build with gcc-3.2's libstdc++.so (Az)
if [ "$(gcc-version)" = "3.2" ]
then
- patch -p1 < ${FILESDIR}/${PV}/${P}-use-libstdc++-5.0.0.patch || die
+ epatch ${FILESDIR}/${PV}/${P}-use-libstdc++-5.0.0.patch
fi
# Debian patch to enable build of zipdep
- patch -p1 < ${FILESDIR}/${PV}/${PN}-1.0.0-zipdep-not-found.patch || die
+ epatch ${FILESDIR}/${PV}/${PN}-1.0.0-zipdep-not-found.patch
# Some Debian patches to get the build to use $CC and $CXX,
# thanks to nidd from #openoffice.org
- patch -p1 < ${FILESDIR}/${PV}/${P}-gcc-version-check.patch || die
- patch -p1 < ${FILESDIR}/${PV}/${P}-set-compiler-vars.patch || die
- patch -p1 < ${FILESDIR}/${PV}/${P}-use-compiler-vars.patch || die
+ epatch ${FILESDIR}/${PV}/${P}-gcc-version-check.patch
+ epatch ${FILESDIR}/${PV}/${P}-set-compiler-vars.patch
+ epatch ${FILESDIR}/${PV}/${P}-use-compiler-vars.patch
# Update configure before we do anything else.
cd ${S}/config_office; autoconf || die; cd ${S}
# This resolves missing symbols (Debian)
- patch -p1 < ${FILESDIR}/${PV}/${P}-compiler-flags.patch || die
+ epatch ${FILESDIR}/${PV}/${P}-compiler-flags.patch
# Enable ccache and distcc (Debian)
- patch -p1 < ${FILESDIR}/${PV}/${P}-parallel-build.patch || die
+ epatch ${FILESDIR}/${PV}/${P}-parallel-build.patch
# If $HOME is not set, ccache breaks. (Debian)
- patch -p1 < ${FILESDIR}/${PV}/${P}-dont-unset-home.patch || die
+ epatch ${FILESDIR}/${PV}/${P}-dont-unset-home.patch
if [ "$(use ppc)" ]
then
# Not sure about this .. PPC guys will have to verify.
- patch -p1 < ${FILESDIR}/${PV}/${P}-bridge-fix-on-PPC.patch || die
+ epatch ${FILESDIR}/${PV}/${P}-bridge-fix-on-PPC.patch
fi
# Misc Debian patches to fixup build
- patch -p1 < ${FILESDIR}/${PV}/${PN}-1.0.1-no-mozab.patch || die
+ epatch ${FILESDIR}/${PV}/${PN}-1.0.1-no-mozab.patch
+ rm -f ${S}/moz/prj/build.lst
echo "moz moz : NULL" > ${S}/moz/prj/build.lst
# Misc patches from Mandrake
- patch -p1 < ${FILESDIR}/${PV}/${P}-braindamage.patch || die
- patch -p1 < ${FILESDIR}/${PV}/${P}-fix-asm.patch || die
+ epatch ${FILESDIR}/${PV}/${P}-braindamage.patch
+ epatch ${FILESDIR}/${PV}/${P}-fix-asm.patch
# Get OO to use STLport-4.5.3 (Az)
cp ${DISTDIR}/STLport-${STLP_VER}.tar.gz ${S}/stlport/download || die
cd ${S}/stlport
- patch -p1 < ${FILESDIR}/${PV}/${P}-use-STLport-4.5.3.patch || die
+ epatch ${FILESDIR}/${PV}/${P}-use-STLport-4.5.3.patch
# Get OO to build with freetype-2.1.2
cd ${S}
cp ${DISTDIR}/freetype-${FT_VER}.tar.gz ${S}/freetype/download || die
cp ${FILESDIR}/${PV}/freetype-${FT_VER}.patch ${S}/freetype || die
- patch -p1 < ${FILESDIR}/${PV}/${P}-use-freetype-${FT_VER}.patch || die
+ epatch ${FILESDIR}/${PV}/${P}-use-freetype-${FT_VER}.patch
# More gcc3 related fixes
if [ "$(gcc-major-version)" -eq 3 ] && [ "$(gcc-minor-version)" -ne 0 ]