summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2004-06-02 12:36:09 +0000
committerAron Griffis <agriffis@gentoo.org>2004-06-02 12:36:09 +0000
commit69a47ea8f56eda2fd5ff8ba399b1b0da662e1837 (patch)
treea5812cc232807a2213aaf68230cf91fa51064c53 /app-office
parentInitial commit, #51595 (diff)
downloadhistorical-69a47ea8f56eda2fd5ff8ba399b1b0da662e1837.tar.gz
historical-69a47ea8f56eda2fd5ff8ba399b1b0da662e1837.tar.bz2
historical-69a47ea8f56eda2fd5ff8ba399b1b0da662e1837.zip
Fix use invocation
Diffstat (limited to 'app-office')
-rw-r--r--app-office/gnumeric/ChangeLog7
-rw-r--r--app-office/gnumeric/gnumeric-1.0.13-r1.ebuild16
-rw-r--r--app-office/gnumeric/gnumeric-1.2.12.ebuild2
-rw-r--r--app-office/gnumeric/gnumeric-1.2.4.ebuild2
-rw-r--r--app-office/gnumeric/gnumeric-1.2.6.ebuild2
-rw-r--r--app-office/openoffice/ChangeLog7
-rw-r--r--app-office/openoffice/openoffice-1.0.3-r2.ebuild6
-rw-r--r--app-office/openoffice/openoffice-1.1.0-r4.ebuild6
-rw-r--r--app-office/openoffice/openoffice-1.1.0-r5.ebuild6
-rw-r--r--app-office/openoffice/openoffice-1.1.1-r1.ebuild8
10 files changed, 36 insertions, 26 deletions
diff --git a/app-office/gnumeric/ChangeLog b/app-office/gnumeric/ChangeLog
index 4c2b3d4cf153..9a83e001e562 100644
--- a/app-office/gnumeric/ChangeLog
+++ b/app-office/gnumeric/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-office/gnumeric
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/gnumeric/ChangeLog,v 1.62 2004/06/02 08:00:32 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/gnumeric/ChangeLog,v 1.63 2004/06/02 12:33:20 agriffis Exp $
+
+ 02 Jun 2004; Aron Griffis <agriffis@gentoo.org> gnumeric-1.0.13-r1.ebuild,
+ gnumeric-1.2.12.ebuild, gnumeric-1.2.2.ebuild, gnumeric-1.2.4.ebuild,
+ gnumeric-1.2.6.ebuild:
+ Fix use invocation
02 Jun 2004; Michael Sterrett <mr_bones_@gentoo.org> gnumeric-1.2.2.ebuild:
sync IUSE
diff --git a/app-office/gnumeric/gnumeric-1.0.13-r1.ebuild b/app-office/gnumeric/gnumeric-1.0.13-r1.ebuild
index 4c6fac78f1b7..cc47d0468a48 100644
--- a/app-office/gnumeric/gnumeric-1.0.13-r1.ebuild
+++ b/app-office/gnumeric/gnumeric-1.0.13-r1.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
# Maintainer: Martin Schlemmer <azarah@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/app-office/gnumeric/gnumeric-1.0.13-r1.ebuild,v 1.8 2004/05/30 08:27:47 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/gnumeric/gnumeric-1.0.13-r1.ebuild,v 1.9 2004/06/02 12:33:20 agriffis Exp $
inherit virtualx libtool gnome.org
@@ -49,32 +49,32 @@ src_compile() {
elibtoolize
local myconf=""
- if [ -n "`use gb`" ]; then
+ if use gb; then
myconf="${myconf} --with-gb"
else
myconf="${myconf} --without-gb"
fi
- if [ -n "`use perl`" ]; then
+ if use perl; then
myconf="${myconf} --with-perl"
else
myconf="${myconf} --without-perl"
fi
- if [ -n "`use python`" ]; then
+ if use python; then
myconf="${myconf} --with-python"
else
myconf="${myconf} --without-python"
fi
- if [ -n "`use libgda`" ]; then
+ if use libgda; then
myconf="${myconf} --with-gda --with-bonobo"
else
myconf="${myconf} --without-gda"
fi
- if [ -n "`use evo`" ]; then
+ if use evo; then
myconf="${myconf} --with-evolution"
fi
- if [ -n "`use bonobo`" ]; then
+ if use bonobo; then
myconf="${myconf} --with-bonobo"
- elif [ -z "`use libgda`" ]; then
+ elif ! use libgda; then
myconf="${myconf} --without-bonobo"
fi
diff --git a/app-office/gnumeric/gnumeric-1.2.12.ebuild b/app-office/gnumeric/gnumeric-1.2.12.ebuild
index a54db3fa7f73..d73740dc12da 100644
--- a/app-office/gnumeric/gnumeric-1.2.12.ebuild
+++ b/app-office/gnumeric/gnumeric-1.2.12.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/gnumeric/gnumeric-1.2.12.ebuild,v 1.1 2004/05/05 13:50:03 foser Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/gnumeric/gnumeric-1.2.12.ebuild,v 1.2 2004/06/02 12:33:20 agriffis Exp $
#provide Xmake and Xemake
inherit virtualx libtool gnome2 eutils flag-o-matic
diff --git a/app-office/gnumeric/gnumeric-1.2.4.ebuild b/app-office/gnumeric/gnumeric-1.2.4.ebuild
index 2b4032b75329..3a7bb951215a 100644
--- a/app-office/gnumeric/gnumeric-1.2.4.ebuild
+++ b/app-office/gnumeric/gnumeric-1.2.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/gnumeric/gnumeric-1.2.4.ebuild,v 1.4 2004/01/30 05:24:38 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/gnumeric/gnumeric-1.2.4.ebuild,v 1.5 2004/06/02 12:33:20 agriffis Exp $
#provide Xmake and Xemake
inherit virtualx libtool gnome2 eutils
diff --git a/app-office/gnumeric/gnumeric-1.2.6.ebuild b/app-office/gnumeric/gnumeric-1.2.6.ebuild
index 0b1df20b526d..31adb13e311b 100644
--- a/app-office/gnumeric/gnumeric-1.2.6.ebuild
+++ b/app-office/gnumeric/gnumeric-1.2.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/gnumeric/gnumeric-1.2.6.ebuild,v 1.5 2004/04/06 20:25:54 gmsoft Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/gnumeric/gnumeric-1.2.6.ebuild,v 1.6 2004/06/02 12:33:20 agriffis Exp $
#provide Xmake and Xemake
inherit virtualx libtool gnome2 eutils flag-o-matic
diff --git a/app-office/openoffice/ChangeLog b/app-office/openoffice/ChangeLog
index afeffe5a603f..b505685911fe 100644
--- a/app-office/openoffice/ChangeLog
+++ b/app-office/openoffice/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-office/openoffice
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/openoffice/ChangeLog,v 1.74 2004/05/25 13:12:32 weeve Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/openoffice/ChangeLog,v 1.75 2004/06/02 12:36:09 agriffis Exp $
+
+ 02 Jun 2004; Aron Griffis <agriffis@gentoo.org> openoffice-1.0.3-r2.ebuild,
+ openoffice-1.1.0-r4.ebuild, openoffice-1.1.0-r5.ebuild,
+ openoffice-1.1.1-r1.ebuild:
+ Fix use invocation
25 May 2004; Jason Wever <weeve@gentoo.org> +files/1.1.1/linux-sparc.patch,
openoffice-1.1.1-r1.ebuild:
diff --git a/app-office/openoffice/openoffice-1.0.3-r2.ebuild b/app-office/openoffice/openoffice-1.0.3-r2.ebuild
index 7d7e4eed9ec7..e822c16c66ee 100644
--- a/app-office/openoffice/openoffice-1.0.3-r2.ebuild
+++ b/app-office/openoffice/openoffice-1.0.3-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/openoffice/openoffice-1.0.3-r2.ebuild,v 1.3 2004/05/12 11:17:05 pappy Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/openoffice/openoffice-1.0.3-r2.ebuild,v 1.4 2004/06/02 12:36:09 agriffis Exp $
# IMPORTANT: This is extremely alpha!!!
@@ -608,7 +608,7 @@ src_install() {
dosym ooffice /usr/bin/oosetup
einfo "Installing Menu shortcuts (need \"gnome\" or \"kde\" in USE)..."
- if [ -n "`use gnome`" ]
+ if use gnome
then
insinto /usr/share/gnome/apps/OpenOffice.org
# Install the files needed for the catagory
@@ -625,7 +625,7 @@ src_install() {
done
fi
- if [ -n "`use kde`" ]
+ if use kde
then
local kdeloc="${D}${INSTDIR}/share/kde/net/applnk/OpenOffice.org${PV}"
diff --git a/app-office/openoffice/openoffice-1.1.0-r4.ebuild b/app-office/openoffice/openoffice-1.1.0-r4.ebuild
index c16e29565f68..6ad38b343954 100644
--- a/app-office/openoffice/openoffice-1.1.0-r4.ebuild
+++ b/app-office/openoffice/openoffice-1.1.0-r4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/openoffice/openoffice-1.1.0-r4.ebuild,v 1.4 2004/05/07 14:40:14 suka Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/openoffice/openoffice-1.1.0-r4.ebuild,v 1.5 2004/06/02 12:36:09 agriffis Exp $
# IMPORTANT: This is extremely alpha!!!
@@ -588,7 +588,7 @@ src_install() {
dosym ooffice /usr/bin/oopadmin
einfo "Installing Menu shortcuts (need \"gnome\" or \"kde\" in USE)..."
- if [ -n "`use gnome`" ]
+ if use gnome
then
insinto /usr/share/gnome/apps/OpenOffice.org
# Install the files needed for the catagory
@@ -606,7 +606,7 @@ src_install() {
done
fi
- if [ -n "`use kde`" ]
+ if use kde
then
local kdeloc="${D}${INSTDIR}/share/kde/net/"
diff --git a/app-office/openoffice/openoffice-1.1.0-r5.ebuild b/app-office/openoffice/openoffice-1.1.0-r5.ebuild
index 2abf8b34addb..a98b55e1b39f 100644
--- a/app-office/openoffice/openoffice-1.1.0-r5.ebuild
+++ b/app-office/openoffice/openoffice-1.1.0-r5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/openoffice/openoffice-1.1.0-r5.ebuild,v 1.4 2004/05/07 14:40:14 suka Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/openoffice/openoffice-1.1.0-r5.ebuild,v 1.5 2004/06/02 12:36:09 agriffis Exp $
# IMPORTANT: This is extremely alpha!!!
@@ -458,7 +458,7 @@ src_install() {
done
einfo "Installing Menu shortcuts (need \"gnome\" or \"kde\" in USE)..."
- if [ -n "`use gnome`" ]
+ if use gnome
then
insinto /usr/share/gnome/apps/OpenOffice.org
# Install the files needed for the catagory
@@ -479,7 +479,7 @@ src_install() {
done
fi
- if [ -n "`use kde`" ]
+ if use kde
then
local kdeloc="${D}${INSTDIR}/share/kde/net/"
diff --git a/app-office/openoffice/openoffice-1.1.1-r1.ebuild b/app-office/openoffice/openoffice-1.1.1-r1.ebuild
index fb17ea5f424d..9781ca6715b7 100644
--- a/app-office/openoffice/openoffice-1.1.1-r1.ebuild
+++ b/app-office/openoffice/openoffice-1.1.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/openoffice/openoffice-1.1.1-r1.ebuild,v 1.5 2004/05/25 13:12:32 weeve Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/openoffice/openoffice-1.1.1-r1.ebuild,v 1.6 2004/06/02 12:36:09 agriffis Exp $
# IMPORTANT: This is extremely alpha!!!
@@ -260,7 +260,7 @@ src_unpack() {
epatch ${FILESDIR}/${PV}/build.patch
# Linux/SPARC fixes
- [ `use sparc` ] && epatch ${FILESDIR}/${PV}/linux-sparc.patch
+ use sparc && epatch ${FILESDIR}/${PV}/linux-sparc.patch
#Security fix
epatch ${FILESDIR}/${PV}/neon.patch
@@ -461,7 +461,7 @@ src_install() {
done
einfo "Installing Menu shortcuts (need \"gnome\" or \"kde\" in USE)..."
- if [ -n "`use gnome`" ]
+ if use gnome
then
insinto /usr/share/gnome/apps/OpenOffice.org
# Install the files needed for the catagory
@@ -482,7 +482,7 @@ src_install() {
done
fi
- if [ -n "`use kde`" ]
+ if use kde
then
local kdeloc="${D}${INSTDIR}/share/kde/net/"