summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2012-06-28 12:55:46 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2012-06-28 12:55:46 +0000
commit10a983221713611f928d4b5da56737d9b015ccd4 (patch)
tree674dbc337debeba40cd128ce9ce9b34ec8a14528 /app-office
parentMarking gnupg-2.0.19 ppc for bug 421591 (diff)
downloadhistorical-10a983221713611f928d4b5da56737d9b015ccd4.tar.gz
historical-10a983221713611f928d4b5da56737d9b015ccd4.tar.bz2
historical-10a983221713611f928d4b5da56737d9b015ccd4.zip
Bumpy to 2.4.3.
Package-Manager: portage-2.2.0_alpha114/cvs/Linux x86_64
Diffstat (limited to 'app-office')
-rw-r--r--app-office/calligra-l10n/ChangeLog8
-rw-r--r--app-office/calligra-l10n/calligra-l10n-2.4.3.ebuild77
2 files changed, 83 insertions, 2 deletions
diff --git a/app-office/calligra-l10n/ChangeLog b/app-office/calligra-l10n/ChangeLog
index 595b63067500..4fa1473f0b47 100644
--- a/app-office/calligra-l10n/ChangeLog
+++ b/app-office/calligra-l10n/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-office/calligra-l10n
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/calligra-l10n/ChangeLog,v 1.17 2012/06/24 14:08:17 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/calligra-l10n/ChangeLog,v 1.18 2012/06/28 12:55:46 scarabeus Exp $
+
+*calligra-l10n-2.4.3 (28 Jun 2012)
+
+ 28 Jun 2012; Tomáš Chvátal <scarabeus@gentoo.org> +calligra-l10n-2.4.3.ebuild:
+ Bumpy to 2.4.3.
24 Jun 2012; Agostino Sarubbo <ago@gentoo.org> -calligra-l10n-2.4.1.ebuild:
Remove old
@@ -86,4 +91,3 @@
15 Sep 2011; Tomáš Chvátal <scarabeus@gentoo.org>
+calligra-l10n-2.3.81.ebuild, +metadata.xml:
Initial commit for the calligra translations.
-
diff --git a/app-office/calligra-l10n/calligra-l10n-2.4.3.ebuild b/app-office/calligra-l10n/calligra-l10n-2.4.3.ebuild
new file mode 100644
index 000000000000..5f00c2eb2f8c
--- /dev/null
+++ b/app-office/calligra-l10n/calligra-l10n-2.4.3.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/calligra-l10n/calligra-l10n-2.4.3.ebuild,v 1.1 2012/06/28 12:55:46 scarabeus Exp $
+
+EAPI=4
+
+inherit kde4-base
+
+DESCRIPTION="Calligra localization package"
+HOMEPAGE="http://www.kde.org/"
+LICENSE="GPL-2"
+
+DEPEND="sys-devel/gettext"
+RDEPEND="!app-office/koffice-l10n"
+
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+MY_LANGS="ca ca@valencia cs da de el en_GB es et fi fr hu it kk nb nds nl pl pt pt_BR ru sk sv uk zh_CN zh_TW"
+URI_BASE="mirror://kde/stable/${PN/-l10n/}-${PV}/${PN}/"
+SRC_URI=""
+SLOT="4"
+
+for MY_LANG in ${MY_LANGS} ; do
+ IUSE="${IUSE} linguas_${MY_LANG}"
+ SRC_URI="${SRC_URI} linguas_${MY_LANG}? ( ${URI_BASE}/${PN}-${MY_LANG}-${PV}.tar.bz2 )"
+done
+unset MY_LANG
+
+S="${WORKDIR}"
+
+src_unpack() {
+ local lng dir
+ if [[ -z ${A} ]]; then
+ elog
+ elog "You either have the LINGUAS variable unset, or it only"
+ elog "contains languages not supported by ${P}."
+ elog "You won't have any additional language support."
+ elog
+ elog "${P} supports these language codes:"
+ elog "${MY_LANGS}"
+ elog
+ fi
+
+ [[ -n ${A} ]] && unpack ${A}
+ cd "${S}"
+
+ # add all linguas to cmake
+ if [[ -n ${A} ]]; then
+ for lng in ${MY_LANGS}; do
+ dir="${PN}-${lng}-${PV}"
+ if [[ -d "${dir}" ]] ; then
+ echo "add_subdirectory( ${dir} )" >> "${S}"/CMakeLists.txt
+ fi
+ done
+ fi
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_MESSAGES=ON -DBUILD_DATA=ON
+ $(cmake-utils_use_build doc)
+ )
+ [[ -e "${S}"/CMakeLists.txt ]] && kde4-base_src_configure
+}
+
+src_compile() {
+ [[ -e "${S}"/CMakeLists.txt ]] && kde4-base_src_compile
+}
+
+src_test() {
+ [[ -e "${S}"/CMakeLists.txt ]] && kde4-base_src_test
+}
+
+src_install() {
+ [[ -e "${S}"/CMakeLists.txt ]] && kde4-base_src_install
+}