summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2009-12-12 13:11:45 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2009-12-12 13:11:45 +0000
commitc9658638118c5a0f0a79108f79e68c2c2d3db09d (patch)
treed64f589027ed1a5d84e0a590b75d69f267ae7d46 /app-office/qcharselect
parentVersion bumps for new genpatches and new TuxOnIce patch version 3.0.99.41. (diff)
downloadhistorical-c9658638118c5a0f0a79108f79e68c2c2d3db09d.tar.gz
historical-c9658638118c5a0f0a79108f79e68c2c2d3db09d.tar.bz2
historical-c9658638118c5a0f0a79108f79e68c2c2d3db09d.zip
Initial commit.
Package-Manager: portage-2.2_rc58/cvs/Linux x86_64
Diffstat (limited to 'app-office/qcharselect')
-rw-r--r--app-office/qcharselect/ChangeLog10
-rw-r--r--app-office/qcharselect/Manifest4
-rw-r--r--app-office/qcharselect/metadata.xml9
-rw-r--r--app-office/qcharselect/qcharselect-0.2.ebuild39
4 files changed, 62 insertions, 0 deletions
diff --git a/app-office/qcharselect/ChangeLog b/app-office/qcharselect/ChangeLog
new file mode 100644
index 000000000000..586617370900
--- /dev/null
+++ b/app-office/qcharselect/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for app-office/qcharselect
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/qcharselect/ChangeLog,v 1.1 2009/12/12 13:11:45 ssuominen Exp $
+
+*qcharselect-0.2 (12 Dec 2009)
+
+ 12 Dec 2009; Samuli Suominen <ssuominen@gentoo.org>
+ +qcharselect-0.2.ebuild:
+ Initial commit.
+
diff --git a/app-office/qcharselect/Manifest b/app-office/qcharselect/Manifest
new file mode 100644
index 000000000000..ea67b0b4008e
--- /dev/null
+++ b/app-office/qcharselect/Manifest
@@ -0,0 +1,4 @@
+DIST qcharselect-0.2.tar.bz2 174408 RMD160 ab0219a314e0c6b36939b76a320a5fdd09d13708 SHA1 24ba6f51cec2fc39798689cd4e43374e38cacd1a SHA256 7291e4e18e9a24feedcbb10cd3167bff412192c2fe76946e8203b429f024c266
+EBUILD qcharselect-0.2.ebuild 880 RMD160 2201dbc8e055ee3a993f995d58b93910ee91fa3f SHA1 e96222ac443bdcae8ae1d63e979ebbb00778f54b SHA256 5f1affd98357afea542da22bfcd016363036f6c771786c5ac981d1d31c400342
+MISC ChangeLog 352 RMD160 f6949d8acb36e3827531a0c585920fd8d9b51dbc SHA1 7e604e987edaeb9aaff3727a7700a73742d52a49 SHA256 119eef5698228f8d3fdac81549fdefa66acec6c25f68970fb8066d2c78474753
+MISC metadata.xml 261 RMD160 531dc9368ca014828ea666ea181a0964b85c6599 SHA1 8ab4ac3f879eab826f2b1b10f4447011a311f7ad SHA256 e62ce21a3bc7f443e27f2855a442538d9f23e9bcbd90b80481f21fd789cad6d5
diff --git a/app-office/qcharselect/metadata.xml b/app-office/qcharselect/metadata.xml
new file mode 100644
index 000000000000..7ce270433c50
--- /dev/null
+++ b/app-office/qcharselect/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>qt</herd>
+ <maintainer>
+ <email>ssuominen@gentoo.org</email>
+ <name>Samuli Suominen</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/app-office/qcharselect/qcharselect-0.2.ebuild b/app-office/qcharselect/qcharselect-0.2.ebuild
new file mode 100644
index 000000000000..502c7de96e78
--- /dev/null
+++ b/app-office/qcharselect/qcharselect-0.2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/qcharselect/qcharselect-0.2.ebuild,v 1.1 2009/12/12 13:11:45 ssuominen Exp $
+
+EAPI=2
+inherit multilib
+
+DESCRIPTION="A Qt4 port of KCharSelect from KDE 3.5"
+HOMEPAGE="http://qcharselect.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+DEPEND="x11-libs/qt-gui:4[qt3support]"
+
+src_prepare() {
+ sed -i \
+ -e 's:update-mime-database:true:g' \
+ -e 's:data/desktop/qcharselect:src/QCharSelect:' \
+ Makefile.in || die
+}
+
+src_configure() {
+ local myconf
+ use debug && myconf="--enable-debug"
+
+ econf \
+ --with-qtdir=/usr \
+ --with-qtlibdir=/usr/$(get_libdir)/qt4 \
+ ${myconf}
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc README
+}