summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Proschofsky <suka@gentoo.org>2005-03-30 10:17:17 +0000
committerAndreas Proschofsky <suka@gentoo.org>2005-03-30 10:17:17 +0000
commitb2418af25822c7046764688a14a8a2e2c3ebc2eb (patch)
treeb602df2377ab4d45992cdc744a8241d0f00db22d /app-office/openoffice-bin
parentadd bmp fix, mark 2.6.4-r1 x86 (diff)
downloadhistorical-b2418af25822c7046764688a14a8a2e2c3ebc2eb.tar.gz
historical-b2418af25822c7046764688a14a8a2e2c3ebc2eb.tar.bz2
historical-b2418af25822c7046764688a14a8a2e2c3ebc2eb.zip
simplify menu entry installation and fix problems with newer findutils
Package-Manager: portage-2.0.51.19
Diffstat (limited to 'app-office/openoffice-bin')
-rw-r--r--app-office/openoffice-bin/ChangeLog7
-rw-r--r--app-office/openoffice-bin/files/1.1.4/ooffice-wrapper-1.32
-rw-r--r--app-office/openoffice-bin/openoffice-bin-1.1.4.ebuild68
3 files changed, 30 insertions, 47 deletions
diff --git a/app-office/openoffice-bin/ChangeLog b/app-office/openoffice-bin/ChangeLog
index 1e81ae6c661e..ca821495c9d0 100644
--- a/app-office/openoffice-bin/ChangeLog
+++ b/app-office/openoffice-bin/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-office/openoffice-bin
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/openoffice-bin/ChangeLog,v 1.63 2005/01/24 07:36:42 suka Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/openoffice-bin/ChangeLog,v 1.64 2005/03/30 10:17:17 suka Exp $
+
+ 30 Mar 2005; Andreas Proschofsky <suka@gentoo.org>
+ files/1.1.4/ooffice-wrapper-1.3, openoffice-bin-1.1.4.ebuild:
+ Simplify menu entry installation, see bug #81902, also fix problem with
+ newer findutils, bug#86974
24 Jan 2005; Andreas Proschofsky <suka@gentoo.org>
files/1.1.4/ooffice-wrapper-1.3:
diff --git a/app-office/openoffice-bin/files/1.1.4/ooffice-wrapper-1.3 b/app-office/openoffice-bin/files/1.1.4/ooffice-wrapper-1.3
index ea1be9d0765f..c12d92e91bd1 100644
--- a/app-office/openoffice-bin/files/1.1.4/ooffice-wrapper-1.3
+++ b/app-office/openoffice-bin/files/1.1.4/ooffice-wrapper-1.3
@@ -86,7 +86,7 @@ fi
# Default font path. This is used if SAL_FONTPATH_PRIVATE is not defined.
GENTOO_FONTPATH=""
-for d in `find /usr/share/fonts -type d -maxdepth 1 -mindepth 1` ; do
+for d in `find /usr/share/fonts -maxdepth 1 -mindepth 1 -type d` ; do
GENTOO_FONTPATH="$GENTOO_FONTPATH;$d"
done
diff --git a/app-office/openoffice-bin/openoffice-bin-1.1.4.ebuild b/app-office/openoffice-bin/openoffice-bin-1.1.4.ebuild
index ae77cf93299a..9118a8adbb9f 100644
--- a/app-office/openoffice-bin/openoffice-bin-1.1.4.ebuild
+++ b/app-office/openoffice-bin/openoffice-bin-1.1.4.ebuild
@@ -1,12 +1,14 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/openoffice-bin/openoffice-bin-1.1.4.ebuild,v 1.13 2005/01/29 20:15:15 suka Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/openoffice-bin/openoffice-bin-1.1.4.ebuild,v 1.14 2005/03/30 10:17:17 suka Exp $
# NOTE: There are two big issues that should be addressed.
#
# 1) Language support and fonts should be addressed.
-IUSE="gnome java kde"
+inherit eutils fdo-mime
+
+IUSE="java kde"
INSTDIR="/opt/OpenOffice.org"
MY_P="OOo_${PV}_LinuxIntel_install"
@@ -110,49 +112,22 @@ src_install() {
dosym ooffice /usr/bin/oo${app}
done
- einfo "Installing Menu shortcuts (need \"gnome\" or \"kde\" in USE)..."
- if use gnome
- then
- insinto /usr/share/gnome/apps/OpenOffice.org
- # Install the files needed for the category
- doins ${D}${INSTDIR}/share/gnome/net/.directory
- doins ${D}${INSTDIR}/share/gnome/net/.order
-
- # Change this to ooo*.desktop from *.desktop for now, since
- # otherwise two sets of icons will appear in the GNOME menu.
- # <brad@gentoo.org> (04 Aug 2003)
- for x in ${D}${INSTDIR}/share/gnome/net/ooo*.desktop
- do
- # We have to handle soffice and setup differently
- perl -pi -e "s:${INSTDIR}/program/setup:/usr/bin/oosetup:g" ${x}
- perl -pi -e "s:${INSTDIR}/program/soffice:/usr/bin/ooffice:g" ${x}
- # Now fix the rest
- perl -pi -e "s:${INSTDIR}/program/s:/usr/bin/oo:g" ${x}
- doins ${x}
- done
- fi
-
- if use kde
- then
- local kdeloc="${D}${INSTDIR}/share/kde/net/"
-
- insinto /usr/share/applnk/OpenOffice.org\ 1.1
- # Install the files needed for the category
- doins ${kdeloc}/.directory
- dodir /usr/share
- # Install the icons and mime info
- cp -a ${D}${INSTDIR}/share/kde/net/share/mimelnk ${D}${INSTDIR}/share/kde/net/share/icons ${D}/usr/share
-
- for x in ${kdeloc}/*.desktop
- do
- # We have to handle soffice and setup differently
- perl -pi -e "s:${INSTDIR}/program/setup:/usr/bin/oosetup:g" ${x}
- perl -pi -e "s:${INSTDIR}/program/soffice:/usr/bin/ooffice:g" ${x}
- # Now fix the rest
- perl -pi -e "s:${INSTDIR}/program/s:/usr/bin/oo:g" ${x}
- doins ${x}
- done
- fi
+ einfo "Installing menu shortcuts..."
+ dodir /usr/share
+ cp -a ${D}${INSTDIR}/share/kde/net/share/icons ${D}/usr/share
+
+ use kde && cp -a ${D}${INSTDIR}/share/kde/net/share/mimelnk ${D}/usr/share
+
+ for x in ${D}${INSTDIR}/share/kde/net/*.desktop; do
+ # We have to handle soffice and setup differently
+ sed -i -e "s:${INSTDIR}/program/setup:/usr/bin/oosetup:g" ${x}
+ sed -i -e "s:${INSTDIR}/program/soffice:/usr/bin/ooffice:g" ${x}
+ # Now fix the rest
+ sed -i -e "s:${INSTDIR}/program/s:/usr/bin/oo:g" ${x}
+ echo "Categories=Application;Office;" >> ${x}
+ domenu ${x}
+ rm ${x}
+ done
# Remove unneeded stuff
@@ -178,6 +153,9 @@ src_install() {
pkg_postinst() {
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+
einfo " To start OpenOffice.org, run:"
einfo
einfo " $ ooffice"