summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Hüttel <dilfridge@gentoo.org>2011-02-24 12:00:57 +0000
committerAndreas Hüttel <dilfridge@gentoo.org>2011-02-24 12:00:57 +0000
commita10f8dbb742543dddbc89dd9838fe5b25cd02071 (patch)
treeb7c6d88e30f161e60b55905e38d8c52978f6df92 /app-office/kexi
parentremove old (diff)
downloadhistorical-a10f8dbb742543dddbc89dd9838fe5b25cd02071.tar.gz
historical-a10f8dbb742543dddbc89dd9838fe5b25cd02071.tar.bz2
historical-a10f8dbb742543dddbc89dd9838fe5b25cd02071.zip
koffice version bump
Package-Manager: portage-2.1.9.41/cvs/Linux x86_64 RepoMan-Options: --force
Diffstat (limited to 'app-office/kexi')
-rw-r--r--app-office/kexi/ChangeLog7
-rw-r--r--app-office/kexi/kexi-2.3.3.ebuild56
2 files changed, 62 insertions, 1 deletions
diff --git a/app-office/kexi/ChangeLog b/app-office/kexi/ChangeLog
index ce2fc6ca705c..4bee04aca12d 100644
--- a/app-office/kexi/ChangeLog
+++ b/app-office/kexi/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-office/kexi
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/kexi/ChangeLog,v 1.106 2011/02/16 21:53:19 dilfridge Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/kexi/ChangeLog,v 1.107 2011/02/24 12:00:56 dilfridge Exp $
+
+*kexi-2.3.3 (24 Feb 2011)
+
+ 24 Feb 2011; Andreas K. Huettel <dilfridge@gentoo.org> +kexi-2.3.3.ebuild:
+ Version bump
16 Feb 2011; Andreas K. Huettel <dilfridge@gentoo.org> kexi-2.3.1.ebuild:
Works also with newer dev-libs/libpqxx now
diff --git a/app-office/kexi/kexi-2.3.3.ebuild b/app-office/kexi/kexi-2.3.3.ebuild
new file mode 100644
index 000000000000..c32579642f94
--- /dev/null
+++ b/app-office/kexi/kexi-2.3.3.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/kexi/kexi-2.3.3.ebuild,v 1.1 2011/02/24 12:00:56 dilfridge Exp $
+
+EAPI=3
+
+KMNAME="koffice"
+inherit kde4-meta
+
+DESCRIPTION="KOffice integrated environment for database management"
+KEYWORDS="~amd64 ~x86"
+IUSE="freetds mysql postgres reports xbase"
+
+DEPEND="
+ sys-libs/readline
+ app-arch/bzip2
+ ~app-office/kspread-${PV}:${SLOT}
+ freetds? ( dev-db/freetds )
+ mysql? ( virtual/mysql )
+ postgres? ( >=dev-libs/libpqxx-3 )
+ reports? ( ~app-office/koffice-libs-${PV}:${SLOT}[reports] )
+ xbase? ( dev-db/xbase )
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}/${PN}"-2.3.0-link.patch )
+
+KMLOADLIBS="koffice-libs"
+KMEXTRACTONLY="
+ KoConfig.h.cmake
+ libs/
+ kspread/
+"
+
+src_configure() {
+ mycmakeargs=(
+ -DWITH_WEBFORMS=Off
+ $(cmake-utils_use_with freetds FreeTDS)
+ $(cmake-utils_use_with mysql MySQL)
+ $(cmake-utils_use_with postgres PostgreSQL)
+ $(cmake-utils_use_with postgres Pqxx)
+ $(cmake-utils_use_with xbase XBase)
+ -DBUILD_kexi=ON
+ $(cmake-utils_use_build reports koreport)
+ )
+
+ kde4-meta_src_configure
+}
+
+src_install() {
+ kde4-meta_src_install
+
+ # this is already installed by koffice-data
+ rm -f "${D}/usr/include/config-opengl.h"
+ rm -f "${D}/usr/include/KoConfig.h"
+}