summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Faulhammer <fauli@gentoo.org>2010-10-09 19:32:03 +0000
committerChristian Faulhammer <fauli@gentoo.org>2010-10-09 19:32:03 +0000
commit6e87359edfd788ea4597f5153f90495d95050b0a (patch)
tree5038389d661be6b3aaf34eb65448d9463b5a33c3 /app-mobilephone
parentNext Square preview release is out, and the previous release now fails to fet... (diff)
downloadhistorical-6e87359edfd788ea4597f5153f90495d95050b0a.tar.gz
historical-6e87359edfd788ea4597f5153f90495d95050b0a.tar.bz2
historical-6e87359edfd788ea4597f5153f90495d95050b0a.zip
version bump for bug 317623, fixes Python usage as reported in bug 311669 by changing shebangs, depending on Python 2 only
Package-Manager: portage-2.1.8.3/cvs/Linux i686
Diffstat (limited to 'app-mobilephone')
-rw-r--r--app-mobilephone/wammu/ChangeLog8
-rw-r--r--app-mobilephone/wammu/wammu-0.34.ebuild69
2 files changed, 76 insertions, 1 deletions
diff --git a/app-mobilephone/wammu/ChangeLog b/app-mobilephone/wammu/ChangeLog
index 3b5aed2e8667..db593f184ecc 100644
--- a/app-mobilephone/wammu/ChangeLog
+++ b/app-mobilephone/wammu/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-mobilephone/wammu
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/wammu/ChangeLog,v 1.42 2010/02/01 21:55:28 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/wammu/ChangeLog,v 1.43 2010/10/09 19:32:03 fauli Exp $
+
+*wammu-0.34 (09 Oct 2010)
+
+ 09 Oct 2010; Christian Faulhammer <fauli@gentoo.org> +wammu-0.34.ebuild:
+ version bump for bug 317623, fixes Python usage as reported in bug 311669
+ by changing shebangs, depending on Python 2 only
*wammu-0.32.1 (01 Feb 2010)
diff --git a/app-mobilephone/wammu/wammu-0.34.ebuild b/app-mobilephone/wammu/wammu-0.34.ebuild
new file mode 100644
index 000000000000..647632340771
--- /dev/null
+++ b/app-mobilephone/wammu/wammu-0.34.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/wammu/wammu-0.34.ebuild,v 1.1 2010/10/09 19:32:03 fauli Exp $
+
+EAPI="2"
+
+PYTHON_DEPEND="2"
+
+inherit distutils
+
+DESCRIPTION="Front-end for gammu to access mobile phones easily"
+HOMEPAGE="http://www.wammu.eu/"
+SRC_URI="http://dl.cihar.com/wammu/v0/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="bluetooth"
+
+RDEPEND=">=app-mobilephone/gammu-1.25.0[python]
+ >=dev-python/wxpython-2.8
+ bluetooth? (
+ || (
+ dev-python/pybluez
+ net-wireless/gnome-bluetooth
+ )
+ )"
+DEPEND="${RDEPEND}"
+
+# Supported languages and translated documentation
+# Be sure all languages are prefixed with a single space!
+MY_AVAILABLE_LINGUAS=" af bg ca cs da de el es et fi fr gl he hu id it ko nl pl pt_BR ru sk sv zh_CN zh_TW"
+IUSE="${IUSE} ${MY_AVAILABLE_LINGUAS// / linguas_}"
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_prepare() {
+ local lang support_linguas=no
+ for lang in ${MY_AVAILABLE_LINGUAS} ; do
+ if use linguas_${lang} ; then
+ support_linguas=yes
+ break
+ fi
+ done
+ # install all languages when all selected LINGUAS aren't supported
+ if [ "${support_linguas}" = "yes" ]; then
+ for lang in ${MY_AVAILABLE_LINGUAS} ; do
+ if ! use linguas_${lang} ; then
+ rm -r locale/${lang} || die
+ fi
+ done
+ fi
+
+ python_convert_shebangs -r 2 .
+}
+
+src_compile() {
+ # SKIPWXCHECK: else 'import wx' results in
+ # Xlib: connection to ":0.0" refused by server
+ SKIPWXCHECK=yes distutils_src_compile
+}
+
+src_install() {
+ DOCS="AUTHORS FAQ"
+ SKIPWXCHECK=yes distutils_src_install
+}