summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrandon Low <lostlogic@gentoo.org>2002-06-10 15:16:38 +0000
committerBrandon Low <lostlogic@gentoo.org>2002-06-10 15:16:38 +0000
commitc63474f780178b59abec155fbde82d51453960ae (patch)
tree8b78204c59a61a428650704ee1fa546569b40ffb /app-misc
parentproperly fix DEPEND for gnome1 (diff)
downloadhistorical-c63474f780178b59abec155fbde82d51453960ae.tar.gz
historical-c63474f780178b59abec155fbde82d51453960ae.tar.bz2
historical-c63474f780178b59abec155fbde82d51453960ae.zip
New version closes bug #3510
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/xlockmore/ChangeLog13
-rw-r--r--app-misc/xlockmore/files/digest-xlockmore-5.041
-rw-r--r--app-misc/xlockmore/xlockmore-5.04.ebuild61
3 files changed, 74 insertions, 1 deletions
diff --git a/app-misc/xlockmore/ChangeLog b/app-misc/xlockmore/ChangeLog
index 7505ae7ca655..2b3ea5192b8b 100644
--- a/app-misc/xlockmore/ChangeLog
+++ b/app-misc/xlockmore/ChangeLog
@@ -1,6 +1,17 @@
# ChangeLog for app-misc/xlockmore
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/app-misc/xlockmore/ChangeLog,v 1.8 2002/06/03 21:55:30 lostlogic Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/xlockmore/ChangeLog,v 1.9 2002/06/10 15:16:38 lostlogic Exp $
+
+*xlockmore-5.04 (10 Jun 2002)
+
+ 10 Jun 2002; Brandon Low <lostlogic@gentoo.org> xlockmore-5.04.ebuild :
+
+ New version available fixes a problem some users were having with xlock
+ looking for an image in a redhat subdir and crashing back to X (making
+ it a BIT less effective as a locker).
+
+ xglock appears to be integrated into xlock now, and xmlock does appear
+ to build successfully.
*xlockmore-5.03-r5 (24 Apr 2002)
diff --git a/app-misc/xlockmore/files/digest-xlockmore-5.04 b/app-misc/xlockmore/files/digest-xlockmore-5.04
new file mode 100644
index 000000000000..57df1f1c2aed
--- /dev/null
+++ b/app-misc/xlockmore/files/digest-xlockmore-5.04
@@ -0,0 +1 @@
+MD5 654f4d6b65cf8622ce6617f749bb2049 xlockmore-5.04.tar.gz 1753845
diff --git a/app-misc/xlockmore/xlockmore-5.04.ebuild b/app-misc/xlockmore/xlockmore-5.04.ebuild
new file mode 100644
index 000000000000..7c500a44793e
--- /dev/null
+++ b/app-misc/xlockmore/xlockmore-5.04.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: system@gentoo.org
+# $Header: /var/cvsroot/gentoo-x86/app-misc/xlockmore/xlockmore-5.04.ebuild,v 1.1 2002/06/10 15:16:38 lostlogic Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Just another screensaver application for X"
+SRC_URI="ftp://ftp.tux.org/pub/tux/bagleyd/xlockmore/${P}.tar.gz"
+HOMEPAGE="http://www.tux.org/~bagleyd/xlockmore.html"
+
+DEPEND="virtual/x11 media-libs/freetype
+ opengl? ( virtual/opengl )
+ pam? ( sys-libs/pam )
+ nas? ( media-libs/nas )
+ esd? ( media-sound/esound )
+ motif? ( >=x11-libs/openmotif-2.1.30-r1 )
+ gtk? ( x11-libs/gtk+ )"
+
+src_compile() {
+ local myconf
+ use pam && myconf="${myconf} --enable-pam" \
+ || myconf="${myconf} --disable-pam --enable-xlockrc"
+ use nas || myconf="${myconf} --without-nas"
+ use esd && myconf="${myconf} --with-esound"
+ use opengl || myconf="${myconf} --without-opengl --without-gltt --without-mesa"
+ use truetype || myconf="${myconf} --without-ttf"
+
+ use motif || myconf="${myconf} --without-motif"
+ use gtk || myconf="${myconf} --without-gtk"
+
+ ./configure \
+ --prefix=/usr \
+ --mandir=${prefix}/share/man/man1 \
+ --sharedstatedir=/usr/share/xlockmore \
+ --host=${CHOST} ${myconf} || die "Configure failed"
+
+ emake || die "Make failed"
+
+}
+
+src_install() {
+ make install \
+ prefix=${D}/usr \
+ mandir=${D}/usr/share/man/man1 \
+ xapploaddir=${D}/usr/X11R6/lib/X11/app-defaults \
+ || die "Install failed"
+
+ #Install pam.d file and unset setuid root
+ if use pam; then
+ insinto /etc/pam.d
+ newins etc/xlock.pamd xlock
+ chmod 111 ${D}/usr/bin/xlock
+ fi
+
+ insinto /usr/share/xlockmore/sounds
+ doins sounds/*
+
+ dodoc docs/* README
+ dohtml docs/*.html
+ rm ${D}/usr/share/doc/${PF}/*.html.gz
+}