summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2002-11-30 20:50:28 +0000
committerMike Frysinger <vapier@gentoo.org>2002-11-30 20:50:28 +0000
commit703b97adc4974ab8ed271d8a19d6a0ab21f69fed (patch)
tree8afed31cadb9301420838433a7b49c7569b4a866 /app-misc
parentChanged src_install () to src_install() (diff)
downloadhistorical-703b97adc4974ab8ed271d8a19d6a0ab21f69fed.tar.gz
historical-703b97adc4974ab8ed271d8a19d6a0ab21f69fed.tar.bz2
historical-703b97adc4974ab8ed271d8a19d6a0ab21f69fed.zip
Changed econf||die to econf
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/gtktrain/gtktrain-0.9b.ebuild14
-rw-r--r--app-misc/gtypist/gtypist-2.5.ebuild13
-rw-r--r--app-misc/gtypist/gtypist-2.6.2.ebuild13
-rw-r--r--app-misc/ithought/ithought-0.0.5-r1.ebuild4
4 files changed, 23 insertions, 21 deletions
diff --git a/app-misc/gtktrain/gtktrain-0.9b.ebuild b/app-misc/gtktrain/gtktrain-0.9b.ebuild
index 0a4f6ddb2e6f..90a9d48a2565 100644
--- a/app-misc/gtktrain/gtktrain-0.9b.ebuild
+++ b/app-misc/gtktrain/gtktrain-0.9b.ebuild
@@ -1,27 +1,27 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/gtktrain/gtktrain-0.9b.ebuild,v 1.5 2002/10/20 18:40:22 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/gtktrain/gtktrain-0.9b.ebuild,v 1.6 2002/11/30 20:47:38 vapier Exp $
DESCRIPTION="GUI app for calculating fastest train routes"
SRC_URI="http://www.on.rim.or.jp/~katamuki/software/train/${P}.tar.gz"
HOMEPAGE="http://www.on.rim.or.jp/~katamuki/software/train/"
-DEPEND=">=dev-libs/libtrain-0.9b
- >=gnome-base/gnome-libs-1.4.1.2-r1"
-IUSE="nls"
SLOT="0"
LICENSE="GPL-2"
KEYWORDS="x86"
+IUSE="nls"
+
+DEPEND=">=dev-libs/libtrain-0.9b
+ >=gnome-base/gnome-libs-1.4.1.2-r1"
src_compile() {
use nls || NLS_OPTION="--disable-nls"
-
- econf ${NLS_OPTION} || die "./configure failed"
+ econf ${NLS_OPTION}
emake || die
}
src_install() {
- einstall || die
+ einstall
}
pkg_postinst() {
diff --git a/app-misc/gtypist/gtypist-2.5.ebuild b/app-misc/gtypist/gtypist-2.5.ebuild
index 995ad8d006d5..3d283e494b14 100644
--- a/app-misc/gtypist/gtypist-2.5.ebuild
+++ b/app-misc/gtypist/gtypist-2.5.ebuild
@@ -1,15 +1,15 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/gtypist/gtypist-2.5.ebuild,v 1.8 2002/10/20 18:40:22 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/gtypist/gtypist-2.5.ebuild,v 1.9 2002/11/30 20:48:19 vapier Exp $
-S=${WORKDIR}/${P}
DESCRIPTION="GNU Typist (also called gtypist) is a universal typing tutor."
SRC_URI="ftp://ftp.gnu.org/gnu/gtypist/${P}.tar.gz"
HOMEPAGE="http://www.gnu.org/software/gtypist/gtypist.html"
-IUSE="nls"
+
SLOT="0"
LICENSE="GPL-2"
KEYWORDS="x86"
+IUSE="nls"
DEPEND=">=sys-libs/ncurses-5.2"
@@ -17,14 +17,15 @@ src_compile() {
local myconf
# gtypist uses a built in gettext
- use nls && myconf="--enable-nls" || \
- myconf="--disable-nls"
+ use nls \
+ && myconf="--enable-nls" \
+ || myconf="--disable-nls"
# gtypist also produces some Emacs/XEmacs editing modes if
# emacs/xemacs is present. if emacs/xemacs is not present then
# these emacs modes are not compiled or installed.
- econf ${myconf} || die "./configure failed"
+ econf ${myconf}
emake || die
}
diff --git a/app-misc/gtypist/gtypist-2.6.2.ebuild b/app-misc/gtypist/gtypist-2.6.2.ebuild
index f9a7bf72e900..691fbe3740ca 100644
--- a/app-misc/gtypist/gtypist-2.6.2.ebuild
+++ b/app-misc/gtypist/gtypist-2.6.2.ebuild
@@ -1,15 +1,15 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/gtypist/gtypist-2.6.2.ebuild,v 1.1 2002/11/05 19:29:05 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/gtypist/gtypist-2.6.2.ebuild,v 1.2 2002/11/30 20:49:05 vapier Exp $
-S=${WORKDIR}/${P}
DESCRIPTION="GNU Typist (also called gtypist) is a universal typing tutor."
SRC_URI="mirror://gnu/gtypist/${P}.tar.gz"
HOMEPAGE="http://www.gnu.org/software/gtypist/gtypist.html"
-IUSE="nls"
+
SLOT="0"
LICENSE="GPL-2"
KEYWORDS="~x86"
+IUSE="nls"
DEPEND=">=sys-libs/ncurses-5.2"
@@ -17,14 +17,15 @@ src_compile() {
local myconf
# gtypist uses a built in gettext
- use nls && myconf="--enable-nls" || \
- myconf="--disable-nls"
+ use nls \
+ && myconf="--enable-nls" \
+ || myconf="--disable-nls"
# gtypist also produces some Emacs/XEmacs editing modes if
# emacs/xemacs is present. if emacs/xemacs is not present then
# these emacs modes are not compiled or installed.
- econf ${myconf} || die "./configure failed"
+ econf ${myconf}
emake || die
}
diff --git a/app-misc/ithought/ithought-0.0.5-r1.ebuild b/app-misc/ithought/ithought-0.0.5-r1.ebuild
index aa53a70b0154..a5eb13352de7 100644
--- a/app-misc/ithought/ithought-0.0.5-r1.ebuild
+++ b/app-misc/ithought/ithought-0.0.5-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/ithought/ithought-0.0.5-r1.ebuild,v 1.10 2002/10/20 18:40:22 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/ithought/ithought-0.0.5-r1.ebuild,v 1.11 2002/11/30 20:50:28 vapier Exp $
#emerge doesn't yet support things like a5
@@ -18,7 +18,7 @@ DEPEND="=x11-libs/gtk+-1.2*
dev-libs/libxml2"
src_compile() {
- econf || die
+ econf
emake || die
}