summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-06-11 11:11:33 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-06-11 11:11:33 +0000
commit5a06ba173e34dc17542fdd29004056885be718bc (patch)
tree7461c19c60d9a316833c81b83ea6bca7d267a3ae /app-misc
parentBug 3487 (diff)
downloadhistorical-5a06ba173e34dc17542fdd29004056885be718bc.tar.gz
historical-5a06ba173e34dc17542fdd29004056885be718bc.tar.bz2
historical-5a06ba173e34dc17542fdd29004056885be718bc.zip
version bump
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/xscreensaver/ChangeLog12
-rw-r--r--app-misc/xscreensaver/files/digest-xscreensaver-4.051
-rw-r--r--app-misc/xscreensaver/xscreensaver-4.05.ebuild87
3 files changed, 98 insertions, 2 deletions
diff --git a/app-misc/xscreensaver/ChangeLog b/app-misc/xscreensaver/ChangeLog
index 724d13daec25..3787ec1e8156 100644
--- a/app-misc/xscreensaver/ChangeLog
+++ b/app-misc/xscreensaver/ChangeLog
@@ -1,11 +1,19 @@
# ChangeLog for app-misc/xscreensaver
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/app-misc/xscreensaver/ChangeLog,v 1.12 2002/06/10 06:19:48 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/xscreensaver/ChangeLog,v 1.13 2002/06/11 11:11:33 seemant Exp $
+*xscreensaver-4.05 (11 Jun 2002)
+
+ 11 Jun 2002; Seemant Kulleen <seemant@gentoo.org>
+ xscreensaver-4.05.ebuild files/digest-xscreensaver-4.05 :
+
+ Version bump, which is supposed to fix the GTK2 configure stage errors, as
+ reported in bug #3506 by erichey2@attbi.com (kde123)
+
*xscreensaver-4.04.2-r2 (9 Jun 2002)
- 9 Jun 2002; Seemant Kulleen <seemant@gentoo.orG>
+ 9 Jun 2002; Seemant Kulleen <seemant@gentoo.org>
xscreensaver-4.04.2-r2.ebuild files/digest-xscreensaver-4.04.2-r2 :
There was a typo in the last revision which caused GL screenhacks to fail.
diff --git a/app-misc/xscreensaver/files/digest-xscreensaver-4.05 b/app-misc/xscreensaver/files/digest-xscreensaver-4.05
new file mode 100644
index 000000000000..abb2ba26d7b8
--- /dev/null
+++ b/app-misc/xscreensaver/files/digest-xscreensaver-4.05
@@ -0,0 +1 @@
+MD5 39b05d4da14158638e501e3bc31c0943 xscreensaver-4.05.tar.gz 2914308
diff --git a/app-misc/xscreensaver/xscreensaver-4.05.ebuild b/app-misc/xscreensaver/xscreensaver-4.05.ebuild
new file mode 100644
index 000000000000..27a8f3ea1d3b
--- /dev/null
+++ b/app-misc/xscreensaver/xscreensaver-4.05.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: Martin Schlemmer <azarah@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/app-misc/xscreensaver/xscreensaver-4.05.ebuild,v 1.1 2002/06/11 11:11:33 seemant Exp $
+
+S="${WORKDIR}/${P/.2/}"
+DESCRIPTION="a modular screensaver for X11"
+SRC_URI="http://www.jwz.org/xscreensaver/${P}.tar.gz"
+HOMEPAGE="http://www.jwz.org/xscreensaver/"
+
+DEPEND="virtual/x11 sys-devel/bc
+ gtk? ( x11-libs/gtk+ )
+ motif? ( >=x11-libs/openmotif-2.1.30 )
+ opengl? ( virtual/opengl >=media-libs/gle-3.0.1 )
+ gnome? ( media-libs/gdk-pixbuf
+ >=gnome-base/control-center-1.4.0.1-r1 )
+ pam? ( >=sys-libs/pam-0.75 )
+ dev-libs/libxml2"
+
+src_unpack() {
+
+ unpack ${A}
+ cd ${S}
+
+ use nls && ( \
+ cd po
+ patch -p0 < ${FILESDIR}/${P}-gentoo.diff
+ ) || ( \
+ cp Makefile.in Makefile.in.orig
+ sed "s:hacks/glx po:hacks/glx:" \
+ Makefile.in.orig > Makefile.in
+ )
+}
+
+src_compile() {
+ local myconf=""
+ use gnome \
+ && myconf="${myconf} --with-gnome" \
+ || myconf="${myconf} --without-gnome"
+
+ use gtk \
+ && myconf="${myconf} --with-gtk" \
+ || myconf="${myconf} --without-gtk"
+
+ use motif \
+ && myconf="${myconf} --with-motif" \
+ || myconf="${myconf} --without-motif"
+
+ use pam \
+ && myconf="${myconf} --with-pam" \
+ || myconf="${myconf} --without-pam"
+
+ use opengl \
+ && myconf="${myconf} --with-gl --with-gle" \
+ || myconf="${myconf} --without-gl --without-gle"
+
+ export C_INCLUDE_PATH="/usr/include/libxml2/libxml/"
+ ./configure --prefix=/usr \
+ --mandir=/usr/share/man \
+ --host="${CHOST}" \
+ --enable-hackdir=/usr/lib/xscreensaver \
+ --with-mit-ext \
+ --with-dpms-ext \
+ --with-xinerama-ext \
+ --with-xf86vmode-ext \
+ --with-xf86gamma-ext \
+ --with-proc-interrupts \
+ --with-xpm \
+ --with-xshm-ext \
+ --with-xdbe-ext \
+ --enable-locking \
+ ${myconf} || die
+
+ emake || die
+}
+
+src_install() {
+
+ [ -n "$KDEDIR" ] && dodir "$KDEDIR/bin"
+
+ make install_prefix="${D}" install || die
+
+ use pam && ( \
+ insinto /etc/pam.d
+ doins "${FILESDIR}/pam.d/xscreensaver"
+ )
+}