summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Drake <dsd@gentoo.org>2005-10-24 14:02:17 +0000
committerDaniel Drake <dsd@gentoo.org>2005-10-24 14:02:17 +0000
commit55f826da1258cae48b85d671bbbc650c76cc3fa3 (patch)
tree4cba95a7435fada3790cf5c5e1874a37dd9f2aed /app-misc
parentfix digest (diff)
downloadhistorical-55f826da1258cae48b85d671bbbc650c76cc3fa3.tar.gz
historical-55f826da1258cae48b85d671bbbc650c76cc3fa3.tar.bz2
historical-55f826da1258cae48b85d671bbbc650c76cc3fa3.zip
Initial import, thanks to everyone on bug #67768
Package-Manager: portage-1.589-cvs
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/beagle/ChangeLog12
-rw-r--r--app-misc/beagle/Manifest16
-rw-r--r--app-misc/beagle/beagle-0.1.1.ebuild112
-rw-r--r--app-misc/beagle/files/beagle-0.1.1-null-task-source.patch31
-rw-r--r--app-misc/beagle/files/beagle-0.1.1-uri-serialization.patch76
-rw-r--r--app-misc/beagle/files/digest-beagle-0.1.11
-rw-r--r--app-misc/beagle/metadata.xml8
7 files changed, 256 insertions, 0 deletions
diff --git a/app-misc/beagle/ChangeLog b/app-misc/beagle/ChangeLog
new file mode 100644
index 000000000000..57e6b368e766
--- /dev/null
+++ b/app-misc/beagle/ChangeLog
@@ -0,0 +1,12 @@
+# ChangeLog for app-misc/beagle
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/beagle/ChangeLog,v 1.1 2005/10/24 14:02:17 dsd Exp $
+
+*beagle-0.1.1 (24 Oct 2005)
+
+ 24 Oct 2005; Daniel Drake <dsd@gentoo.org>
+ +files/beagle-0.1.1-null-task-source.patch,
+ +files/beagle-0.1.1-uri-serialization.patch, +metadata.xml,
+ +beagle-0.1.1.ebuild:
+ Initial import, thanks to everyone on bug #67768
+
diff --git a/app-misc/beagle/Manifest b/app-misc/beagle/Manifest
new file mode 100644
index 000000000000..1c2ef06d96af
--- /dev/null
+++ b/app-misc/beagle/Manifest
@@ -0,0 +1,16 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
+MD5 067a64ceb2a8be2583f99eab522eaa08 beagle-0.1.1.ebuild 2947
+MD5 7ebc3e7303ef4457b02d369e19b2e5ec ChangeLog 458
+MD5 43c872252a620e391c449e150e344a3a metadata.xml 224
+MD5 3375984ea7d16737cd465bae6ed3d928 files/beagle-0.1.1-null-task-source.patch 1347
+MD5 9c5c2f0ad3f959022b402ddba4dc671d files/beagle-0.1.1-uri-serialization.patch 2704
+MD5 4840546d3689482f55c682ef01d4807b files/digest-beagle-0.1.1 66
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v1.4.2 (GNU/Linux)
+
+iD8DBQFDXOqdTOXg++0VvJQRAq/1AJ9Jb/l2LfLYDqWKoM0mNnqlkkEaYgCeO6oH
+NflvfeUminwvTnV6nx8IYb4=
+=wv7r
+-----END PGP SIGNATURE-----
diff --git a/app-misc/beagle/beagle-0.1.1.ebuild b/app-misc/beagle/beagle-0.1.1.ebuild
new file mode 100644
index 000000000000..c9f7b472b4be
--- /dev/null
+++ b/app-misc/beagle/beagle-0.1.1.ebuild
@@ -0,0 +1,112 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/beagle/beagle-0.1.1.ebuild,v 1.1 2005/10/24 14:02:17 dsd Exp $
+
+inherit gnome.org gnome2 eutils mono
+
+DESCRIPTION="Beagle is a search tool that ransacks your personal information space to find whatever you're looking for."
+HOMEPAGE="http://www.beagle-project.org/"
+LICENSE="MIT Apache-1.1"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="spreadsheet pdf webservices wv chm debug"
+
+RDEPEND=">=dev-lang/mono-1.1.9.1
+ app-shells/bash
+ app-arch/zip
+ sys-devel/gettext
+ =dev-db/sqlite-2*
+ =gnome-base/gnome-vfs-2*
+ =gnome-base/libgnome-2*
+ >=www-client/mozilla-1.6
+ >=x11-libs/gtk+-2.6
+ >=dev-libs/glib-2.6
+ >=dev-dotnet/gtk-sharp-2.3
+ >=dev-dotnet/glade-sharp-2.3
+ >=dev-dotnet/gecko-sharp-0.11
+ >=dev-dotnet/gnome-sharp-2.3
+ >=dev-dotnet/gconf-sharp-2.3
+ >=dev-libs/gmime-2.1.16
+ >=dev-libs/atk-1.2.4
+ >=media-libs/libexif-0.6.0
+ >=dev-libs/libxml2-2.6.19
+ wv? (>=app-text/wv-1.0.3-r1)
+ chm? (app-doc/chmlib)
+ pdf? ( app-text/xpdf )
+ spreadsheet? ( >=app-office/gnumeric-1.4.3-r3 )
+ ||( (
+ x11-libs/libX11
+ x11-libs/libXScrnSaver
+ x11-libs/libXt
+ x11-libs/libICE
+ x11-libs/libSM )
+ virtual/x11 )"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ ||( (
+ x11-proto/xproto
+ x11-proto/scrnsaverproto )
+ virtual/x11 )"
+
+USE_DESTDIR="1"
+
+pkg_setup() {
+ DOCS="AUTHORS ChangeLog INSTALL NEWS README"
+
+ G2CONF="${G2CONF} \
+ $(use_enable webservices) \
+ --enable-libbeagle \
+ --disable-evolution-sharp"
+
+ if built_with_use dev-libs/gmime mono
+ then
+ einfo "Mono support enabled in dev-libs/gmime, I will continue..."
+ else
+ eerror "Please rebuild dev-libs/gmime, with mono support enabled!"
+ eerror "Try USE=\"mono\" emerge dev-libs/gmime,"
+ eerror "or add \"mono\" to your USE string in /etc/make.conf and"
+ eerror "emerge dev-libs/gmime."
+ die "Mono USE flag must be enabled in dev-libs/gmime"
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ # To prevent excessive revdep-rebuild, gentoo's libexif is sticking to
+ # soversion 10 for now.
+ sed -i -e 's/EXIF_SOVERSION=12/EXIF_SOVERSION=10/' configure.in
+
+ # Don't log so much
+ ! use debug && sed -i -e \
+ 's/defaultLevel = LogLevel.Debug/defaultLevel = LogLevel.Info/' \
+ Util/Logger.cs
+
+ # Fix an indexing crasher
+ epatch ${FILESDIR}/${P}-null-task-source.patch
+
+ # Fix handling of filenames
+ epatch ${FILESDIR}/${P}-uri-serialization.patch
+}
+
+src_install() {
+ gnome2_src_install
+
+ dodir /usr/share/beagle
+ insinto /usr/share/beagle
+ doins mozilla-extension/beagle.xpi
+}
+
+pkg_postinst () {
+ gnome2_pkg_postinst
+
+ einfo "If available, Beagle greatly benefits from using certain operating"
+ einfo "system features such as Extended Attributes and inotify."
+ echo
+ einfo "For more info on how to create the optimal beagle environment, and"
+ einfo "basic usage info, see the Gentoo page of the Beagle website:"
+ einfo " http://www.beagle-project.org/Gentoo_Installation"
+}
+
diff --git a/app-misc/beagle/files/beagle-0.1.1-null-task-source.patch b/app-misc/beagle/files/beagle-0.1.1-null-task-source.patch
new file mode 100644
index 000000000000..2e742dcd7611
--- /dev/null
+++ b/app-misc/beagle/files/beagle-0.1.1-null-task-source.patch
@@ -0,0 +1,31 @@
+--- beagled/KopeteQueryable/KopeteQueryable.cs 29 Aug 2005 05:34:06 -0000 1.3
++++ beagled/KopeteQueryable/KopeteQueryable.cs 6 Oct 2005 12:40:52 -0000 1.4
+@@ -74,8 +74,9 @@ namespace Beagle.Daemon.KopeteQueryable
+
+ if (!Inotify.Enabled) {
+ Scheduler.Task task = Scheduler.TaskFromHook (new Scheduler.TaskHook (CrawlHook));
+- task.Tag = "Crawling ~/.kopete/logs to find new logfiles";
+- ThisScheduler.Add (task);
++ task.Tag = "Crawling ~/.kopete/logs to find new logfiles";
++ task.Source = this;
++ ThisScheduler.Add (task);
+ }
+
+ stopwatch.Stop ();
+--- beagled/IndexSynchronization.cs 13 Jul 2005 16:28:40 -0000 1.1
++++ beagled/IndexSynchronization.cs 6 Oct 2005 15:51:45 -0000
+@@ -68,12 +68,14 @@ namespace Beagle.Daemon {
+ task.Tag = "Synchronize Indexes";
+ task.Priority = Scheduler.Priority.Delayed;
+ task.TriggerTime = DateTime.Now.AddMinutes (sync_interval_in_minutes);
++ task.Source = synchronization_lock;
+ Scheduler.Global.Add (task);
+
+ // Set up the shutdown synchronization task
+ task = Scheduler.TaskFromHook (new Scheduler.TaskHook (ShutdownHook));
+ task.Tag = "Synchronize Indexes on Shutdown";
+ task.Priority = Scheduler.Priority.Shutdown;
++ task.Source = synchronization_lock;
+ Scheduler.Global.Add (task);
+ }
+
diff --git a/app-misc/beagle/files/beagle-0.1.1-uri-serialization.patch b/app-misc/beagle/files/beagle-0.1.1-uri-serialization.patch
new file mode 100644
index 000000000000..181c6e734e86
--- /dev/null
+++ b/app-misc/beagle/files/beagle-0.1.1-uri-serialization.patch
@@ -0,0 +1,76 @@
+--- beagle-0.1.1/Util/UriFu.cs.orig 2005-10-24 14:13:05.000000000 +0100
++++ beagle-0.1.1/Util/UriFu.cs 2005-10-24 14:13:18.000000000 +0100
+@@ -42,58 +42,35 @@ namespace Beagle.Util {
+
+ static public Uri UriStringToUri (string path)
+ {
+- // Decode our pre-encoded 'odd' characters into their real values
+- int i = 0, pos = 0;
+- while ((i = path.IndexOf ('%', pos)) != -1) {
+- pos = i;
+- char unescaped = UriFu.HexUnescape (path, ref pos);
+- if (unescaped < '!' || unescaped > '~') {
+- path = path.Remove (i, 3);
+- path = path.Insert (i, new String(unescaped, 1));
+- pos -= 2;
+- }
+- }
+-
+- // Paths from the file:// indexer need (re)quoting. For example,
+- // valid characters such as @ need to be converted to their hex
+- // values.
+- if (path.StartsWith ("file://")) {
+- // Remove the file:// prefix
+- path = path.Substring (7);
+-
+- return PathToFileUri (path);
+- }
+-
+- // Currently, no other protocols need extra processing
++ // Our current hackery attempts to serialize Uri strings in
++ // escaped and constructable form, so we don't require any
++ // extra processing on deserialization right now.
+ return new Uri (path, true);
+ }
+
+ static public String UriToSerializableString (Uri uri)
+ {
+ int i;
+- string ret;
++ string path;
+ StringBuilder builder = new StringBuilder ();
+-
+- // The ToString() of a file:// URI is not always representative of
+- // what it was constructed from. For example, it will return a
+- // # (which was inputted as %23) as %23, whereas the more standard
+- // behaviour for other escaped-characters is to return them as
+- // their actual character. (e.g. %40 gets returned as @)
+- // On the other hand, the LocalPath of a file:// URI does seem to
+- // return the literal # so we use that instead.
++
+ if (uri.IsFile)
+- ret = Uri.UriSchemeFile + Uri.SchemeDelimiter + uri.LocalPath;
++ path = Uri.UriSchemeFile + Uri.SchemeDelimiter
++ + StringFu.HexEscape (uri.LocalPath);
+ else
+- ret = uri.ToString ();
++ path = uri.ToString ();
+
+ // XmlSerializer is happy to serialize 'odd' characters, but doesn't
+ // like to deserialize them. So we encode all 'odd' characters now.
+- for (i = 0; i < ret.Length; i++)
+- if ((ret [i] < '!') || (ret [i] > '~' && ret [i] < 256))
+- builder.Append (Uri.HexEscape (ret [i]));
++ for (i = 0; i < path.Length; i++)
++ if ((path [i] < '!') || (path [i] > '~' && path [i] < 256))
++ builder.Append (Uri.HexEscape (path [i]));
+ else
+- builder.Append (ret [i]);
++ builder.Append (path [i]);
+
++ if (uri.IsFile)
++ builder.Append (uri.Fragment);
++
+ return builder.ToString ();
+ }
+
diff --git a/app-misc/beagle/files/digest-beagle-0.1.1 b/app-misc/beagle/files/digest-beagle-0.1.1
new file mode 100644
index 000000000000..0502b41f4e14
--- /dev/null
+++ b/app-misc/beagle/files/digest-beagle-0.1.1
@@ -0,0 +1 @@
+MD5 e788ed11077e576797a0793631f2fe8b beagle-0.1.1.tar.bz2 1178163
diff --git a/app-misc/beagle/metadata.xml b/app-misc/beagle/metadata.xml
new file mode 100644
index 000000000000..11616e7f96a6
--- /dev/null
+++ b/app-misc/beagle/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+ <email>dsd@gentoo.org</email>
+ <name>Daniel Drake</name>
+</maintainer>
+</pkgmetadata>