summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Johanson <latexer@gentoo.org>2003-02-06 02:12:10 +0000
committerPeter Johanson <latexer@gentoo.org>2003-02-06 02:12:10 +0000
commit35ad17b0e66e0d6d68b80f4f23c05f7f5a085e5a (patch)
tree2dee8f2e51bce941e1bfe5780f912271cb12016d /app-misc
parentAdded a comment about suid root (diff)
downloadhistorical-35ad17b0e66e0d6d68b80f4f23c05f7f5a085e5a.tar.gz
historical-35ad17b0e66e0d6d68b80f4f23c05f7f5a085e5a.tar.bz2
historical-35ad17b0e66e0d6d68b80f4f23c05f7f5a085e5a.zip
Updated ebuild. #15004.
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/lcdproc/ChangeLog9
-rw-r--r--app-misc/lcdproc/files/LCDd8
-rw-r--r--app-misc/lcdproc/files/digest-lcdproc-0.4.3-r21
-rw-r--r--app-misc/lcdproc/files/lcdproc11
-rw-r--r--app-misc/lcdproc/lcdproc-0.4.3-r2.ebuild99
5 files changed, 120 insertions, 8 deletions
diff --git a/app-misc/lcdproc/ChangeLog b/app-misc/lcdproc/ChangeLog
index 239e21a24f8f..6ad282da5686 100644
--- a/app-misc/lcdproc/ChangeLog
+++ b/app-misc/lcdproc/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-misc/lcdproc
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/app-misc/lcdproc/ChangeLog,v 1.4 2003/01/07 16:58:28 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/lcdproc/ChangeLog,v 1.5 2003/02/06 02:12:10 latexer Exp $
+
+*lcdproc-0.4.3-r2 (05 Feb 2003)
+
+ 05 Feb 2003; Peter Johanson <latexer@gentoo.org> lcdproc-0.4.3-r2.ebuild :
+ Ebuild updates as per #15004. Now build specific drivers by setting
+ LCDPROC_DRIVERS before emerging. Updated init scripts as well. Updates thanks
+ to Rene Wagner <reenoo@gmx.net>.
*lcdproc-0.4.3-r1 (07 Jan 2003)
diff --git a/app-misc/lcdproc/files/LCDd b/app-misc/lcdproc/files/LCDd
index 92a7c4365c75..b90ec0056417 100644
--- a/app-misc/lcdproc/files/LCDd
+++ b/app-misc/lcdproc/files/LCDd
@@ -1,7 +1,7 @@
#!/sbin/runscript
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/app-misc/lcdproc/files/LCDd,v 1.1 2003/01/07 16:59:04 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/lcdproc/files/LCDd,v 1.2 2003/02/06 02:12:10 latexer Exp $
depend() {
need net
@@ -9,12 +9,14 @@ depend() {
start() {
ebegin "Starting LCDd"
- /usr/sbin/LCDd -c /etc/LCDd.conf
+ start-stop-daemon --start --quiet -m --pidfile /var/run/LCDd.pid \
+ --background --exec /usr/sbin/LCDd -- -c /etc/LCDd.conf
+ sleep 1
eend $?
}
stop() {
ebegin "Stopping LCDd"
- killall LCDd
+ start-stop-daemon --stop --quiet --pidfile /var/run/LCDd.pid
eend $?
}
diff --git a/app-misc/lcdproc/files/digest-lcdproc-0.4.3-r2 b/app-misc/lcdproc/files/digest-lcdproc-0.4.3-r2
new file mode 100644
index 000000000000..1f5322b6c793
--- /dev/null
+++ b/app-misc/lcdproc/files/digest-lcdproc-0.4.3-r2
@@ -0,0 +1 @@
+MD5 77228a346a1f4347eb0db7383c76c988 lcdproc-0.4.3.tar.gz 351458
diff --git a/app-misc/lcdproc/files/lcdproc b/app-misc/lcdproc/files/lcdproc
index ec3a8f5e1e35..ff1fb0e4d3b5 100644
--- a/app-misc/lcdproc/files/lcdproc
+++ b/app-misc/lcdproc/files/lcdproc
@@ -1,18 +1,21 @@
#!/sbin/runscript
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/app-misc/lcdproc/files/lcdproc,v 1.5 2003/01/07 16:58:28 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/lcdproc/files/lcdproc,v 1.6 2003/02/06 02:12:10 latexer Exp $
+depend(){
+ need LCDd
+}
start() {
- ebegin "Starting LCDProc"
source /etc/lcdproc.conf
ebegin "Starting lcdproc"
- /usr/bin/lcdproc -d ${SCREENS}
+ start-stop-daemon --start --background \
+ --exec /usr/bin/lcdproc -- -d ${SCREENS}
eend $?
}
stop() {
ebegin "Stopping LCDProc"
- killall lcdproc
+ start-stop-daemon --stop --exec /usr/bin/lcdproc
eend $?
}
diff --git a/app-misc/lcdproc/lcdproc-0.4.3-r2.ebuild b/app-misc/lcdproc/lcdproc-0.4.3-r2.ebuild
new file mode 100644
index 000000000000..95117e5494dd
--- /dev/null
+++ b/app-misc/lcdproc/lcdproc-0.4.3-r2.ebuild
@@ -0,0 +1,99 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/lcdproc/lcdproc-0.4.3-r2.ebuild,v 1.1 2003/02/06 02:12:10 latexer Exp $
+
+SRC_URI="mirror://sourceforge/lcdproc/${P}.tar.gz"
+DESCRIPTION="Client/Server suite to drive all kinds of LCD (-like) devices"
+HOMEPAGE="http://lcdproc.org/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86"
+IUSE="doc ncurses svga"
+
+DEPEND=">=sys-apps/baselayout-1.6.4
+ doc? ( >=app-text/docbook-sgml-utils-0.6.11-r2 )
+ ncurses? ( >=sys-libs/ncurses-5.3 )
+ svga? ( >=media-libs/svgalib-1.4.3 )"
+
+src_unpack() {
+ unpack ${A} || die
+ cd ${S}
+
+ sed -i "889s:-O3:${CFLAGS}:" configure
+
+ # fix a few bugs ;)
+ patch -p2 < ${FILESDIR}/${P}-gentoo.diff || die \
+ "Patch #1 failed."
+}
+
+src_compile() {
+
+ # By default, all drivers that are supported by the given plattform/hardware
+ # are compiled (of course respecting the existing USE flags). If the
+ # LCDPROC_DRIVERS environment variable is set to a comma separated list, only
+ # the specified drivers will be compiled.
+ # Example:
+ #
+ # env LCDPROC_DRIVERS="curses,CFontz" emerge lcdproc
+ #
+ # NOTE: The ebuild still respects your USE variable and will not install any
+ # additional packages unless the corresponding USE flag is set!
+ # You might have to alter it if e.g. ncurses is normally not part of your
+ # USE variable.
+ # Example:
+ #
+ # env USE="$USE ncurses" LCDPROC_DRIVERS="curses,CFontz" emerge lcdproc
+
+ local myconf
+
+ myconf="--enable-drivers=mtxorb,cfontz,text,lb216,hd44780,joy,irman,lircin,"
+ myconf="${myconf}bayrad,glk,stv5730,sed1330,sed1520,lcdm001,t6963"
+
+ use ncurses && myconf="${myconf},curses"
+ use svga && myconf="${myconf},svgalib"
+
+ [ x"${LCDPROC_DRIVERS}" = x ] || \
+ myconf="--enable-drivers=${LCDPROC_DRIVERS}"
+
+ use samba && myconf="${myconf} --enable-stat-smbfs"
+ myconf="${myconf} --enable-stat-nfs"
+
+ econf ${myconf} || die
+ emake || die
+
+ if [ `use doc` ]; then
+ cd ${S}/docs/lcdproc-user
+ docbook2html lcdproc-user.docbook
+ fi
+}
+
+src_install() {
+ dosbin server/LCDd
+ dobin clients/lcdproc/lcdproc
+
+ doman docs/lcdproc.1 docs/LCDd.8
+
+ dodoc README ChangeLog COPYING INSTALL
+
+ if [ `use doc` ]; then
+ insinto /usr/share/doc/${PF}/lcdproc-user
+ doins docs/lcdproc-user/*.html
+ fi
+
+ docinto olddocs
+ dodoc docs/README.dg* docs/*.txt
+
+ insinto /usr/share/doc/${PF}/clients/examples
+ doins clients/examples/*.pl
+ insinto /usr/share/doc/${PF}/clients/headlines
+ doins clients/headlines/lcdheadlines
+
+ insinto /etc
+ doins LCDd.conf
+ doins scripts/lcdproc.conf
+
+ exeinto /etc/init.d
+ doexe ${FILESDIR}/LCDd
+ doexe ${FILESDIR}/lcdproc
+}