summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2004-10-30 03:53:10 +0000
committerAron Griffis <agriffis@gentoo.org>2004-10-30 03:53:10 +0000
commit3290d9b19075255b64113bee8d2e481e43822704 (patch)
tree722789ef570345992f3b87caa4948d3bd7ba65e7 /app-misc
parentFixed permissions issue per bug #64558 for ferringb. (diff)
downloadhistorical-3290d9b19075255b64113bee8d2e481e43822704.tar.gz
historical-3290d9b19075255b64113bee8d2e481e43822704.tar.bz2
historical-3290d9b19075255b64113bee8d2e481e43822704.zip
Add ebuild for Jim Jozwiak's nutrition program. Thanks to Chris Houser (Chouser) for the ebuild
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/nut/ChangeLog10
-rw-r--r--app-misc/nut/Manifest4
-rw-r--r--app-misc/nut/files/digest-nut-10.71
-rw-r--r--app-misc/nut/metadata.xml8
-rw-r--r--app-misc/nut/nut-10.7.ebuild26
5 files changed, 49 insertions, 0 deletions
diff --git a/app-misc/nut/ChangeLog b/app-misc/nut/ChangeLog
new file mode 100644
index 000000000000..2cc518feef02
--- /dev/null
+++ b/app-misc/nut/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for app-misc/nut
+# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/nut/ChangeLog,v 1.1 2004/10/30 03:53:10 agriffis Exp $
+
+*nut-10.7 (29 Oct 2004)
+
+ 29 Oct 2004; Aron Griffis <agriffis@gentoo.org> +nut-10.7.ebuild:
+ Add ebuild for Jim Jozwiak's nutrition program. Thanks to Chris Houser
+ (Chouser) for the ebuild
+
diff --git a/app-misc/nut/Manifest b/app-misc/nut/Manifest
new file mode 100644
index 000000000000..b9e099fcb675
--- /dev/null
+++ b/app-misc/nut/Manifest
@@ -0,0 +1,4 @@
+MD5 f9279406b233d265ea14e85921163835 nut-10.7.ebuild 685
+MD5 5646e5c85486f6dfdd4c1aa7684b56c2 ChangeLog 393
+MD5 0438280d99e7ca0de9ea61818e31e586 metadata.xml 224
+MD5 6b54b1872dd19d3d2c74bd862a6970af files/digest-nut-10.7 61
diff --git a/app-misc/nut/files/digest-nut-10.7 b/app-misc/nut/files/digest-nut-10.7
new file mode 100644
index 000000000000..c5d663a044bc
--- /dev/null
+++ b/app-misc/nut/files/digest-nut-10.7
@@ -0,0 +1 @@
+MD5 834e4e04f58a5aaf6197923638073662 nut-10.7.tar.bz2 814785
diff --git a/app-misc/nut/metadata.xml b/app-misc/nut/metadata.xml
new file mode 100644
index 000000000000..e6e18bf1ae5f
--- /dev/null
+++ b/app-misc/nut/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>no-herd</herd>
+<maintainer>
+ <email>agriffis@gentoo.org</email>
+</maintainer>
+</pkgmetadata>
diff --git a/app-misc/nut/nut-10.7.ebuild b/app-misc/nut/nut-10.7.ebuild
new file mode 100644
index 000000000000..5921b2beaebb
--- /dev/null
+++ b/app-misc/nut/nut-10.7.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/nut/nut-10.7.ebuild,v 1.1 2004/10/30 03:53:10 agriffis Exp $
+
+inherit flag-o-matic
+
+DESCRIPTION="record what you eat and analyze your nutrient levels"
+HOMEPAGE="http://www.lafn.org/~av832/"
+SRC_URI="http://www.lafn.org/~av832/${P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+DEPEND=""
+
+src_compile() {
+ append-flags '-DNUTDIR=\".nutdb\" -DFOODDIR=\"/usr/share/nut\"'
+ emake CFLAGS="${CFLAGS}" || die "emake failed"
+}
+
+src_install() {
+ dodir /usr/share/nut
+ cp -a raw.data/* ${D}/usr/share/nut/
+ dobin nut
+ doman nut.1
+}