summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Phillips <rphillips@gentoo.org>2002-06-10 02:01:53 +0000
committerRyan Phillips <rphillips@gentoo.org>2002-06-10 02:01:53 +0000
commit1a68b77da07b3f3fac35025c24a786632522de83 (patch)
treea28861ef94f0ccabcd9b87ae4c8bfcc96e84d166 /app-misc
parentNew package. Fixes #3446 (diff)
downloadhistorical-1a68b77da07b3f3fac35025c24a786632522de83.tar.gz
historical-1a68b77da07b3f3fac35025c24a786632522de83.tar.bz2
historical-1a68b77da07b3f3fac35025c24a786632522de83.zip
new package. Fixes #3447
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/gtktrain/ChangeLog13
-rw-r--r--app-misc/gtktrain/files/digest-gtktrain-0.9b1
-rw-r--r--app-misc/gtktrain/gtktrain-0.9b.ebuild38
3 files changed, 52 insertions, 0 deletions
diff --git a/app-misc/gtktrain/ChangeLog b/app-misc/gtktrain/ChangeLog
new file mode 100644
index 000000000000..51a72dd4ad5f
--- /dev/null
+++ b/app-misc/gtktrain/ChangeLog
@@ -0,0 +1,13 @@
+# ChangeLog for app-misc/gtktrain
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
+# $Header: /var/cvsroot/gentoo-x86/app-misc/gtktrain/ChangeLog,v 1.1 2002/06/10 02:01:53 rphillips Exp $
+
+*gtktrain-0.9b (09 June 2002)
+
+ 09 June 2002; Ryan Phillips <rphillips@gentoo.org> ChangeLog :
+
+ Added initial ChangeLog which should be updated whenever the package is
+ updated in any way. This changelog is targetted to users. This means that the
+ comments should well explained and written in clean English. The details about
+ writing correct changelogs are explained in the skel.ChangeLog file which you
+ can find in the root directory of the portage repository.
diff --git a/app-misc/gtktrain/files/digest-gtktrain-0.9b b/app-misc/gtktrain/files/digest-gtktrain-0.9b
new file mode 100644
index 000000000000..f1e79f473a47
--- /dev/null
+++ b/app-misc/gtktrain/files/digest-gtktrain-0.9b
@@ -0,0 +1 @@
+MD5 8ed8f16f95cdc1ec9743203fc615115a gtktrain-0.9b.tar.gz 137705
diff --git a/app-misc/gtktrain/gtktrain-0.9b.ebuild b/app-misc/gtktrain/gtktrain-0.9b.ebuild
new file mode 100644
index 000000000000..6c22cdacdb6c
--- /dev/null
+++ b/app-misc/gtktrain/gtktrain-0.9b.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/gtktrain/gtktrain-0.9b.ebuild,v 1.1 2002/06/10 02:01:53 rphillips Exp $
+
+DESCRIPTION="GUI app for calculating fastest train routes"
+SRC_URI="http://www.on.rim.or.jp/~katamuki/software/train/${P}.tar.gz"
+HOMEPAGE="http://www.on.rim.or.jp/~katamuki/software/train/"
+LICENSE="GPL-2"
+DEPEND=">=dev-libs/libtrain-0.9b
+ >=gnome-base/gnome-libs-1.4.1.2-r1"
+
+src_compile() {
+ if [ -z "`use nls`" ] ; then
+ NLS_OPTION="--disable-nls"
+ fi
+
+ ./configure \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man \
+ ${NLS_OPTION} || die "./configure failed"
+
+ emake || die
+}
+
+src_install () {
+ make \
+ prefix=${D}/usr \
+ mandir=${D}/usr/share/man \
+ infodir=${D}/usr/share/info \
+ install || die
+}
+
+pkg_postinst () {
+ einfo "Japanese train routes are located: "
+ einfo " http://www.oohito.com/data/train/index.htm"
+}