summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAJ Lewis <roadrunner@gentoo.org>2001-04-25 20:40:49 +0000
committerAJ Lewis <roadrunner@gentoo.org>2001-04-25 20:40:49 +0000
commit7d0d99c7bfcee79e270295d83f1167cca9816f6a (patch)
treeb160488245e5302770246184d44cc10bb3993d23 /app-misc/twin/twin-0.2.8.ebuild
parent- adding ckermit (diff)
downloadhistorical-7d0d99c7bfcee79e270295d83f1167cca9816f6a.tar.gz
historical-7d0d99c7bfcee79e270295d83f1167cca9816f6a.tar.bz2
historical-7d0d99c7bfcee79e270295d83f1167cca9816f6a.zip
o twin 0.2.8! This is kinda of a clunky version, but it is "stable"
Diffstat (limited to 'app-misc/twin/twin-0.2.8.ebuild')
-rw-r--r--app-misc/twin/twin-0.2.8.ebuild60
1 files changed, 60 insertions, 0 deletions
diff --git a/app-misc/twin/twin-0.2.8.ebuild b/app-misc/twin/twin-0.2.8.ebuild
new file mode 100644
index 000000000000..4ea52147132a
--- /dev/null
+++ b/app-misc/twin/twin-0.2.8.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author AJ Lewis <aj@gentoo.org>
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="A text-mode window environment"
+SRC_URI="http://ftp1.sourceforge.net/twin/${A}
+ http://linuz.sns.it/~max/twin/${A}"
+HOMEPAGE="http://linuz.sns.it/~max/twin/"
+DEPEND="virtual/glibc
+ X? ( >=x11-base/xfree-4.0.1 )
+ >=sys-libs/ncurses-5.2"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ try patch -p1 < ${FILESDIR}/${PF}-gentoo.diff
+}
+
+src_compile() {
+ local conf
+
+ conf="\n\n\n\n\n\n\n\n"
+ if [ "`use X`" ]
+ then
+ conf=${conf}"y\n"
+ else
+ conf=${conf}"n\n"
+ fi
+ conf=${conf}"\n\n\n\n\n"
+ echo -e ${conf} > .temp
+ cat .temp | make config
+ rm .temp
+ try make clean
+ try make
+}
+
+src_install() {
+
+ dodir /usr/lib /usr/bin /usr/lib/ /usr/include
+
+ dobin server/twin_real server/twin_wrapper
+ dobin clients/twsetroot clients/twevent clients/twmapscrn \
+ clients/twedit clients/twterm clients/twattach clients/twsysmon
+
+ dolib lib/libTw.so.1.0.0
+
+ insinto /usr/include
+ doins include/libTwkeys.h include/libTw.h include/libTwerrno.h
+
+ dosym /usr/bin/twin_wrapper /usr/bin/twin
+ dosym /usr/bin/twattach /usr/bin/twdetach
+ dosym /usr/lib/libTw.so.1.0.0 /usr/lib/libTw.so.1
+ dosym /usr/lib/libTw.so.1 /usr/lib/libTw.so
+
+ dodoc BUGS COPYING COPYING.LIB INSTALL README TODO Changelog.txt ${P}.lsm
+ docinto clients
+ dodoc clients/README.twsetroot clients/twsetroot.sample
+}