summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTavis Ormandy <taviso@gentoo.org>2003-08-04 09:52:28 +0000
committerTavis Ormandy <taviso@gentoo.org>2003-08-04 09:52:28 +0000
commitec26b8e068ef048be16cbaf1f77fe1f4b90cc6fd (patch)
treec72348219fb48c119047ee25338f56cae6b1994f /app-misc/tdl/tdl-1.4.1.ebuild
parentinitial import (diff)
downloadhistorical-ec26b8e068ef048be16cbaf1f77fe1f4b90cc6fd.tar.gz
historical-ec26b8e068ef048be16cbaf1f77fe1f4b90cc6fd.tar.bz2
historical-ec26b8e068ef048be16cbaf1f77fe1f4b90cc6fd.zip
initial import
Diffstat (limited to 'app-misc/tdl/tdl-1.4.1.ebuild')
-rw-r--r--app-misc/tdl/tdl-1.4.1.ebuild61
1 files changed, 61 insertions, 0 deletions
diff --git a/app-misc/tdl/tdl-1.4.1.ebuild b/app-misc/tdl/tdl-1.4.1.ebuild
new file mode 100644
index 000000000000..11dda7d3f7bd
--- /dev/null
+++ b/app-misc/tdl/tdl-1.4.1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/tdl/tdl-1.4.1.ebuild,v 1.1 2003/08/04 09:52:20 taviso Exp $
+
+DESCRIPTION="Command line To Do List manager"
+HOMEPAGE="http://www.rc0.org.uk/tdl/"
+SRC_URI="http://www.rrbcurnow.freeuk.com/tdl/${P}.tar.gz"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~x86 ~alpha"
+IUSE="readline ncurses doc"
+
+RDEPEND="readline? ( >=sys-libs/readline-4.3
+ ncurses? ( sys-libs/ncurses )
+ !ncurses? ( sys-libs/libtermcap-compat ) )
+ doc? ( app-text/tetex )"
+DEPEND="${RDEPEND}
+ sys-apps/texinfo
+ >=sys-apps/sed-4"
+
+S=${WORKDIR}/${P}
+
+src_compile() {
+ local myconf="--prefix=/usr"
+
+ if ! use readline; then
+ myconf="${myconf} --without-readline"
+ else
+ if use ncurses; then
+ sed -i 's#-ltermcap#-lncurses#g' ${S}/configure
+ else
+ sed -i 's#-lncurses##g' ${S}/configure
+ fi
+ fi
+
+ ./configure ${myconf} || die "configure failed, sorry!"
+ emake all tdl.info tdl.html tdl.txt || die
+ use doc && emake tdl.dvi tdl.ps tdl.pdf
+}
+
+src_install() {
+ local i
+
+ dodoc COPYING README NEWS
+ doinfo tdl.info
+ dohtml tdl.html
+
+ dobin tdl
+ doman tdl.1
+
+ for i in tdl{a,l,d,g}
+ do
+ dosym tdl /usr/bin/${i}
+ dosym tdl.1 /usr/share/man/man1/${i}.1
+ done
+
+ prepallman
+
+ use doc && dodoc tdl.dvi tdl.ps tdl.pdf
+}