summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-03-01 01:12:02 +0000
committerMike Frysinger <vapier@gentoo.org>2003-03-01 01:12:02 +0000
commit4a1cbda0fe67b339956101bd46d481dd48221e8c (patch)
tree6b6ae376e27faed12d2d85375ff90704992abe33 /app-misc/gtypist
parentpatches for 5.8.0-r10 (diff)
downloadhistorical-4a1cbda0fe67b339956101bd46d481dd48221e8c.tar.gz
historical-4a1cbda0fe67b339956101bd46d481dd48221e8c.tar.bz2
historical-4a1cbda0fe67b339956101bd46d481dd48221e8c.zip
touchups
Diffstat (limited to 'app-misc/gtypist')
-rw-r--r--app-misc/gtypist/gtypist-2.5.ebuild13
-rw-r--r--app-misc/gtypist/gtypist-2.6.2.ebuild14
2 files changed, 6 insertions, 21 deletions
diff --git a/app-misc/gtypist/gtypist-2.5.ebuild b/app-misc/gtypist/gtypist-2.5.ebuild
index 98bcc6fc0bde..c23de4428c38 100644
--- a/app-misc/gtypist/gtypist-2.5.ebuild
+++ b/app-misc/gtypist/gtypist-2.5.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/gtypist/gtypist-2.5.ebuild,v 1.10 2003/02/13 09:01:39 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/gtypist/gtypist-2.5.ebuild,v 1.11 2003/03/01 01:10:15 vapier Exp $
-DESCRIPTION="GNU Typist (also called gtypist) is a universal typing tutor."
+DESCRIPTION="universal typing tutor"
SRC_URI="ftp://ftp.gnu.org/gnu/gtypist/${P}.tar.gz"
HOMEPAGE="http://www.gnu.org/software/gtypist/gtypist.html"
@@ -14,18 +14,11 @@ IUSE="nls"
DEPEND=">=sys-libs/ncurses-5.2"
src_compile() {
- local myconf
-
- # gtypist uses a built in gettext
- use nls \
- && myconf="--enable-nls" \
- || myconf="--disable-nls"
-
# gtypist also produces some Emacs/XEmacs editing modes if
# emacs/xemacs is present. if emacs/xemacs is not present then
# these emacs modes are not compiled or installed.
- econf ${myconf}
+ econf `use_enable nls` || die
emake || die
}
diff --git a/app-misc/gtypist/gtypist-2.6.2.ebuild b/app-misc/gtypist/gtypist-2.6.2.ebuild
index 3757e214ef6a..8b9d962922d6 100644
--- a/app-misc/gtypist/gtypist-2.6.2.ebuild
+++ b/app-misc/gtypist/gtypist-2.6.2.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/gtypist/gtypist-2.6.2.ebuild,v 1.3 2003/02/13 09:01:45 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/gtypist/gtypist-2.6.2.ebuild,v 1.4 2003/03/01 01:10:15 vapier Exp $
-DESCRIPTION="GNU Typist (also called gtypist) is a universal typing tutor."
+DESCRIPTION="universal typing tutor"
SRC_URI="mirror://gnu/gtypist/${P}.tar.gz"
HOMEPAGE="http://www.gnu.org/software/gtypist/gtypist.html"
@@ -14,18 +14,10 @@ IUSE="nls"
DEPEND=">=sys-libs/ncurses-5.2"
src_compile() {
- local myconf
-
- # gtypist uses a built in gettext
- use nls \
- && myconf="--enable-nls" \
- || myconf="--disable-nls"
-
# gtypist also produces some Emacs/XEmacs editing modes if
# emacs/xemacs is present. if emacs/xemacs is not present then
# these emacs modes are not compiled or installed.
-
- econf ${myconf}
+ econf `use_enable nls` || die
emake || die
}