summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Ahlberg <aliz@gentoo.org>2002-12-03 13:36:19 +0000
committerDaniel Ahlberg <aliz@gentoo.org>2002-12-03 13:36:19 +0000
commit2f50b522707023823e73c57ebc52f50e86b9bee0 (patch)
treeb1d5b75ca54d99b65508b34f563ee905295427bf /app-misc/dnetc/dnetc-2.9001.478.ebuild
parentutempter: a daemon that grants safe root access to unprivileged programs. use... (diff)
downloadhistorical-2f50b522707023823e73c57ebc52f50e86b9bee0.tar.gz
historical-2f50b522707023823e73c57ebc52f50e86b9bee0.tar.bz2
historical-2f50b522707023823e73c57ebc52f50e86b9bee0.zip
New clients for RC5-72
Diffstat (limited to 'app-misc/dnetc/dnetc-2.9001.478.ebuild')
-rw-r--r--app-misc/dnetc/dnetc-2.9001.478.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/app-misc/dnetc/dnetc-2.9001.478.ebuild b/app-misc/dnetc/dnetc-2.9001.478.ebuild
new file mode 100644
index 000000000000..1cde4dae73b4
--- /dev/null
+++ b/app-misc/dnetc/dnetc-2.9001.478.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/dnetc/dnetc-2.9001.478.ebuild,v 1.1 2002/12/03 13:36:19 aliz Exp $
+
+MAJ_PV=${PV:0:6}
+MIN_PV=${PV:7:9}
+
+DESCRIPTION="distributed.net client"
+HOMEPAGE="http://www.distributed.net"
+SRC_URI="ppc? ( http://http.distributed.net/pub/dcti/v${MAJ_PV}/dnetc${MIN_PV}-linux-ppc.tar.gz )
+ x86? ( http://http.distributed.net/pub/dcti/v${MAJ_PV}/dnetc${MIN_PV}-linux-x86-elf.tar.gz )"
+LICENSE="distributed.net"
+SLOT="0"
+KEYWORDS="x86 ppc -sparc -sparc64 -alpha"
+IUSE=""
+DEPEND=""
+#RDEPEND=""
+S="${WORKDIR}"
+RESTRICT="nomirror"
+
+src_install() {
+ exeinto /opt/distributed.net
+ doexe dnetc
+
+ doman dnetc.1
+ dodoc docs/*
+
+ exeinto /etc/init.d ; newexe ${FILESDIR}/dnetc.init dnetc
+ insinto /etc/conf.d ; newins ${FILESDIR}/dnetc.conf dnetc
+}
+
+pkg_postinst() {
+ einfo "Either configure your email adress in /etc/conf.d/dnetc"
+ einfo "or create the configuration file /opt/distributed.net/dnetc.ini"
+}
+
+pkg_postrm() {
+ if [ -d /opt/distributed.net ]; then
+ einfo "All files has not been removed from /opt/distributed.net"
+ fi
+}