summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Walker <ka0ttic@gentoo.org>2004-09-11 15:31:51 +0000
committerAaron Walker <ka0ttic@gentoo.org>2004-09-11 15:31:51 +0000
commitd1e0e3ef6de2ac417c24e2babd0f76ce51741ac1 (patch)
treedfeafad2bdc7ca4a6aa50a0f1677fe8e69403ace /app-misc/devtodo
parentfix dependencies, #63498 (diff)
downloadhistorical-d1e0e3ef6de2ac417c24e2babd0f76ce51741ac1.tar.gz
historical-d1e0e3ef6de2ac417c24e2babd0f76ce51741ac1.tar.bz2
historical-d1e0e3ef6de2ac417c24e2babd0f76ce51741ac1.zip
Version bump; Upstream fixes for bugs 35449, 60206, and 60207. Also added bash-completion script (please test)
Diffstat (limited to 'app-misc/devtodo')
-rw-r--r--app-misc/devtodo/ChangeLog9
-rw-r--r--app-misc/devtodo/Manifest6
-rw-r--r--app-misc/devtodo/devtodo-0.1.18.ebuild57
-rw-r--r--app-misc/devtodo/files/devtodo.bash-completion124
-rw-r--r--app-misc/devtodo/files/digest-devtodo-0.1.181
-rw-r--r--app-misc/devtodo/metadata.xml9
6 files changed, 204 insertions, 2 deletions
diff --git a/app-misc/devtodo/ChangeLog b/app-misc/devtodo/ChangeLog
index ebc2d00fd8fc..c7803f53474e 100644
--- a/app-misc/devtodo/ChangeLog
+++ b/app-misc/devtodo/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-misc/devtodo
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/devtodo/ChangeLog,v 1.16 2004/08/21 23:26:06 kloeri Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/devtodo/ChangeLog,v 1.17 2004/09/11 15:31:51 ka0ttic Exp $
+
+*devtodo-0.1.18 (10 Sep 2004)
+
+ 10 Sep 2004; Aaron Walker <ka0ttic@gentoo.org> +metadata.xml,
+ +files/devtodo.bash-completion, +devtodo-0.1.18.ebuild:
+ Version bump; upstream fixes for bugs 35449, 60206, and 60207. Also added
+ bash-completion script (please test)
*devtodo-0.1.17-r2 (22 Aug 2004)
diff --git a/app-misc/devtodo/Manifest b/app-misc/devtodo/Manifest
index b263686e2cb1..3afc93cdff53 100644
--- a/app-misc/devtodo/Manifest
+++ b/app-misc/devtodo/Manifest
@@ -1,11 +1,15 @@
MD5 26f617dc1d0fe0d93ca6c5454807b01a devtodo-0.1.17-r1.ebuild 1413
+MD5 6d18583cddc104e533e6d07ecbe4a22f devtodo-0.1.18.ebuild 1615
MD5 708bc8d1cf20e92b71d189b71d12b641 devtodo-0.1.17.ebuild 939
MD5 ca08010dc7c4cec26d4b8c4481f5b6ef devtodo-0.1.17-r2.ebuild 1530
-MD5 e82698451e7b89bee489bcbc0c9d51f1 ChangeLog 2603
+MD5 355e4e3d9cd1cca47b26b9c13acb9a2f ChangeLog 2873
+MD5 f8d10f350e91f30316ea4e1bd1e76470 metadata.xml 254
MD5 cb4cff0cd869696d1207553de89551c1 files/digest-devtodo-0.1.17 66
+MD5 e254b7fe4623f6fb5dfb4c9169e75ef7 files/digest-devtodo-0.1.18 66
MD5 cb4cff0cd869696d1207553de89551c1 files/digest-devtodo-0.1.17-r1 66
MD5 cb4cff0cd869696d1207553de89551c1 files/digest-devtodo-0.1.17-r2 66
MD5 404d78d738ead3b99865b3f9cb33177d files/devtodo-fix-TERM-sigabrt.patch 758
MD5 68c51e9b769e87f037a34aa64bbc911f files/devtodo-fix-cd-builtin.patch 303
+MD5 2f6f41259976609db78b40c59b9131f0 files/devtodo.bash-completion 3070
MD5 48d3c0943acaae812475061a16fe6eb9 files/devtodo.patch 2359
MD5 3d389c27b4ba6ade4412c088cefe6f46 files/devtodo-1.1.17-notdl.patch 1985
diff --git a/app-misc/devtodo/devtodo-0.1.18.ebuild b/app-misc/devtodo/devtodo-0.1.18.ebuild
new file mode 100644
index 000000000000..1a00a101826e
--- /dev/null
+++ b/app-misc/devtodo/devtodo-0.1.18.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/devtodo/devtodo-0.1.18.ebuild,v 1.1 2004/09/11 15:31:51 ka0ttic Exp $
+
+inherit eutils gnuconfig
+
+DESCRIPTION="A nice command line todo list for developers"
+HOMEPAGE="http://swapoff.org/DevTodo"
+SRC_URI="http://swapoff.org/files/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~mips ~alpha ~hppa ~amd64 ~ia64 ~s390"
+IUSE=""
+
+RDEPEND=">=sys-libs/ncurses-5.2 >=sys-libs/readline-4.1"
+DEPEND="${RDEPEND} sys-devel/automake"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ # bug #55371
+ epatch ${FILESDIR}/${PN}-1.1.17-notdl.patch
+
+ gnuconfig_update
+}
+
+src_compile() {
+ automake
+ econf --sysconfdir=/etc/devtodo || die
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ dodoc AUTHORS ChangeLog QuickStart README TODO doc/scripts.sh \
+ doc/scripts.tcsh doc/todorc.example contrib/tdrec
+
+ insinto /usr/share/bash-completion
+ newins ${FILESDIR}/${PN}.bash-completion ${PN}
+}
+
+pkg_postinst() {
+ echo
+ einfo "Because of a conflict with app-misc/tdl, the tdl symbolic link"
+ einfo "and manual page have been removed."
+ einfo "If you upgraded from a previous version, you may have to manually"
+ einfo "remove the symbolic links:"
+ einfo " /usr/bin/tdl -> /usr/bin/devtodo"
+ einfo " /usr/share/man/man1/tdl.1.gz -> /usr/share/man/man1/devtodo.1.gz"
+ echo
+ einfo "To enable command-line completion for devtodo, issue the following"
+ einfo "command as root:"
+ einfo " ln -s /usr/share/bash-completion/devtodo /etc/bash_completion.d/"
+ echo
+}
diff --git a/app-misc/devtodo/files/devtodo.bash-completion b/app-misc/devtodo/files/devtodo.bash-completion
new file mode 100644
index 000000000000..7170c2205fcc
--- /dev/null
+++ b/app-misc/devtodo/files/devtodo.bash-completion
@@ -0,0 +1,124 @@
+# bash-completion script for devtodo
+# place this in /etc/bash_completion.d
+
+_devtodo() {
+ local cur prev
+ COMPREPLY=()
+ cur="${COMP_WORDS[COMP_CWORD]}"
+ prev="${COMP_WORDS[COMP_CWORD-1]}"
+
+ if [[ "${cur}" == -* ]] || [[ ${COMP_CWORD} -eq 1 ]]; then
+ COMPREPLY=($(compgen -W "-v --verbose -a --add -g --graft \
+ -l --link -R --reparent -p --priority -e --edit --remove \
+ -d --done -D --not-done --global-database -G --global --database \
+ -T --TODO -A --all -f --filter --colour --force-colour --mono \
+ --help --version --title --date-format --format --use-format \
+ --sort --paranoid --database-loaders --backup -s --summary \
+ --timeout" -- "${cur}"))
+ fi
+
+ case "${prev}" in
+ -p|--priority)
+ COMPREPLY=($(compgen -W "default veryhigh high medium low \
+ verylow" -- "${cur}"))
+ ;;
+
+ --database-loaders)
+ COMPREPLY=($(compgen -W "xml binary" -- "${cur}"))
+ ;;
+
+ -l|--link|--*database)
+ COMPREPLY=($(compgen -o filenames -A file -- "${cur}"))
+ ;;
+ esac
+}
+complete -F _devtodo devtodo
+complete -F _devtodo todo
+
+_tda() {
+ local cur prev
+ COMPREPLY=()
+ cur="${COMP_WORDS[COMP_CWORD]}"
+ prev="${COMP_WORDS[COMP_CWORD-1]}"
+
+ if [[ "${cur}" == -* ]] || [[ ${COMP_CWORD} -eq 1 ]]; then
+ COMPREPLY=($(compgen -W "-v --verbose -g --graft -p --priority \
+ -G --global --global-database --database --mono --help --version" \
+ -- "${cur}"))
+ fi
+
+ case "${prev}" in
+ -p|--priority)
+ COMPREPLY=($(compgen -W "default veryhigh high medium low \
+ verylow" -- "${cur}"))
+ ;;
+
+ --*database)
+ COMPREPLY=($(compgen -o filenames -A file -- "${cur}"))
+ ;;
+ esac
+}
+complete -F _tda tda
+
+_tde() {
+ local cur prev
+ COMPREPLY=()
+ cur="${COMP_WORDS[COMP_CWORD]}"
+ prev="${COMP_WORDS[COMP_CWORD-1]}"
+
+ if [[ "${cur}" == -* ]] || [[ ${COMP_CWORD} -eq 1 ]]; then
+ COMPREPLY=($(compgen -W "-v --verbose -p --priority -G --global \
+ --global-database --database --mono --help --version --title -c \
+ --comment"-- "${cur}"))
+ fi
+
+ case "${prev}" in
+ -p|--priority)
+ COMPREPLY=($(compgen -W "default veryhigh high medium low \
+ verylow" -- "${cur}"))
+ ;;
+
+ --*database)
+ COMPREPLY=($(compgen -o filenames -A file -- "${cur}"))
+ ;;
+ esac
+}
+complete -F _tde tde
+
+_tdr() {
+ local cur prev
+ COMPREPLY=()
+ cur="${COMP_WORDS[COMP_CWORD]}"
+ prev="${COMP_WORDS[COMP_CWORD-1]}"
+
+ if [[ "${cur}" == -* ]] || [[ ${COMP_CWORD} -eq 1 ]]; then
+ COMPREPLY=($(compgen -W "-v --verbose --global-database -G --global \
+ --database --mono --help --version" -- "${cur}"))
+ fi
+
+ case "${prev}" in
+ --*database)
+ COMPREPLY=($(compgen -o filenames -A file -- "${cur}"))
+ ;;
+ esac
+}
+complete -F _tdr tdr
+
+_tdd() {
+ local cur prev
+ COMPREPLY=()
+ cur="${COMP_WORDS[COMP_CWORD]}"
+ prev="${COMP_WORDS[COMP_CWORD-1]}"
+
+ if [[ "${cur}" == -* ]] || [[ ${COMP_CWORD} -eq 1 ]]; then
+ COMPREPLY=($(compgen -W "-v --verbose --global-database -G --global \
+ --database --mono --help --version" -- "${cur}"))
+ fi
+
+ case "${prev}" in
+ --*database)
+ COMPREPLY=($(compgen -o filenames -A file -- "${cur}"))
+ ;;
+ esac
+}
+complete -F _tdd tdd
diff --git a/app-misc/devtodo/files/digest-devtodo-0.1.18 b/app-misc/devtodo/files/digest-devtodo-0.1.18
new file mode 100644
index 000000000000..1e3f25c5d61f
--- /dev/null
+++ b/app-misc/devtodo/files/digest-devtodo-0.1.18
@@ -0,0 +1 @@
+MD5 6ca0a414685cb7a7f32f7ae22cb3a2a9 devtodo-0.1.18.tar.gz 432858
diff --git a/app-misc/devtodo/metadata.xml b/app-misc/devtodo/metadata.xml
new file mode 100644
index 000000000000..d31152aca840
--- /dev/null
+++ b/app-misc/devtodo/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>no-herd</herd>
+ <maintainer>
+ <email>ka0ttic@gentoo.org</email>
+ <name>Aaron Walker</name>
+ </maintainer>
+</pkgmetadata>