summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Koltsov <maksbotan@gentoo.org>2014-04-10 18:05:53 +0000
committerMaxim Koltsov <maksbotan@gentoo.org>2014-04-10 18:05:53 +0000
commit3319ca40a8f9b40259ee5542e66a662340a185b4 (patch)
treef511e0ab6b3f6305f0eabec4aab81b7ea108d6a5 /app-leechcraft/lc-bittorrent/lc-bittorrent-0.6.65.ebuild
parentVersion bump, added support for DNSSEC (Bug #504154). Initial ebuild changes ... (diff)
downloadhistorical-3319ca40a8f9b40259ee5542e66a662340a185b4.tar.gz
historical-3319ca40a8f9b40259ee5542e66a662340a185b4.tar.bz2
historical-3319ca40a8f9b40259ee5542e66a662340a185b4.zip
Bump LeechCraft to 0.5.65, thanks to 0xd34df00d.
Package-Manager: portage-2.2.10/cvs/Linux x86_64 Manifest-Sign-Key: 0xF8DBDADE
Diffstat (limited to 'app-leechcraft/lc-bittorrent/lc-bittorrent-0.6.65.ebuild')
-rw-r--r--app-leechcraft/lc-bittorrent/lc-bittorrent-0.6.65.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/app-leechcraft/lc-bittorrent/lc-bittorrent-0.6.65.ebuild b/app-leechcraft/lc-bittorrent/lc-bittorrent-0.6.65.ebuild
new file mode 100644
index 000000000000..37c1114476ca
--- /dev/null
+++ b/app-leechcraft/lc-bittorrent/lc-bittorrent-0.6.65.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-leechcraft/lc-bittorrent/lc-bittorrent-0.6.65.ebuild,v 1.1 2014/04/10 17:50:55 maksbotan Exp $
+
+EAPI="4"
+
+inherit leechcraft
+
+DESCRIPTION="Full-featured BitTorrent client plugin for LeechCraft."
+
+SLOT="0"
+KEYWORDS=" ~amd64 ~x86"
+IUSE="debug geoip"
+
+DEPEND="~app-leechcraft/lc-core-${PV}
+ net-libs/rb_libtorrent"
+RDEPEND="${DEPEND}
+ virtual/leechcraft-task-show
+ geoip? ( dev-libs/geoip )"
+
+src_configure(){
+ local mycmakeargs="
+ $(cmake-utils_use_enable geoip BITTORRENT_GEOIP)
+ "
+ cmake-utils_src_configure
+}