summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoseph Jezak <josejx@gentoo.org>2006-10-02 04:46:37 +0000
committerJoseph Jezak <josejx@gentoo.org>2006-10-02 04:46:37 +0000
commit65ec3e032e4b724c540aa2be229485f5e879f169 (patch)
treeb2f0426b9c589732b9bb961653522cbe3a40b33b /app-laptop/pbbuttonsd
parentAdd missing autotools versions specification, thanks to Patrick Laurer for re... (diff)
downloadhistorical-65ec3e032e4b724c540aa2be229485f5e879f169.tar.gz
historical-65ec3e032e4b724c540aa2be229485f5e879f169.tar.bz2
historical-65ec3e032e4b724c540aa2be229485f5e879f169.zip
Added the latest version.
Package-Manager: portage-2.1.2_pre2
Diffstat (limited to 'app-laptop/pbbuttonsd')
-rw-r--r--app-laptop/pbbuttonsd/files/digest-pbbuttonsd-0.7.93
-rw-r--r--app-laptop/pbbuttonsd/pbbuttonsd-0.7.9.ebuild81
2 files changed, 84 insertions, 0 deletions
diff --git a/app-laptop/pbbuttonsd/files/digest-pbbuttonsd-0.7.9 b/app-laptop/pbbuttonsd/files/digest-pbbuttonsd-0.7.9
new file mode 100644
index 000000000000..ab719f14abad
--- /dev/null
+++ b/app-laptop/pbbuttonsd/files/digest-pbbuttonsd-0.7.9
@@ -0,0 +1,3 @@
+MD5 3d2447ed7425bd2a9155ca18ebf9d4c9 pbbuttonsd-0.7.9.tar.gz 432995
+RMD160 8570485273c1eb1fae12018f05be6710d349fef6 pbbuttonsd-0.7.9.tar.gz 432995
+SHA256 b27734a305eadf3b5617c235a7165fa7151f9b732bab4e3ddf8b11648a4e929e pbbuttonsd-0.7.9.tar.gz 432995
diff --git a/app-laptop/pbbuttonsd/pbbuttonsd-0.7.9.ebuild b/app-laptop/pbbuttonsd/pbbuttonsd-0.7.9.ebuild
new file mode 100644
index 000000000000..0b78f5b87939
--- /dev/null
+++ b/app-laptop/pbbuttonsd/pbbuttonsd-0.7.9.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-laptop/pbbuttonsd/pbbuttonsd-0.7.9.ebuild,v 1.1 2006/10/02 04:44:10 josejx Exp $
+
+inherit eutils flag-o-matic
+
+DESCRIPTION="Handles power management and special keys on laptops."
+HOMEPAGE="http://pbbuttons.sf.net"
+SRC_URI="mirror://sourceforge/pbbuttons/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~ppc ~ppc64 ~x86"
+IUSE="acpi debug alsa oss ibam"
+
+DEPEND=">=sys-apps/baselayout-1.8.6.12-r1
+ >=dev-libs/glib-2.6"
+RDEPEND="alsa? ( >=media-libs/alsa-lib-1.0 )
+ >=dev-libs/glib-2.6"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ autoconf
+ automake
+}
+
+src_compile() {
+ # Fix crash bug on some systems
+ replace-flags -O? -O1
+
+ if use x86; then
+ if use acpi; then
+ laptop=acpi
+ else
+ laptop=i386
+ fi
+ else
+ laptop=powerbook
+ fi
+
+ econf laptop=$laptop \
+ $(use_with debug) \
+ $(use_with alsa) \
+ $(use_with oss) \
+ $(use_with ibam) \
+ || die "Sorry, failed to configure pbbuttonsd"
+ emake || die "Sorry, failed to compile pbbuttonsd"
+}
+
+src_install() {
+ dodir /etc/power
+ use ibam && dodir /var/lib/ibam
+ make DESTDIR=${D} install || die "failed to install"
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/pbbuttonsd.rc6 pbbuttonsd
+ dodoc README
+}
+
+pkg_postinst() {
+ ewarn "Ensure that the evdev kernel module is loaded otherwise"
+ ewarn "pbbuttonsd won't work."
+ einfo
+ ewarn "If you need extra security, you can tell pbbuttonsd to only accept"
+ ewarn "input from one user. You can set the userallowed option in"
+ ewarn "/etc/pbbuttonsd.conf to limit access."
+ einfo
+
+ if use ppc ; then
+ einfo "It's recommended that you let pbbuttonsd act as the low level"
+ einfo "power manager instead of using pmud."
+ einfo
+ fi
+ if use ibam; then
+ einfo "To properly initialize the IBaM battery database, you will"
+ einfo "need to perform a full discharge/charge cycle. For more"
+ einfo "details, please see the pbbuttonsd man page."
+ einfo
+ fi
+ ewarn "Warning: the NoTapTyping option is unstable, see bug #86768."
+}